Ask / Submit
3

no 'å' in the terminal

asked 2015-04-17 22:24:37 +0200

rbckman gravatar image

updated 2016-08-17 16:38:40 +0200

jiit gravatar image

when in the terminal and I press the 'å' character on the virtual-keyboard I get another character. it's an 'a' with a sad mouth on top instead of a round one. peace!

edit retag flag offensive close delete

Comments

Agree.. å gives â Å gives Â

kimmoli ( 2015-04-18 08:38:44 +0200 )edit
2

This should be fixed in , https://github.com/nemomobile/fingerterm/commit/b628b75fea8db8b12807517dd4723749e9ffdb88

But seems the layout file is not updated during update, ./home/nemo/.config/FingerTerm/finnish.layout says 0xc2 to me.

kimmoli ( 2015-04-18 10:03:01 +0200 )edit

2 Answers

Sort by » oldest newest most voted
4

answered 2015-04-18 10:10:52 +0200

kimmoli gravatar image

updated 2015-04-18 10:28:09 +0200

Delete this file (Fingerterm version >= 1.1.12)

rm ./home/nemo/.config/FingerTerm/finnish.layout

And it will be re-created when terminal is started, and you can stargate again

Older versions, manually edit this file with change described here:

https://github.com/nemomobile/fingerterm/commit/b628b75fea8db8b12807517dd4723749e9ffdb88

(If you mess it up, just delete the file, and it will be respawned on fingerterm start)

edit flag offensive delete publish link more

Comments

It worked!! Thank you Kimmoli!

rbckman ( 2015-04-18 10:14:25 +0200 )edit

No, wait.. I need to change the config file. ./home/nemo/.config/FingerTerm/finnish.layout 'å' needs to be 0xc5 not 0xc2. If I remove the config file I'm back to the sad mouth 'â'

rbckman ( 2015-04-18 10:21:03 +0200 )edit
1

eh. depends what is your fingerterm version. That is fixed from 1.1.12 and upwards

kimmoli ( 2015-04-18 10:22:14 +0200 )edit

aight, I got an old version. Good it's fixed in the new version.

rbckman ( 2015-04-18 10:34:00 +0200 )edit
0

answered 2015-04-18 11:27:01 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2015-04-18 11:32:27 +0200

eson gravatar image

Just to straighten things up... ;)

Someone who wants Swedish keyboard layout? Copy finnish.layout, rename it swedish.layout and fix the above "å" error.

Then edit the ./home/nemo/.config/FingerTerm/settings.ini.

Line 38 should be keyboardLayout=swedish.

...Or you could just use the Finnish layout. ;)

edit flag offensive delete publish link more

Comments

... it should be å also in finnish layout, not â

kimmoli ( 2015-04-18 15:08:40 +0200 )edit

@kimmoli - Of course! I forgot to tell.

eson ( 2015-04-18 15:41:26 +0200 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2015-04-17 22:24:37 +0200

Seen: 199 times

Last updated: Apr 18 '15