Ask / Submit
5

alarm ringtone not changeable

asked 2015-04-18 08:56:58 +0300

pillenpepi gravatar image

updated 2015-04-18 12:23:18 +0300

morning everyone! my alarm ringtone cannot be changed. instead of the chosen alarm ringtone, i always hear the standard tone. update to 1.1.4 did not change anything. tried 2 android alarms too - those were not working. thanks in advance for any help/ideas.

edit retag flag offensive close delete

Comments

Try changing ambience?

kuzeyron ( 2015-04-19 10:43:55 +0300 )edit

It does not help. Changing the default sound in Settings or in ambience dies not work. Alarm sound is always the same. This must be hard coded some place. I don't expect any changes in following updates...

rannari ( 2015-04-20 00:11:23 +0300 )edit

That's bad and sad!

kuzeyron ( 2015-04-20 08:57:28 +0300 )edit

I cannot confirm this on 1.1.7.28. Works fine here. Changed alarm ringtone in ambience, and it is used.

Holger ( 2015-09-20 22:59:56 +0300 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2015-04-19 13:27:38 +0300

llg179 gravatar image

Hi! I have 1.1.2.16 sailfish os version and I use Clock sailfish app to set an alarm, Calendar sailfish app to set an event. Ringtones can be set under Gallery / Ambience / Clock & Calendar. When I changed the clock's sound it accepted that. When I changed the calendar's sound then calendar did not play sound at all. Calendar's setting: remind me at time of event. Reverting to the original sound file did not help either: no sound was played. Then calendar app crashed. Then original sound was played again (I used utilities / stop android support too however that might be irrelevant). Then I changed the ambiance's calendar sound and it was used. Maybe when ambiance or calendar is being edited when calendar fires causes the problem?

edit flag offensive delete publish link more
1

answered 2015-06-28 11:59:11 +0300

irrep gravatar image

This is not a solution, but a workaround. It works until the GUI settings actually change anything.

I have used the developer mode and root access to replace the file /usr/share/sounds/jolla-ringtones/stereo/jolla-alarm.wav with the alarm sound that I want to have. Now it plays my sound.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2015-04-18 08:56:58 +0300

Seen: 441 times

Last updated: Jun 28 '15