Ask / Submit
21

[bug] Calendar duplicates on every sync [released]

asked 2015-04-19 23:01:16 +0300

paulvt gravatar image

updated 2015-05-07 22:34:43 +0300

heubergen gravatar image

It seems that every time my CalDAV account is synced, I get a duplicate calendar of each enabled calendar of that account. I noticed this when I opened Manage Calendars list in the Calendar app and found it out to be huge (over 100 calendars). Also, most of them are white coloured, but some have the colour of the calendar on the server (?). I am pretty sure this started with 1.1.4.28 (Äijänpäivänjärvi). It also doesn't matter if one or both of my calendars are enabled for the server, nor does it seem to matter whether the server is ownCloud or DAViCal.

When I remove the accounts, most of them are gone, but I few duplicates remain that always have been there, so maybe all this is due to a mess in the database?

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by VDVsx
close date 2015-05-06 09:51:54.026754

Comments

1

I deleted my previous comment as I was about to close this instead of https://together.jolla.com/question/90352/bug-owncloud-calendars-duplicated-several-times/

Sorry :P

Tanghus ( 2015-04-20 18:11:16 +0300 )edit

" I am pretty sure this started with 1.1.4.28 (Äijänpäivänjärvi)." No I had that on the last version either - after a few days I had several duplicates of every calendar - that was why I switched to eas (lucky me - my provider gives me the option to choose between EAS and IMAP/CalDAV) -

elastic ( 2015-04-20 23:41:31 +0300 )edit

@elastic Agreed, I had a few duplicates before (some which are still left after deleting accounts), but now I'm getting more every sync!

paulvt ( 2015-04-21 00:01:58 +0300 )edit
1

Same here calendar started duplicating each sync. Ended up with 800 calendars and calendar app not working anymore.

Sailor ( 2015-04-22 09:29:37 +0300 )edit

2 Answers

Sort by » oldest newest most voted
3

answered 2015-04-28 19:22:17 +0300

paulvt gravatar image

This seems to have been fixed in 1.1.4.29. See also the updated release history: https://together.jolla.com/question/89804/release-notes-114-aijanpaivanjarvi-early-access/#89804-upgrade-version-history

edit flag offensive delete publish link more

Comments

Great!!!!!

Sailor ( 2015-04-28 21:05:58 +0300 )edit

I do not have any problem any longer with my CalDAV calendar account.

jukey ( 2015-04-30 21:30:16 +0300 )edit
1

I still have issues with the latest early access update (1.1.4.29). I do not have doubled accounts or calendars, but doubled events. After first sync everything was fine. After subsequent syncs each event is there twice. They don't become more with each sync but it stays that way: Every event is there two times. Has anyone the same issue?

Yo ( 2015-05-01 15:51:26 +0300 )edit

I wonder if a "stale" calendar (notebook in mkcal terminology) which contained one copy of the events was somehow created during first sync, then "left behind" as it were? Can you do:

$ devel-su -p sqlite3 /home/nemo/.local/share/system/privileged/Calendar/mkcal/db "select * from calendars;"

Thanks, Chris.

chris.adams ( 2015-05-06 04:51:44 +0300 )edit
2

answered 2015-04-21 00:22:36 +0300

silta gravatar image

Today I had the same problem under 1.1.2.16.

At first I determined an empty field in account settings under "calendar". After syncronizing manually the entry in calendar app was doubled. After an additional sync it was tripled.

I deleted the account in account settings and recreated it with no effect. The next I deleted the account once more and deinstalled calendar app, rebooted, reinstalled app from store and found still one calendar from formerly three.

The only way I found to remove this entry was to deinstall app and delete all files under /home/nemo/.local/share/system/privileged/Calendar/mkcal and /home/nemo/.local/share/system/privileged/Calendars/. After reinstalling calendar app no calendar was shown (except the local one). Than I recreated the account, synced and all was perfect, except the fact that I found after syncing an offset of +1 hour (local Helsinki time from my point of view) in every event on phone, not on server. But this is an old fat bug and the only way to solve is to edit every single event on phone.

Maybe this "broken account settings" are the reason of the lots of calendars. If so it would recommend to check settings before syncing.

I know, it´s not removing the bug, but I hope it can help you to "clean" your database.

NOTE: before deleting files it is strongly recommend to backup them.

edit flag offensive delete publish link more

Comments

I have seen this post before too: https://together.jolla.com/question/67034/howto-reset-user-databases/. That might fix it for me, were it not for being looked out of root access for reasons too complicated to explain here. It should be possible to remove calendars too, I have seen several posts about this

paulvt ( 2015-04-21 00:39:07 +0300 )edit

Have a look at https://together.jolla.com/question/90577/calendar-events-not-showing-and-usrbintimed-qt5-systemd-running-at-100/ to help Jolla to track down the issue.

Sailor ( 2015-04-22 11:55:55 +0300 )edit

I cannot, becase as I said, I can no longer use devel-su, but hopefully others can provide this.

paulvt ( 2015-04-22 19:22:34 +0300 )edit

@Sailor Since my answer above I can´t observe this bug no more. If it´s coming back, I´ll collect logs. Thanks for your hint.

silta ( 2015-04-23 14:50:31 +0300 )edit

Question tools

Follow
8 followers

Stats

Asked: 2015-04-19 23:01:16 +0300

Seen: 877 times

Last updated: May 07 '15