Ask / Submit
13

bug: imap idle/push of some email service providers does not work with generic imap account

Tracked by Jolla (In release)

asked 2015-05-05 13:03:10 +0300

Jolly-Jo gravatar image

updated 2016-12-01 13:37:19 +0300

ApB gravatar image

Steps to reproduce:

  1. Installed 1.1.4.29 today
  2. Changed the update type of my existing imap account to "Always up-to-date"
  3. Sent myself a test-mail, and using browser I made sure I have connectivity on the phone
  4. Never got it (waited 5+ minutes)
  5. Synced manually
  6. Got the mail
  7. Deleted mail account
  8. Re-created mail account, was not offered the 'always up-to-date' option during account creation
  9. Changed the update type of the account to "Always up-to-date" after account creation
  10. Sent myself a test-mail, and using browser I made sure I have connectivity on the phone
  11. Never got it (waited 5+ minutes)
  12. Synced manually
  13. Got the mail

I'm on Fastmail, and imap idle works like a charm in android (k9).

Edit#2 : 2.0.2.51 This still doesn't seem to work as it should. Anyone from jolla can comment?

edit retag flag offensive close delete

Comments

And to me with a google account seems a bit flaky. Ie. i deleted a mail from my spam folder and it was still present on the phone until i updated.

Also i had mails not show up immediately and appeared after i disconnected and reconnected on the wlan.

ApB ( 2015-05-05 13:49:52 +0300 )edit
1

@ApB - Ping is only in inbox so that's expected, network issue was seen recently when device switches from WLAN/mobile but seems to be in network layers.

@Jolly-Jo - will investigate once I get an account on that service.

VDVsx ( 2015-05-06 10:04:05 +0300 )edit
1

@Jolly-Jo - Look like they dont allow imap for trial accounts ("NO Sorry, trial accounts are not permitted to use the 'imap' server. Please login to the web interface for more details "), so you need to collect logs for me.

Enable logging, in:

/home/nemo/.config/QtProject/Messageserver.conf

enable file log and add a path for the log, like for example:

[FileLog]
Enabled=1
Path=/home/nemo/Documents/messageserver.log

Then restart the device or just restart messageserver5

systemctl --user stop messageserver5
systemctl --user start messageserver5

Recreate the account again, make sure "Always-on" is enabled and connected(check status in email app), send some emails to account, send me the log file to mail-logs at jolla dot com. After that turn file log off again by setting "enabled" to 0.Thanks a lot!

VDVsx ( 2015-05-06 10:18:38 +0300 )edit

@VDVsx sent the logs. They stayed totally quiet after the messageserver start. Nothing happened when I had sent the mails. Only when I restarted messageserver again, it would pick up the mails through its initial sync.

Btw, since I am not offered the 'always up-to-date' option during account creation, I would have to re-create the account and after that change the option to 'always up-to-date'. So I saved myself the trouble and only changed the option (I did re-create the account yesterday after the update). I did make sure the mail app was displaying 'up-to-date'.

Jolly-Jo ( 2015-05-06 11:01:44 +0300 )edit

@VDVsx OK thanks. At least could you make it sync all the folders when you start the main app (tap email).

ApB ( 2015-05-06 11:16:48 +0300 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2016-01-13 16:20:14 +0300

ApB gravatar image

Could someone experiencing this bug answer something.

Is your router IPv4 only or you have also IPv6 enabled?

edit flag offensive delete publish link more

Comments

For me the bug appeared only with the 2.0.1.7 update ... - I'm on 3G only so no wifi no router ...

elastic ( 2016-01-21 13:24:26 +0300 )edit
0

answered 2016-05-11 19:39:48 +0300

JoHe gravatar image

This feature "Always up-to-date" (idle/push) has always worked when using Yandex.Mail! So, the title of this question has to be modified.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
7 followers

Stats

Asked: 2015-05-05 13:03:10 +0300

Seen: 1,027 times

Last updated: Dec 01 '16