Ask / Submit
4

Email showing text twice (text/plain and text/html) [released]

asked 2014-01-03 15:32:51 +0300

axaq gravatar image

updated 2014-02-02 01:34:57 +0300

I received a short mail (3 lines) from a Windows Phone. The text is shown in Jolla-Mail app twice with different font sizes. I assume one is the plain text and the other the html text.

When answering the mail only one text is quoted.

The mail contained following parts:

Content-Type: multipart/alternative;
...
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain; charset="Windows-1252"
... plain text ...
Content-Transfer-Encoding: quoted-printable
Content-Type: text/html; charset="Windows-1252"
... html text ...
Content-Type: image/jpeg; name="WP_xxxxxxxx_001.jpg"
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename="WP_xxxxxxxx_001.jpg"

Kmail or the N9 mail app doing it right and show only one text part.

Edit: Also short mails received from Thunderbird/Windows are shown twice (found in 1.0.2.5 and still in 1.0.3.8).

Content-Type: multipart/alternative;
...
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 7bit
... plain text ...
Content-Type: multipart/related;
...
Content-Type: text/html; charset=ISO-8859-15
Content-Transfer-Encoding: 7bit
... html text ...
Content-Type: image/jpeg;
 name="703_0.jpg"
Content-Transfer-Encoding: base64
Content-Disposition: inline;
 filename="703_0.jpg"

Edit: The text from a short mail from N900 with image attachement is shown twice.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by VDVsx
close date 2014-06-09 20:46:13.541801

Comments

I would like to be able to define in settings whether to show text/plain or text/html when both are available.

Penguin ( 2014-01-13 00:44:23 +0300 )edit

@Penguin: I suggest to create a new request/question if that not already exists.

axaq ( 2014-01-21 02:25:47 +0300 )edit

I also have this issue.

jliebe ( 2014-02-07 12:03:29 +0300 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2014-06-09 20:46:03 +0300

VDVsx gravatar image

Fixed in 1.0.7.16, Saapunki, if you still have issues please comment here.

edit flag offensive delete publish link more

Comments

Seems to be fixed. No problems so far. Thanks.

axaq ( 2014-06-14 19:04:49 +0300 )edit

Question tools

Follow
2 followers

Stats

Asked: 2014-01-03 15:32:51 +0300

Seen: 393 times

Last updated: Jun 09 '14