[Bug] e-mail app does not open attachments on ActiveSync accounts

asked 2014-01-03 15:34:15 +0300

dazo gravatar image

updated 2019-08-01 12:24:12 +0300

When clicking on attachments in the e-mail apps on ActiveSync accounts, it downloads it and then nothing happens. When restarting the e-mail app, the attachments is listed as "text/plain" and trying to re-open them just turns up with a "failed" message.

This has happened for me on both xlsx and pdf attachments. Pictures sometimes works.

(This is testet against Zimbra NE and OSE+zextras servers, both v8.0.6)


I still have this issue with 2 accounts:

one is a real exchange account (exchange server), the other one is mailbox.org which allows for activesync. I struggle to open attachements all the time. No matter if it is png or jpeg or pdf attachements.

edit retag flag offensive close delete

Comments

Are you able to collect logs ?

enable logging, in:

/home/nemo/.config/Nokia/activesync.conf

Enable file log and add a path for the log, like for example:

[FileLog]
Enabled=1
Path=/home/nemo/Documents/as.log

Reboot the device and then reproduce the problem, send me the logs to vdvtest100 at gmail dot com. After that turn file log off again by setting "enabled" to 0.Thanks a lot!

VDVsx ( 2014-01-28 13:17:14 +0300 )edit

I'm sorry I didn't respond earlier. I've updated to 1.0.3.8 in the mean time, and I've not had this issue since then. So I'm not able to reproduce it.

Having that said, it would give me more comfort if such debug logs where sent to official jolla.com e-mail addresses. Anyone can create a gmail.com account looking close enough to make people believe it's a jolla developer.

dazo ( 2014-02-05 14:04:56 +0300 )edit

@dazo - fair enough, one was recently created for that: mail-logs at jolla dot com

But if you can't reproduce the issue no need to send the logs. Thanks!

VDVsx ( 2014-02-05 17:39:37 +0300 )edit

Have this issue with my ActiveSync account, too. Also with mailbox.org and Open X-Change as the backend. Haven't been able to download any attachment since I got my Jolla in march...! :-( Not using the latest developer update Björnträsket, but the latest end user version currently available.

Alex-S ( 2015-07-23 10:52:07 +0300 )edit
1

Still present in 3.1.X, no way to download and open any attachment. ActiveSync is almost useless (search also doesn't provide consistent results). Switching again to IMAP.

mailbox.org account (Open X-Change) on XA2 Plus.

magullo ( 2019-08-01 12:23:21 +0300 )edit