Ask / Submit
5

Screen freezes - cannot terminate phone call's [duplicate]

asked 2015-06-05 21:29:55 +0200

Dries Van Giel gravatar image

updated 2015-06-06 01:24:57 +0200

chemist gravatar image

My Jolla becomes unresponsive in a lot of situations when handeling call's:

  • Frequently I cannot answer incoming calls, the phone keeps ringing and does not react on anything I try. Restart needed.
  • I cannot terminate phone calls, the screen is frozen. I am lucky enough that the person on the other side terminates the call before I try anything, the phone recovers. In the other case I have to restart my phone.

To be honest calling is about the only thing I do with my Jolla, so I am not sure it only happens when calling. But when I call I get in trouble.

I have version 1.1.4.29 but the problem also accurred in the previous version.

edit retag flag offensive reopen delete

The question has been closed for the following reason "duplicate question" by Edz
close date 2015-06-05 21:54:28.790970

Comments

same problems :-(

peter-berlin ( 2015-06-05 21:41:44 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-06-05 21:44:40 +0200

Edz gravatar image

updated 2015-06-05 21:54:14 +0200

There seems to be a spate of this going on recently and really, your question is a duplicate,of https://together.jolla.com/question/91141/incoming-call-cannot-answer/ despite slightly different symptoms, your problem I think, is the same, so I'm closing your question.

Run this following command in Terminal and this should fix your problem. Open Terminal and type in pkcon install voicecall-ui-jolla once done, it may be best to reboot the phone and then see if it happens again.

Regards,

edit flag offensive delete publish link more

Comments

Thx!

It says: - Installing - Waiting in que - Starting - ... (a lot of other things)
- Installing - Waiting in qeue - Waiting for authentication - Fatal error: Failed to obtain authentication

-> is that a problem?

Dries Van Giel ( 2015-06-05 21:56:13 +0200 )edit

@Dries Van Giel - perhaps devel-su and password is required, generally I've found I don;t need to devel-su (that's got me thinking!) :)

Edz ( 2015-06-05 21:57:13 +0200 )edit

thx a lot but I have no idea what password I have to type. I am a designer and a terminal is my personal horror. I'll try to look it up.

Dries Van Giel ( 2015-06-05 22:03:43 +0200 )edit
1

It worked! I even managed to do all of this trough the terminal in my mac. https://together.jolla.com/question/30565/howto-using-su-instead-of-devel-su/

I hope it's solved, I'll test it for a few days and will closed this ticket if it works.

Dries Van Giel ( 2015-06-05 22:12:49 +0200 )edit

I'm a glazier by trade, but learning a little about terminal is really essential for using Jolla (Sailfish) in my mind.

Anyway, okay, well, enable developer mode and also remote connection, either type in your own password, just pick one, you are setting the password, when done, hit save. The in Terminal, type the command I gave earlier.

Edz ( 2015-06-05 22:20:51 +0200 )edit

Question tools

Follow
2 followers

Stats

Asked: 2015-06-05 21:29:55 +0200

Seen: 312 times

Last updated: Jun 05 '15