Ask / Submit
98

[release notes] 1.1.6/Aaslakkajärvi [released]

asked 2015-06-08 12:11:52 +0300

bijjal gravatar image

updated 2016-09-01 11:27:09 +0300

jovirkku gravatar image

Update: We'll start rolling out this release to everyone today (15.6).

Please ensure that you have ~1.5GB of free disk space and connect your Jolla to a charger before attempting to upgrade your Jolla. If connected to the internet, and your account is subscribed for early access releases, your Jolla should receive an OS update notification shortly.

As usual,

  • If you use phonehook from OpenRepos, uninstall it before upgrading.
  • If you use patchmanager, revert all applied patches before upgrading.
  • If your device is running software version lower than 1.0.4.20 and have WareHouse app installed (i.e you are using OpenRepos), disable all openrepo repositories before attempting to upgrade your device.
  • Take a backup of your data before attempting to upgrade your device. A successful backup operation is indicated by a green dot in the UI.
  • Do not reboot the device while the update is in progress.
  • The device screen may blank out during the update process, you may waken the display by a short press on the power key to monitor the progress.

For detailed instructions on updating software, visit Zendesk.

Highlights

  • Search emails by keyword via the pulldown menu in Mail app
  • Ability to select and mark multiple emails as read/unread
  • Private browsing mode in Browser
  • Detailed new on memory (disk) usage usage via Settings > System > 'About Product' page (tap on the Memory usage info circle)
  • Import calendar entries (.vcs, .ical) transferred to your phone via Settings > System > Transfers to Calendar app
  • Option to send read receipts to senders of MMS messages (Settings > Apps > Messages)
  • Show notification if an email attachment cannot be opened
  • View phone number of a contact in the call log via tap-and-hold on the call log entry.
  • Notification on file system getting full in Events view indicating that some data should be moved out from the phone memory
  • Voicemail notifications UI - availability differs depending on countries and operators
  • Reset MMS settings to default values from the pulley menu in Settings > System > Mobile network > MMS access point page
  • Better OS upgrade handling
    • OS upgrade notifications update automatically in case there is a newer OS version available
    • Filesystem optimizations prior to installing OS upgrades. This will be effective from the next upgrade onwards.
  • We've recently received approval from Facebook on our new implementation. The account should now work after a re-login.
    • Currently working: calendar sync, feeds and notifications, photo album sync to gallery, share image from gallery app to facebook.
    • Not working: contacts sync and chat (caused by the loss of features in API 2.2, see end of this email for details)

Security fixes

Upgrade version history

  • 1.1.6.27 (8.6.2015): Initial early access release

Known issues

  • If you have phonehook from OpenRepos installed uninstall it before upgrading.
  • Currently, checks on available disk space happens very late during the OS upgrade process and will fail in the installation phase if the disk space is low. Normally there should be an error note asking you to free some disk space and try again, but in some marginal cases it might not be shown. Should this happen, free some disk space and try to install the OS update again.
  • OS update may fail due to some other reasons too, for example it may have installed some packages from the new release and still have something left from the old. If the device can boot up, you can try to recover by doing the following. If not, you can attempt to recover the device using the recovery mode.
    • Delete the file /home/nemo/.cache/store-client/os-info
    • Stop the store-client process (for e.g. pkill store-client)
    • Reopen Settings app, check for updates again and attempt to install the OS update again
  • We have also noted that if the OS update is attempted while there is long queue of installation of apps from the Store, the system may end up in mixed state (for e.g. select all the apps from startup wizard, and start the system update already while the apps are being installed).
    • In such cases, the OS update appears to be stalled, however it is just waiting for the installations to complete before attempting to upgrade the OS. Just wait patiently, the worst thing to do here is to reboot the device!

Changelog

The full changelog is available in this separate post.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by r0kk3rz
close date 2015-09-14 13:45:59.565938

Comments

Thank you, Bijjal :)

Downloading 1.1.6.27 as I type this message.

Exciting! :D

fmotl ( 2015-06-08 12:22:05 +0300 )edit
2

there is a lot's of nice things in this one! great!

cemoi71 ( 2015-06-08 12:29:52 +0300 )edit

I lost some contacts..Investigating... Thanks for the update!

lispy ( 2015-06-08 12:48:53 +0300 )edit
4

I did a Cardav resync with owncloud and now it seems to work again. Had to relink some contacts, tough.

lispy ( 2015-06-08 12:52:09 +0300 )edit
18

Highlights missing Flattr support in Store which is in the Changelog. I'd consider that a fairly big highlight and worth mentioning to non-developers

r0kk3rz ( 2015-06-08 12:55:50 +0300 )edit

23 Answers

Sort by » oldest newest most voted
8

answered 2015-06-08 14:03:26 +0300

DeepPurple15x gravatar image

updated 2015-06-08 15:27:45 +0300

Having to uninstall patchmanager and phonehook again and again is not a good idea. Please consider a feature like 'Factory Reset' that prepares your phone for the next update.

Edit: Number of patches are going to continue to increase. Also more and more apps are being added to warehouse and they are usually pretty good. Uninstalling apps/patches with every new update is not going to get easier. Mistakes will happen. Dont you think we should prepare for this eventuality

edit flag offensive delete publish link more

Comments

47

I don't think Jolla is responsible for being compatible with any third-party patches. I think it's enough to warn and say deactivate it.

Sailor ( 2015-06-08 14:06:23 +0300 )edit
18

These things are not allowed in Harbour for a reason. If you have enabled Developer Mode you are assumed to take a certain amount of responsibility for what happens to your device, including micromanaging anything that is known to cause issues with the upgrade process.

r0kk3rz ( 2015-06-08 14:30:53 +0300 )edit
23

@Sailor Considering how wildly successful many of these patches are - maybe Jolla should just accept them "upstream" (even as an default-off optional feature) so that people don't need to use Patch Manager to install them ? ;-)

That would also kinda fit the #unlike (we aren't like Apple, dictating to users how the UI should look like), co-creation, together, etc. spirit.

MartinK ( 2015-06-08 14:56:09 +0300 )edit
3

@MartinK you mean like adding in a voicemail notification (this release) and having lock screen media controls (on roadmap)?

r0kk3rz ( 2015-06-08 15:00:03 +0300 )edit
3

@r0kk3rz Yeah, that's definitely a step in the right direction. :)

MartinK ( 2015-06-08 16:41:26 +0300 )edit
6

answered 2015-06-16 23:13:38 +0300

chemist gravatar image

Please stop bug-reporting within release notes (early access or not) - start a new question about your issue please. Tag bug #version $item

edit flag offensive delete publish link more

Comments

This is a bug within us, not an answer ;) Well, good to inform here as well of course, but maybe adding a link to the "bug" report: https://together.jolla.com/question/95883/bug-reports-posted-as-answers/

simo ( 2015-06-23 20:04:44 +0300 )edit

i agree with chemist, the "bug-reporting within release notes" is pretty awful for a good structured overview.

cemoi71 ( 2015-07-20 11:04:42 +0300 )edit
5

answered 2015-06-08 18:58:01 +0300

Slawek gravatar image

Private browsing mode needs to be changed to standard mode - closing applications is not enough. I think, closing browser should change it automatically to standard mode.

edit flag offensive delete publish link more
2

answered 2015-06-09 19:35:36 +0300

vishal gravatar image

updated 2015-06-09 19:37:26 +0300

After update i found some issues regarding notifications. Before the update whatsup notifications shows icon and led with different colours. but after update(1.1.6.27) it shows old version symbol and led sometime shows sometime won't.Screenshot-08-06-15-12-00-33.png Screenshot-09-06-15-20-01-02.png

edit flag offensive delete publish link more

Comments

1

You should report it to the developer of watsup...

drummer12 ( 2015-06-09 19:44:56 +0300 )edit
2

same problem, not just with whatsup, with native transfers too(receive file via bt, browser downloads,...)

nightmare ( 2015-06-09 21:18:42 +0300 )edit

ya it's correct i should report it to developer of whatsup. but i used hike chat app after OS update from 1.1.2 to 1.1.4 notification icon changed(didn't updated the hike app). It means not only the app should be updated there is some issue with system software too.

vishal ( 2015-06-10 04:29:23 +0300 )edit
1

Cepi (the dev of watsup), says its an issue from sailfish.

Thaodan ( 2015-06-10 14:34:13 +0300 )edit

Thanks at least we found the issue is from which side. This answer help sailfish developer team to fix the issue.

vishal ( 2015-06-10 16:37:25 +0300 )edit
2

answered 2015-06-16 21:53:42 +0300

jkhlam gravatar image

updated 2015-06-18 20:43:14 +0300

Anyone else have the problem that music played with the standard media player is like 1.2 times too fast? It's not like "chipmunks" fast but it's definitely halfway there and very noticeable.

Update: I did a comparison between 60 secs from a clock and the amount of seconds played, it's about 64, so it's more like 1,067 times too fast. Also, it's not limited to the standard player, other sailfish and android players have the same issue. It's just me or noone uses Jolla for music?

edit flag offensive delete publish link more

Comments

Tried a song with it and didn't notice anything different.

Start a new thread with it and others might chime in.

ApB ( 2015-06-18 20:57:22 +0300 )edit

just did a test with my laptop playing the same file in unison. seems fine. I'm not using the Jolla-medaplayer though.

r0kk3rz ( 2015-06-18 21:21:23 +0300 )edit

I do have this problem when streaming music from Jolla, via bluetooth to my laptop (laptop connected to an amp/speakers), but I'm having problems with bluetooth in general on my laptop, so I can't say which is in error, I have a feeling it's the bluetooth on the laptop.

fmotl ( 2015-06-18 23:25:15 +0300 )edit

Markkyboy! That's it! All this time I've been using my Bluetooth headset to test things. Listen without Bluetooth and it's back to normal... Immediately went to the complete changelog to search for changes in Bluetooth implementation. Couldn't find anything directly useful, but the "[bluetooth] Use BluetoothPairingManager to handle pairing process" kinda seemed interesting. Unpaired the headset, repaired and presto, problem gone. However, after switching the power on the headset on and off, the problem is back. I guess I'll have to unpair-repair it everytime until it gets fixed...

jkhlam ( 2015-06-19 00:05:20 +0300 )edit

Interestingly, 48 kHz / 44.1 kHz ≃ 1.088… might it be the issue?

Is the problem still present with files using a sample rate of 48 kHz?

sami.boukortt ( 2015-06-24 02:03:44 +0300 )edit
1

answered 2015-06-10 07:48:59 +0300

Trizt gravatar image

Media on SDCard ain't indexed (not since 1.1.4) tracker-control -es do not help.

edit flag offensive delete publish link more

Comments

tracker-search -i got my pictures back to gallery.

jarnose ( 2015-06-10 09:36:27 +0300 )edit

Do not make any difference for me, it's just looking on the local storage, not sdcard.

Trizt ( 2015-06-12 22:25:17 +0300 )edit

When i updated as early access i didnt get this feature, later yesterday i have done reset jolla. Then updated os again now it sync every media from sdcard and can be seen in gallery.

vishal ( 2015-06-17 10:21:09 +0300 )edit
1

answered 2015-06-15 09:13:03 +0300

pan tau gravatar image

updated 2015-07-20 10:31:54 +0300

after uptade: Messages are now closed completely after swipe to close, every next launch of messages takes ages and mostly starting app cover disapear - and after moments app appear on screan, this is similar startup time to first launch after phone boot ( appcover of starting messages disapearing noticed after 1.1.4 but the loadtime is related to my growing messages size, i never deleted any message since first Symbian, so i wont change my habbit)

until this update it was acceptable to wait until all messages are fetched from storage (thousands of sms / im ) for the first start, right after phone boot , then next openning of messages after closing app was fast.

now i should not close messages.... and it makes my jolla bit unusable in stress time

please make an option for : close whole messages app / close messages UI (keep messages in cache)

edit: 76 seconds for each start of app !

edit flag offensive delete publish link more
1

answered 2015-06-16 22:49:12 +0300

temaleva gravatar image

Since update I have dramatic battery drain especially with mobile data on. Before it was about 12 hour before the battery is empty. Now it is almost two time quicker. Usage is almost the same. You can see the difference on the attached diagram. image description

edit flag offensive delete publish link more

Comments

A lot of people have the same draining trouble, me too. I really don't know why. But every hour or less than one hour, i loose 10% of charge O_o.

Kiri ( 2015-08-05 13:29:08 +0300 )edit
0

answered 2015-06-08 18:32:50 +0300

kormarun gravatar image

updated 2015-06-08 18:42:18 +0300

Since the update the browser cannot "Open in new tab" anymore. Anyone else having similar problems? The button is there but tapping it returns to current opened page (with no new tab opened)

Edit: more precise error desc.

edit flag offensive delete publish link more

Comments

No, I still can do this.

Slawek ( 2015-06-08 18:45:12 +0300 )edit

no may be some other problem, everyone can open new tab. Try to restart mobile or reinstall system software.

vishal ( 2015-06-10 16:35:56 +0300 )edit

tabs doesnt seem to work in private browsing. if your browsers text field is striped you are in private browsing. change it by tapping tabs, square thing with number inside, drag down and choose normalbrowsing

FOMBE ( 2015-06-10 23:19:53 +0300 )edit

I don't have problems. Tabs works as usual in private section of browser...

drummer12 ( 2015-06-16 19:21:08 +0300 )edit
0

answered 2015-06-10 08:57:24 +0300

updated 2015-06-11 10:26:32 +0300

Browser is nearly unusable in my case. Everytime if there is more than one tab opened OOM-Killer closes all apps and also the browser itself... Anybody else got the same problem?

Edit: A few restarts fixed the problem. Now browser works like in 1.1.4.x

edit flag offensive delete publish link more

Comments

like 1.1.2 version browser sometime closes automatically. sometime android apps if minimized exits automatically.

vishal ( 2015-06-10 14:30:47 +0300 )edit

try restarting the device and clear cache and history... I have no trouble ;)

drummer12 ( 2015-06-16 19:19:38 +0300 )edit

updating to 1.1.7 solved my problems. Thanks

oguzhanssan ( 2015-07-21 01:01:11 +0300 )edit

Question tools

Follow
16 followers

Stats

Asked: 2015-06-08 12:11:52 +0300

Seen: 22,962 times

Last updated: Jul 20 '15