We have moved to a new Sailfish OS Forum. Please start new discussions there.
5

[Bug] Cannot log in e-mail account (IMAP SMTP) since password change

asked 2015-06-12 12:48:53 +0200

martind gravatar image

updated 2017-07-21 04:54:11 +0200

DarkTuring gravatar image

After smpt/pop3/imap general email provider server login password update and change i cannot login any longer.
To replicate:
1. Add general email account under Jolla SFOS accounts, use your email provider outlook external email client parameters, user name and password settings for receive and send account;
2. retrieve all your emails and make sure it works,
3. go to your email provider website and update login password;
4. update login password under the general account you added on your SFOS phone, server settings,
resync emails, and you will get an error message;



What it should be doing is accept new credentials in Jolla SFOS and verify server settings, the same way it performs the verification when first adding the account;


Please fix in SFOS update on how credential changes are handled under accounts;

I'm using SFOS 1.1.4.29, Jolla Phone Problem Persists in SFOS 2.1.0.11, Intex Aquafish.

edit retag flag offensive close delete

2 Answers

Sort by » oldest newest most voted
2

answered 2018-02-03 14:10:44 +0200

TomC gravatar image

I have noticed this also, previously with Jolla 1, but now also with Sailfish X, version 2.1.3.7.

My email account, provided by my ISP has worked fine on Sailfish X, until I changed the password yesterday. After that, I was not able to login any more from Sailfish X, although I changed the password in the account. The workaround to solve it was to delete the account on the phone and recreate it.

Is there any information regarding this bug? It seems to be old, so it should be adressed in some way by now.

edit flag offensive delete publish link more

Comments

^^ Time for jolla to track this issue !

launchpad ( 2018-05-30 15:35:00 +0200 )edit
1

I can confirm this bug still exists on my Xperia X, and that rebooting cured it without having to delete the account and recreate it. But maybe I was lucky!

NXM ( 2019-07-05 13:00:31 +0200 )edit

I can confirm this bug still exists on Sailfish OS version 3.1.0.11 on Jolla 1. Rebooting also helped in my case. Thanks for the suggestion @NXM

Ant ( 2019-08-22 22:26:55 +0200 )edit
1

answered 2015-06-12 15:04:10 +0200

martind gravatar image

updated 2015-06-12 15:05:10 +0200

I solved the problem. For me the following workaround worked: Delete the old e-mail account, Reboot, create a new one.

And I found out that the special character @ or § is not supported by Sailfish OS in the e-mail password.

edit flag offensive delete publish link more

Comments

^^ I do not recall the "@"-character ever being an issue ....

a.o. @jovirkku : Nevertheless the workaround still(!!) happens to be necessary when restoring device backups. Not all restored email-accounts won't sync unless they are being deleted and set up again from scratch. Really cumbersome !

[ currently using SFOS-X 2.1.4.14 ]

launchpad ( 2018-05-30 15:27:34 +0200 )edit

This is quite an old Q&A. It seems there is no (obvious) way to update an E-mail's account passwords (for incoming and outgoing messages). Having to recreate an account is normally not what should be done for editing the passwords.

NikosAlexandris ( 2019-02-17 13:23:00 +0200 )edit
1

Any hint to edit e-mail settings via the command line? Where are the settings located?

NikosAlexandris ( 2019-05-05 22:34:09 +0200 )edit
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2015-06-12 12:48:53 +0200

Seen: 315 times

Last updated: Feb 03 '18