Ask / Submit
33

Preventing pocket dialing to emergency service (112)

asked 2014-01-03 19:26:46 +0200

make gravatar image

updated 2014-11-06 10:35:34 +0200

bijjal gravatar image

Today something happened to me for the first time that shouldn't happen to anyone: I somehow pocket dialed to emergency service (112).

The device was in my front jeans pocket, screen facing to my leg, and I was lifting some boxes from under the table to the table and vice versa. And right after that I heard a woman answering the call. (I don't know if the speaker turns on automatically when making an emergency call, or was that turned on also by mistake.)

I'm also pretty sure my lock time (30 mins) was reached and the device was locked by the lock code.

Pocket dialing to emergency services should never ever happen, because it drains on emergency service operators time, and there might be someone else in the line needing help for a real emergency. So how to prevent those?

edit retag flag offensive close delete

Comments

People noted that the SIM card connection is lousy (search for "SIM" on togehter.jolla.com):

jgr ( 2014-01-04 03:04:09 +0200 )edit
1

Nope, that didn't happen. I didn't have to enter my PIN. But I guess the same emergency call button is on the unlock screen...

make ( 2014-01-04 18:39:08 +0200 )edit
1

This is somewhat related to this question but it's not an answer - so let's have a comment then:

At least on my device you can have a call to 110 accidentally while the device is locked. This is bad as 110 is an emergency number in number of countries like in Germany where this is a number to Police and in Norway where it's number to fire department). All you have to do is three steps:

  1. swipe up to open unlock screen
  2. press the emergency call button
  3. press call button -> the phone calls to 110 !!

Note, that no number was selected by me, the field showing selected number was absolutely empty. Thinking about these three steps I would say it's pretty much possible to make 'pocket calls' to at least 110 while the device is locked.

EHyde ( 2014-08-19 10:46:48 +0200 )edit

@EHyde: when device is in pocket, proximity sensor is supposed to block the swipe, so step 1 is blocked, so emergency call is not possible unless you have broken hardware in the device. 2. If proximity sensor would be broken it would still be unlikely to get touch events pressed in the area of emergency button, you have 5 touch presses before emergency button is hidden, so taken the area of whole screen the change is a few % times the few % in step 3. So even if your proximity and light sensor would be broken the change for pocket call is in the area of under promille.

rainisto ( 2014-08-19 11:02:10 +0200 )edit

@rainisto: yes, sure, I see that it's unlikely. And it's clear that ultimately you just can't 100% prevent it from happening. But on the other hand, once you have millions of devices around (sure you will, or even more!) unlikely events starts to happen every now and then...

But actually my point is that I was surprised to see that you don't have to select any number when you get to emergency call dialer, just hitting call is enough to make a call to (almost random) number. Should it be it be something to explicitly selected by the user? If so the likelyhood of the pocket call to emergency number turns to even more unlikely.

EHyde ( 2014-08-19 11:29:09 +0200 )edit

5 Answers

Sort by » oldest newest most voted
8

answered 2014-01-03 19:30:12 +0200

make gravatar image

There is a proximity sensor in the device, so maybe the unlock / double-tapping should be made impossible if the sensor reads something right in front of it? (If it's not already doing that.)

edit flag offensive delete publish link more

Comments

1

Proximity sensor prevents wake up by douple-tap, but not by power button. Wake up by double-tap also doesn't happen if taps are made in different places or screen is being touched somewhere.

hana ( 2014-01-09 02:41:50 +0200 )edit

Then I guess the first thing what happened was that the power button was pressed.

I just checked, that swiping is also prevented by the proximity sensor, which is good... BUT: only if you press your finger tightly against the sensor. If you only press your finger lightly, or put anything else on top of it (like an 1 cm thick book), the swiping is NOT prevented.

It seems that there is a different sensitivity setting for the proximity sensor for the wake up (book over the sensor prevents double-tap) and the swiping (book doesn't prevent it). So maybe the same sensitivity setting needs to be also for preventing the swipe gestures?

make ( 2014-01-09 23:52:19 +0200 )edit

@make I actually can't prevent swiping, even if I press my finger hard on the proximity sensor.

hana ( 2014-01-10 04:15:34 +0200 )edit

Pressing the emergency call button doesn't work if you have your finger on the proximity sensor. Nor does swiping for me. It seems that no touch input is going through. But you need to really press on the sensor just covering it lightly doesn't work. So maybe some sensitivity adjustments are needed.

hetas ( 2014-08-15 10:04:46 +0200 )edit

The only way I can prevent swiping is pressing the sensor so hard and so widely that my finger actually touches the display too. This obviously prevents swiping, but not because of the proximity sensor.

hana ( 2014-08-17 15:38:50 +0200 )edit
7

answered 2014-08-15 11:10:35 +0200

rainisto gravatar image

updated 2014-08-15 11:15:17 +0200

It's in the QML file, so in developer mode you can edit the button out (PinInput.qml).

Disclaimer, if you break the file you are in danger of bricking the device (as you then cannot open the lock from UI) so better keep working ssh connection open when you are editing it (or you need to use emergency mode to fix the file).

Unfortunately law states that we need to offer emergency calls in all situations, so on official firmware hiding it will not be offered.

edit flag offensive delete publish link more

Comments

Thank you! I completely understand that this will not be an official option, but diving into this qml will get me to where I want to go. Not sure if it satisfies the original question, I'll leave that to make to decide.

Update: Simply toggling showEmergencyButton on line 51 did the trick. I did however had to reboot the phone for the setting to take effect, so for anyone contemplating the same thing, tread carefully!

OliverH ( 2014-08-15 11:38:45 +0200 )edit

Since Jolla 2 (1.1.9.28 Eineheminlampi) defining the item as false is not enough. You also have to comment out the IconButton{} code from line 259 to 277. Tread ever so more carefully!

OliverH ( 2015-09-25 12:16:04 +0200 )edit
2

answered 2014-09-03 22:53:02 +0200

spiiroin gravatar image

If the proximity sensor is covered, the double tap detection is disabled -> tapping the display while something is on top of the sensor should not wake up the device.

On the other hand by default the power button will wake up the display even if the proximity sensor is covered.

If finger/palm is detected on screen when it wakes up, the touch input is blocked until touch release is detected. This might explain the "pressing hard on top of proximity sensor stops swipes" if the finger is actually touching the screen too (the proximity sensor plays no role once the display is on - except during calls).

There is no settings ui for this, but it is possible to make the device ignore power button too if the proximity sensor is covered by running:

mcetool --set-powerkey-action=proximity

(to install mcetool run: pkcon install mce-tools)

edit flag offensive delete publish link more

Comments

If there's audio playing volume buttons will wake up the display, also.

hetas ( 2014-09-04 07:33:18 +0200 )edit

@hetas: yes, but not if the proximity sensor is covered.

spiiroin ( 2014-09-04 10:16:06 +0200 )edit
1

answered 2014-08-15 07:58:46 +0200

OliverH gravatar image

updated 2014-08-15 09:51:33 +0200

I just bought a Jolla and one week in, this happened to me. I really want to lose the emergency-button on the UNlock-screen. Please tell me this isn't hardcoded and I can edit a file to achieve this (and which file then). I'm already in Developer Mode.

edit flag offensive delete publish link more

Comments

so, you have some kind of emergency button on your lock screen?? what does it look like? i don't have such thing... does it depend on your operator maybe ?

Leinad ( 2014-08-15 08:55:16 +0200 )edit

On the unlock-screen, ofcourse. Pardon me for creating a confusion here.

OliverH ( 2014-08-15 09:19:27 +0200 )edit

the screen that shows up directly after double tap? that's the one i mean, i have no button there... only time and date and some symbols

Leinad ( 2014-08-15 09:56:49 +0200 )edit

That is indeed the lockscreen. The unlockscreen appeears after that asking for your security code, if you have that set under Settings --> Device lock --> Automatic locking
Note that the screen going black is set under Settings --> Display

OliverH ( 2014-08-15 10:02:46 +0200 )edit

ah ok, i haven't set a security code, so i guess, that's why i don't have that button.

Leinad ( 2014-08-15 10:06:38 +0200 )edit
0

answered 2014-11-06 15:53:52 +0200

nthn gravatar image

Disabling touch input when the sensor is covered (so preventing pocket dialing) is planned to be released in update10: https://lists.sailfishos.org/pipermail/devel/2014-November/005168.html

"Since this also means any proximity sensor faults will render the device practically unusable, it will be possible to temporarily disable proximity sensor by triple power key press."

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2014-01-03 19:26:46 +0200

Seen: 11,510 times

Last updated: Nov 06 '14