Browser doesn't trigger network connection dialog

asked 2015-06-16 02:22:13 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2015-06-16 02:23:39 +0300

Tanghus gravatar image

Unforetunately I discovered this too late in the release cycle, as I don't go out much because of a busted leg :P

When there's no network connection - for example if you move outside your home wifi range without having cellular data enabled - the browser gives a "server not found" instead of prompting to select a network.

I'm almost sure this problem didn't exist before 1.1.6.27; at least I couldn't find any issues about it here.

/Tanghus

edit retag flag offensive close delete

Comments

Some people will consider this a feature.

chemist ( 2015-06-16 13:34:20 +0300 )edit

Some people will consider this a feature.

How come?

Tanghus ( 2015-06-16 14:14:44 +0300 )edit

Good point, but the currently selected solution doesn't work well IMHO.

From the question you linked to:

If the user has a data plan then a connection to the Internet is always expected to exist, so no popup is needed. If a known Wifi access point is available then Wifi will be automatically be used instead, so no popup is needed.

In my case I was standing at the bus stop trying to open the site of the bus company to get the times. Instead of either switching to mobile data when realizing it was out of known wifi range, or showing the connection dialog, it waited a long time for a timeout.

As far as I understand different apps have different priorities. If I e.g. check for updates, the connection dialog pops up.

Tanghus ( 2015-06-16 15:28:04 +0300 )edit