Ask / Submit
8

Alarm and Silent icons doesn't appear with unofficial translation [answered]

asked 2015-06-17 19:29:35 +0300

czdosi gravatar image

updated 2016-02-01 18:08:51 +0300

Few days ago I noticed that alarm icon doesn't appear at lock screen right of clock. Today I found that silent icon is missing too. It seems this happened after I update to 1.1.6.27 which was without problems. I have no patches from OpenRepos installed. Anybody have same issue?

I found this ancient question from Sailfish OS beginning which seems as similar problem. But restarts mentioned there didn't help.

UPDATE 2015-06-18: Today, I found when I switch language to English (from Czech unofficial translation) then both icons comes back. So is the bug in translation or is something bad with fallbacking of "untranslated" icons in Sailfish? I'm going to contact guy who develop the Czech translation.

UPDATE 2015-06-19: @Kees reported same problem with unofficial Dutch translation (see comments below).

UPDATE 2016-02-01: Solved. See answer below.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by JSEHV
close date 2016-02-01 18:21:53.991723

Comments

3

Upgraded to Aaslakkajärvi yesterday. Both icons still present. No bug here.

objectifnul ( 2015-06-17 20:34:21 +0300 )edit
1

Hmmm. I got the same issue with unofficial Dutch Language. Thought it was just my phone, until I changed the language back to English. All of a sudden I have the silent and alarm icons back! It mus be something with the translations then. I'll try to contact the Dutch translators...

Kees ( 2015-06-19 18:05:40 +0300 )edit

Thanks @Kees. So it isn't only the CZ translation problem.

czdosi ( 2015-06-21 21:26:49 +0300 )edit
1

cz unofficial localizatuon, same problem..

Bobsikus ( 2015-06-23 22:42:05 +0300 )edit

ongoing cz/sk unofficial localization , same problem switch to EN Alarm and Silent icons they are there

kobylkanoro ( 2015-07-07 14:00:47 +0300 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2015-06-18 17:50:12 +0300

I wasn't able to find where the problem is. My approach is quite straight forward. I downloaded *qm from device, I have converted them to *ts using lconvert utility, Sent to Transifex, Downloaded Translations, compiled new messages using lrelease. Additionally, there is just cs.conf to get language into the list of supported languages. The scripts, I am using, are available at github: https://github.com/jmlich/jolla-cesky/ The translations itself are at transifex https://www.transifex.com/projects/p/jolla-cesky/

If you find it, let me know and I will release fixed package.

edit flag offensive delete publish link more

Comments

Thx, @xmlich02. I'll try check it out.

czdosi ( 2015-06-18 22:54:51 +0300 )edit
0

answered 2016-02-01 18:04:10 +0300

czdosi gravatar image

updated 2016-02-01 18:11:17 +0300

Answer found there: https://together.jolla.com/question/128208/top-icons-not-showing-with-unofficial-localization/

You have to compile locale and reboot. For Czech e.g:

localedef -i cs_CZ -f UTF-8 cs_CZ.utf8
edit flag offensive delete publish link more

Question tools

Follow
2 followers

Stats

Asked: 2015-06-17 19:29:35 +0300

Seen: 275 times

Last updated: Feb 01 '16