Ask / Submit
1

Update failed; device boots but does not work

asked 2015-06-17 21:00:33 +0200

Yeum gravatar image

I just recently tried to update to Aaslakkajärvi.

After downloading & starting the update, the device seemed to restart itself after only ~40% of the progress bar had went through. When the device restarted, I went to the store, and said "can not use store while update in progress". So I went back to settings/update, and hit "update device" again.

Now when the system boots, it gives me the background image, and nothing else - no clock, no icons, no request to enter PIN code.

The inputs appear to be functioning, as double-tapping still wakes the device, and I can put it to sleep with the close gesture (pulling over from the top), volume keys also function (you see the volume up/down animation).

I guess this is something you could maybe fix with developer mode (re-running the update via the terminal), but I'm having trouble connecting to the device via USB at all. I always previously used Wifi to do my transfers due to the trouble of getting USB working, but now the problem is I had the WiFi function turned off when doing the update => can't connect to the device via the usual wifi IP adress.

Any good ideas on how to fix the connectivety/device?

edit retag flag offensive close delete

Comments

Was able to connect to the device in recovery mode (telnet) using the default USB IP adress (192.168.2.15) and the (windows) RNDIS driver install instructions found here: https://together.jolla.com/question/22079/howto-all-computer-users-recover-or-reset-a-device-that-is-stuck-in-boot-loop/

Still can not connect to the device in normal mode via SSH. Would rather not do a full factory reset if I could avoid it.

Yeum ( 2015-06-17 21:35:09 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-06-18 04:55:54 +0200

simo gravatar image

updated 2015-06-18 05:04:59 +0200

Important

This is one of many reports on similar problem after this and earlier update, I'm suggesting "Tracked by Jolla" sign for the oldest similar question before closing any of these as duplicates, as the fix seems to require use of Recovery mode (factory reset) in many cases, and in some cases even warranty repair.

Other questions: (that I found)

https://together.jolla.com/question/91886/114-bricked-phone/

https://together.jolla.com/question/92776/crash-during-sailfish-update/

https://together.jolla.com/question/96132/recovery-mode-possible-bug/

Closely related:

https://together.jolla.com/question/91260/help-11429-almost-bricked-my-device/

https://together.jolla.com/question/91900/no-gui-after-114-update/

https://together.jolla.com/question/95550/phone-not-booting/

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2015-06-17 21:00:33 +0200

Seen: 143 times

Last updated: Jun 18 '15