Phone doesn't connect to WLAN automatically.

asked 2015-06-21 00:48:59 +0200

ApB gravatar image

updated 2016-08-17 10:55:59 +0200

jiit gravatar image

When i enter the area my wlan covers i have to double tap on the phone to get it to connect to my Wi-Fi. No hidden wifi. I think this happens in the last few releases. Any ideas on how to solve this?

Looked for other similar bugs but all i could find was year old threads.

Update: Tested a bit more and i think i have something.

When the mobile data are active and i enter my wifi area it connects (switches from mobile to wifi) fine. When the mobile data are deactivated (no connection) and i ender my wifi area i have to wake up the phone to connect.

Can someone test the above and confirm the bug?

edit retag flag offensive close delete



No data plan active currently, same behaviour : I too need to wake the Jolla phone up for Sailfish to consider connecting.

DrYak ( 2015-06-24 03:07:19 +0200 )edit

Thanks for testing. Now we need Jolla ( @tigeli ) to take notice.

ApB ( 2015-06-24 07:13:45 +0200 )edit

I myself usually need to go to Settings, turn off wifi for a couple of seconds and then turn it back on to get my Jolla to connect properly to my home wifi again. Occasionally, the phone has difficulties understanding I'm out of home and home wifi and complains a while "problem with network", yet at the same time I am using mobile data without problems.

The connectivity to home wifi has been a bit difficult for at least a year, often connecting poorly to wifi when coming home again.

statler ( 2015-06-24 19:56:01 +0200 )edit

I suspect the problem is a power-management issue. If you're not connected your Jolla is probably suspended and therefore cannot notice that you're home, until you wake it up.

reinob ( 2015-10-06 12:46:06 +0200 )edit