Ask / Submit
13

Messages app taking ages to start

asked 2015-06-21 18:38:22 +0200

malibu1106 gravatar image

updated 2015-08-31 22:32:25 +0200

Hello there.

Since the last update, the message app don't keep running in background, it's really busy, for every launch, you've to wait up to 10 seconds or more depending amount of message you have .. it's a really bad idea ..

I'm here to ask people, if someone know a way to keep the process running in background.

Thanks ..

Edit 31/08 : Still present in 1.1.7.28

edit retag flag offensive close delete

Comments

Updated your Q a bit and deleted your bumper, just keep the app open if it annoys you that it is actually stopped when you close it. (I have close to all apps open, that is what multitasking is for - browser makes oom-killer close them sometimes but well thats better than having your phone freeze like on android!), you may change this to a feature-request May we have an option to keep Messages alive in background?

chemist ( 2015-06-22 23:52:12 +0200 )edit

The worst thing, is that sometimes the processus seems to be running again after cloing message app, In lighthouse, i can see the message app running, eating a little bit of RAM, but the app isn't in cache. So it's really .. idiot !

malibu1106 ( 2015-06-29 16:17:40 +0200 )edit
5

I guess it's being swapped off RAM and takes a bit to be swapped back in. Bottom line: I want more RAM. Please crowdfund a new Jolla 2 with an option of up to 4 GB RAM right after the tablet is done.

Giacomo Di Giacomo ( 2015-06-29 16:56:36 +0200 )edit
1

@Giacomo-Di-Giacomo as much as I like to have a 4GB RAM device... I had winXP running on a 512MB machine (P4), so how about reducing the footprint on Jolla1 first instead of becoming like android where every new version needs shiny 600eur hardware to run smooth (at least we have no Java leaking)

chemist ( 2015-06-29 17:06:03 +0200 )edit
2

Maybe your XP was an old version. I had XP SP3 running on a 1 GB netbook and it kept swapping forever. Expanding it to 2 GB cured the situation. XP is more than 10 years old, don't forget. Anyway, I want to run apps in addition to the OS, so I want lots of RAM to exploit multitasking, including the new split-screen mode that is coming from SFOS 2.

Giacomo Di Giacomo ( 2015-06-29 17:36:00 +0200 )edit

2 Answers

Sort by » oldest newest most voted
3

answered 2015-07-13 12:15:39 +0200

malibu1106 gravatar image

I made a comparaison with my old n95, and it's faster to open message app with the n95 than with jolla running last update. Amazing ... And for people saying " Keep it running ", please read again, the goal is to close it normally.

edit flag offensive delete publish link more

Comments

76 seconds - everytime, is just TOO MUCH waiting.....

pan tau ( 2015-07-20 10:04:57 +0200 )edit
5

We are investigating this internally. There are a variety of things we're investigating to fix, related to this issue, including the way we resolve sender/receiver information for messages, how we do the database access in this flow, and the in-memory format we use for results.

I can't give an ETA on when the improvements will be released, but you can see some of the work-in-progress at https://bugs.merproject.org/show_bug.cgi?id=1174

Cheers, Chris.

chris.adams ( 2015-07-20 10:23:33 +0200 )edit
1

It was perfect on 1.1.4, this problem came from 1.1.6 I'm using the power menu (coderus app) double tap function to open message app, and before 1.1.6, there was no loading time, double click : it's open ! It was a really cool thing ..

Hope to see it fixed soon !

By the way, is there a way to downgrade sailfish version ?

malibu1106 ( 2015-07-20 16:23:56 +0200 )edit

yes. before 1.1.6 it was fine, and 'resolv' time for sender/receiver was there only at first start of Messages.

pan tau ( 2015-07-22 23:55:22 +0200 )edit
1

answered 2015-08-04 00:21:10 +0200

pan tau gravatar image

updated 2015-08-05 13:14:55 +0200

80+ seconds everytime when you need to open messages :(

3244 Groups (mostly from internet gw - sms sender 990009 followedByRandomNumbers for each sms)

81733 Events

edit: had to cleanup (edit grep parameter to fit your selection ):

commhistory-tool listgroups|grep remoteUids:\"990009|awk '{print $2}'|xargs -I {} commhistory-tool list -group {}|awk -F "|" '{print $1}'|xargs -I {} commhistory-tool delete {}

you can also cleanup all messages per protocol , excluding some persons (grep -v) or so ...

before run the command, you should review returned groups for your grep params, example:

        commhistory-tool listgroups|grep remoteUids:\"990009
        or
        commhistory-tool listgroups|grep Account/gabble/jabber
        or
        commhistory-tool listgroups|grep Account/haze/icq|grep -v ExcludeIcqNumber
        ...

then append rest of commands to delete events.

OR via sqlite, then reboot

sqlite3 /home/nemo/.local/share/commhistory/commhistory.db
DELETE From Events where remoteUid like "990009%";
DELETE From Groups where remoteUids like "990009%";
edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2015-06-21 18:38:22 +0200

Seen: 666 times

Last updated: Aug 31 '15