Ask / Submit
8

[Bug] Sound pitch over bluetooth changed since 1.1.6 (audio too fast over bluetooth) [released]

asked 2015-06-23 14:43:34 +0200

rburkhanov gravatar image

updated 2015-09-04 11:51:59 +0200

jiit gravatar image

This problem is also still present in 1.1.7.27 & 1.1.7.28

I have no way to confirm this instrumentally, but since the latest update (1.1.6.27) sound pitch over BT for music & any other audio files playback had been notably changed. All sounds seem way higher now. It does not depend on whether I listen to a music with audioplayer (in my case I use SFOS native version of QuasarMX) or it is a streaming file played back directly in native browser, sound seems higher (and somehow quicker) then it should be. The same applies to all system sounds played with notifications (incoming message, new mail, etc.). Has anybody noticed the same or I'm the only one?

I've (Markkyboy) tried my Bose AE2w headphones with Jolla device (despite my comments below) and the audio is still too fast. Also when using audio from Jolla device over bluetooth with my laptop.

Confirm this issue still present with 1.1.7.28 — tested it with different hw: bt speakers, headphones & car audio (5 different devices in total, to be exact). It's really annouyng and makes one of my most often ways to use Jolla impossible. Hoped it would change with the latest update because of "Update to PulseAudio 6.0, improving Bluetooth audio", but no… (rburkhanov)

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by rburkhanov
close date 2015-10-11 13:01:22.229533

Comments

I think this has already been mentioned, but I can't find it.

I did experience this problem when streaming music to my PC via bluetooth, the speed increase was quite noticeable to say the least, not exactly Alvin and the Chipmunks, but certainly quicker than it should be (I believe was the quote from the original post about this problem).

Yet, the audio is fine when played through my bluetooth headphones, it plays at normal speed.

Edz ( 2015-06-23 15:00:54 +0200 )edit

Yeah I mentioned it in the release notes thread, should have done it here also but forgot... https://together.jolla.com/question/95124/release-notes-116aaslakkajarvi/ The changed pitch is a consequence of the speed increase. I hadn't noticed it in system sounds though so I went and tested it. Turns out you're right it's also system sounds. Then I noticed you also mentioned browser, hadn't tried that out either but instead of browser, I used a Sailfish Youtube app. Turns out the audio and the video are in sync, yet the audio still is too fast. So it's not just audio but video as well... You should try to unpair and repair your Bluetooth device, it should fix it until you turn it off and on...

jkhlam ( 2015-06-23 22:45:47 +0200 )edit

@jkhlam I've made some tests. Unpairing doesn't help, but resetting bt (turning airplane mode on/off) - does.

rburkhanov ( 2015-06-24 07:23:57 +0200 )edit

Turning on/off airplane mode doesn't fix it for me... Did you try watching a movie clip? Does your problem also return after turning the Bluetooth device on/off?

jkhlam ( 2015-06-24 20:11:49 +0200 )edit

@jkhlam Rebooting the device somehow helps, but only if it's made right before pairing with bt audio. At least this is my subjective feelings.

I want to try some objective measuring: make a recording with a microphone and compare it to the original track using some tools. Will report here on any results.

rburkhanov ( 2015-06-24 22:25:56 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2015-09-02 01:02:04 +0200

neter gravatar image

updated 2015-09-02 02:20:31 +0200

My girlfriend had this problem too and I fixed it by changing the default sample rate in the pulseaudio configuration. First you need to provide you a way to edit files with root privileges. One way:

  1. Enable Developer mode in Settings > System settings > Developer mode, and set a password
  2. Open Terminal and login as root with command devel-su and the password above
  3. I don't remember if there is vi editor by default, but there is sed, or you can install vimfrom OpenRepos.net, or some other editor

To fix the sound problem you have to add such row in the file /etc/pulse/daemon.conf

default-sample-rate = 48000

After that you need to restart pulseaudio or the whole system. I don't know why it needs this change, all my desktop systems works well without this row (the default value is 44100) and the same BT headset (SBH50), and this row was not there before Sailfish 1.1.6 too (if I remember correctly), but I hope it helps you too.

P.S.: Now I saw that it is 48000 in my Maemo (N900).

edit flag offensive delete publish link more

Comments

makes no difference for me, I tried both settings, the music is still too fast over bluetooth audio. This also happens when using my Bose AE2w headphones. Somewhat annoying to have like £400 of tech and it doesn't work properly!, c'mon @jolla!, sort it out!

Edz ( 2015-09-02 23:12:37 +0200 )edit

Markkyboy, did you see some difference after the change, or it is absolutely the same? And which both settings (I suggested one)? Did you add the suggested row or did you edit the example row in the file (may be forgotten comment sign in the beginning of the row)? Did you reboot the phone after that? Can you check with far bigger and far smaller common rates (e.g. 8000 and 192000)? Do you have previous modifications of the pulseaudio and bluetoothd configurations, made by you or by some app? Can you check if there is some difference with factory reset? Sorry for the rain of questions but please answer to all.

neter ( 2015-09-03 23:54:32 +0200 )edit

Hi @neter - did you read my opening comment?, "makes no difference for me" - yes, it stayed absolutely, the same, hence my opening comment. :) I know how to edit files and what to edit, of course I rebooted. There were no 'examples' in the file to comment/uncomment that I recall. The line default-sample-rate = 48000 already exists in daemon.conf - no need to add it, just a simple edit using vim is sufficient. No, no previous configs for BT/pulseaudio. Can I check by doing a factory reset?, certainly not. My phone was reset recently, with the sole purpose of updating to the latest (opt-in) 1.1.7.28 (now released to public). What version of SailfishOS are you running? I'll look at daemon.conf again, I'm certain I saw no examples or anything to add/uncomment/comment, but I could be wrong.

Edz ( 2015-09-04 00:27:05 +0200 )edit

The existing default-sample-rate row in the file is an example row with the default value 44100. If you change the value there, you have to remove the comment sign (;, dot and comma) at the beginning of the row to take effect. SailfishOS 1.1.7.28.

neter ( 2015-09-04 00:37:12 +0200 )edit

@neter, with or without ; (semi colon) no difference is made. NO DIFFERENCE.

Edz ( 2015-09-05 00:07:29 +0200 )edit

Question tools

Follow
1 follower

Stats

Asked: 2015-06-23 14:43:34 +0200

Seen: 814 times

Last updated: Sep 03 '15