Ask / Submit
3

Baikal CardDAV

asked 2015-06-30 01:21:49 +0200

Usegui gravatar image

updated 2016-06-10 18:00:57 +0200

Hello,

I am trying to synchronize my jolla with my baikail cardDav on my laptop without success I put my username, the code After I put

ip_pc/baikal/card.php/addressbooks/username/default/

but nothing happens

edit retag flag offensive close delete

Comments

+1 because i've the problem since the CardDav-feature exists

sqozz ( 2015-06-30 09:42:58 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2015-06-30 18:43:13 +0200

Yo gravatar image

I don't use Baikal but as a start let's try to analyse what's going on:

Have a look at the log and try to pinpoint the errors. Instructions for this can be found in several posts. It can be achieved like this:

  • You need to have developer mode active.
  • Open terminal or SSH into your device. You will need two terminals/ssh sessions.
  • 1st session:
    systemctl --user stop msyncd
    killall msyncd
    MSYNCD_LOGGING_LEVEL=8 devel-su -p msyncd
  • 2nd session:
    devel-su journalctl -af | grep caldav
  • Then go to settings -> accounts and trigger a manual sync (long tap on the account, then select 'sync')
  • You should see output on both terminal sessions. The 2nd session is most of the times the one that has the interesting info...
  • When finished just hit CTRL+C in both sessions.
  • start msyncd again with systemctl --user start msyncd

Report back here and I will try to help.

edit flag offensive delete publish link more

Comments

msyncd refuses to start again after killing it with systemctl and killall (after all, killall reports that there is no process). I'm getting "Failed to register to D-Bus (D-Bus not started or msyncd already running?), aborting start". But "systemctl status dbus" tells me, that dbus is running and "ps aux | grep msyncd" says, that msyncd is not running. Any idea?

sqozz ( 2015-07-08 13:02:02 +0200 )edit

Kill it a bunch of times. You may have to wait a second or two after killing it, in order for the dbus registrations to be dropped by the system. Various triggers can try to restart the service, so you just have to do the systemctl --user stop msyncd and then killall msyncd a bunch of times, and then try to start the service manually with the logging env var set.

chris.adams ( 2015-07-22 08:49:56 +0200 )edit

@cris.adams, I don't get it, I systemctl --user stop msyncd and then killall msyncd like crazy, but msyncd wont' start... The killall msyncd reports that no process was found. :-(

NobodyInPerson ( 2017-02-25 22:06:54 +0200 )edit
0

answered 2016-03-25 16:57:18 +0200

Yo gravatar image

I tried it myself today. Bottom line is: I had to create separate accounts for calDAV and cardDAV to get it working.

calDAV worked fine all the time but cardDAV did not, so I created a separate account for cardDAV with the following URI:

https://server.url/card.php/addressbooks/username/default

Of course this can differ if you have a different version of baikal running or have baikal installed into a directory. Mine is 0.2.7. For 0.4.x it should be:

https://server.url/html/dav.php/addressbooks/username/default

Maybe it also works with different settings, but these worked for me.


@chris.adams : Interested in logs? Main Problem (at least to my untrained eye) seems to be this line from unsuccessful sync:

RequestGenerator::generateRequest:93 - generateRequest(): ""  QUrl( "" )  "1" "PROPFIND" "<d:propfind xmlns:d="DAV:" xmlns:cs="http://calendarserver.org/ns/"><d:prop><d:resourcetype /><d:displayname /><cs:getctag /></d:prop></d:propfind>"

in contrast to

RequestGenerator::generateRequest:93 - generateRequest(): ""  QUrl( "https://user@server.url/card.php/addressbooks/user/default" )  "0" "PROPFIND" "<d:propfind xmlns:d="DAV:"><d:prop><d:current-user-principal /></d:prop></d:propfind>"

I also see some strange behaviour because I migrated my contacts data from one server to another...

edit flag offensive delete publish link more

Comments

Hrm, seems like the addressbookpath isn't being parsed correctly, in the first case (hence the empty URL). There are some recent changes which haven't been released yet (e.g., https://git.merproject.org/mer-core/buteo-sync-plugin-carddav/commit/925d889e661dff18c040250dbcc933569acfb801 and https://git.merproject.org/mer-core/buteo-sync-plugin-carddav/commit/1cacb80a3d0f09b2a673cd62782594c788f79103) which might improve the situation.

chris.adams ( 2016-03-31 09:35:54 +0200 )edit
0

answered 2016-06-10 14:26:27 +0200

Werbaer gravatar image

i also use baikal und it worked for me with following workaraound. i set up for caldav anf carddav 2seperste accounzd in my jolla and parsef the baikal url until ...card.php and on the other account until cal.php. optional path in both cases empty. this works for my calendar and my addressbook. however i have some missing entried in my addressbook but if i make a new contact in the phone it is correctly syncing onto the baikal server. i know try to make the rpm for the buerto sync update but if i fail with that ;) i will wait fot thr next Sailfish update. but generally it works with this settings

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2015-06-30 01:21:49 +0200

Seen: 745 times

Last updated: Jun 10 '16