Keep mtp alive for copying large files

asked 2015-07-15 15:01:22 +0200

Edberg gravatar image

Dear Jolla experts I am facing a problem for which I couldn't find a solution by now. I am connecting my Jolla to a SUSE 13.2. When I plug in the phone the mtp connection is being established and I can search the phone directories. Copying single image files works fine too. However, when I try copying a large video file (4GB) the copy process starts perfectly and ends after roughly 30sec because the mtp connection goes idle. When I try to restart the copy process I get an error message " The process for the mtp protocol died unexpectedly". Even refreshing the folder's content gives that the folder is not available. So basically I can only replug the phone to get connectivity. Is there a way to keep the mtp connection alive? I am sorry if the question is trivial but I am a bloody new Jolly user. Thank you all!

edit retag flag offensive close delete


Yes, the MTP connection still has some issues. A workaround for your problem is file exchange via sftp. To use it activate developer mode via settings menu, enable ssh remote connection and go with dolphin (I assume you are using KDE on your SUSE system) to sftp://nemo@ (or whatever is set as USB IP-adress). This should work without problems.

wanderer ( 2015-07-15 16:00:04 +0200 )edit

I never tried copying that large files by USB. What you could try is copying by NFS ( for example) or SMB ( ). Anyway, with these solutions you might want to charge your phone by USB (doesn't matter if the battery is full, just attach the USB port to a energy source) to prevent the phone from entering standby while copying.

//EDIT: Converted from answer to comment as this isn't a real(/good) answer.

V10lator ( 2015-07-15 16:09:21 +0200 )edit

Thank you wanderer and V10lator. I will try your work arounds.

Edberg ( 2015-07-16 12:09:59 +0200 )edit

SFTP should be the easyst way under linux i think.

Thaodan ( 2015-07-17 01:13:49 +0200 )edit