Ask / Submit
8

CalDav calendars not found in calendar app after update to 1.1.7 [answered]

asked 2015-07-15 16:52:37 +0300

Miguel gravatar image

updated 2015-07-17 14:58:52 +0300

After updating to 1.1.7 my calddav calendars disappeared from the calendar app, altough they are enabled under the calddav account in the settings app. If I select "Manage calendars" from the calendar app, only local calendar appear in the list.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by Miguel
close date 2015-07-24 11:51:10.469881

Comments

1

Same for me. And it makes no sense to delete and create my owncloud calendar again. But the account stuff itself works fine (finds all my calendars when creating the calendar in accounts)

cy8aer ( 2015-07-15 18:19:54 +0300 )edit

once after reboot i have seen all my events - until sync.

edit: i set manualy sync, so i dont syncing now and after couple of time i can see items again - until sync ;)

pan tau ( 2015-07-16 03:28:04 +0300 )edit

Sorry I updated to 1.1.7 just a week ago and since then I cannot see or add any calendars to my ownlcoud (8.1.1 Calendar 0.7.3) account. In the Jolla system account section where I have my Owncloud servers set up as a generic caldavCarddav account, it shows all calendars. But in the calendar app the calendars do not show up. In the iCal application of my OSX 10.10.5 machine the calendars work perfectly. What am I doing wrong?

seethap ( 2015-09-11 08:37:20 +0300 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2015-07-15 22:30:51 +0300

Nokius gravatar image

I had the same issue,

go to Settings -> Accounts -> select your CalDAV account and disable and enable the Calenders and sync after this you should see your Calendar entrys again.

edit flag offensive delete publish link more

Comments

disable/enable/sync didnt help, account recreated didnt help

while syncing and quickly openning calendar i can see for second all dates with my events underlined (almost everyday), but only until sync is complete, it just flash all days with events for moment , while i am on day with event, name and time of events will flash too then disapear :( ... then again, no events, no calendars

pan tau ( 2015-07-16 03:00:39 +0300 )edit
1

Are you able to get logs from the sync? Requires developer mode. First ensure that /etc/systemd/journald.conf has RateLimitBurst=3000 and RateLimitInterval=10s Then ssh in:

$ systemctl --user stop msyncd
$ killall msyncd
$ MSYNCD_LOGGING_LEVEL=8 devel-su -p msyncd

Leave that running, and then ssh in with a different terminal, and do:

$ devel-su journalctl -af | grep caldav

Then trigger sync (Settings|Accounts, longpress CalDAV account -> Sync).

When it's finished, send the output from the second (journalctl) terminal to chris dot adams at jolla dot com -- please note that the log may contain sensitive information like username/password so please redact that before sending the logs.

Thanks, Chris.

chris.adams ( 2015-07-16 03:51:01 +0300 )edit

Two things: Owncloud server: normal syncing btw REPORT connections from phone. I tried:

  • Accounts -> Owncloud Calendar setup -> disabled both calendars, leaving settings
  • Accounts -> Owncloud Calendar setup -> enabled both calendars, sync, leaving settings
  • Calendar: no syncing calendars
  • Accounts -> long press Owncloud Calendar -> deactivate, leaving settings
  • Accounts -> long press Owncloud Calendar -> activate, longpress sync, wait (! server log shows connections), leaving settings
  • Calendar: no syncing calendars
  • deinstall calendar, install calendar, starting it: no syncing calendars

The standard calendars (non syncing) are private and birthdays. Once I had this effect: birthdays were off. I switched it on. About half a second later I could see the syncing calendars (!) but when I just noticed it (about half a second later) the syncing calenders where out of the list again. And till now I was not able to reproduce it.

Is there a possibility to delete the calendar settings (or some sqlite3 db file) to be back at point zero?

cy8aer ( 2015-07-16 08:18:57 +0300 )edit
1

@chris.adams: Output of my sync:

    Jul 16 07:32:47 milgrim caldav-client[23600]: [D] CalDavClient::start:506 - no notebook exists for calendar path: "/owncloud/remote.php/caldav/calendars/myuser/feiertage/" , creating new 
   Jul 16 07:32:47 milgrim caldav-client[23600]: [D] CalDavClient::start:507 - performing slow sync for "/owncloud/remote.php/caldav/calendars/myuser/feiertage/" 
Jul 16 07:32:47 milgrim caldav-client[23600]: [D] Request::debugRequest:140 - "URL = https://user:pass@my.server/owncloud/remote.php/caldav/calendars/myuser/feiertage/" 
  ... and now syncing stuff and same with my second calendar "calendar"
  Jul 16 07:33:01 milgrim caldav-client[23600]: [C] CalDavClient::syncFinished:372 - CalDAV sync failed: 403 "unable to save calendar storage"

(last line of syncing) With syncing stuff I mean lines of type BEGIN:VCALENDARblabla

cy8aer ( 2015-07-16 08:38:35 +0300 )edit
1

caldav-client[12035]: [C] CalDavClient::syncFinished:372 - CalDAV sync failed: 403 "unable to save calendar storage"

pan tau ( 2015-07-16 12:10:32 +0300 )edit
0

answered 2015-07-24 11:50:11 +0300

Miguel gravatar image

I found the culprit, and it is not Sailfish. Problem was with the update to owncloud 8.1 (bad timing). Seems that other operating systems are also affected. See https://github.com/owncloud/calendar/issues/857. I've added a small patch to fix the issue in owncloud https://github.com/owncloud/3rdparty/pull/189.

Sorry for the noise.

edit flag offensive delete publish link more

Comments

we use Zentyal server, no updates there, its sailfish related: CalDAV sync failed: 403 "unable to save calendar storage", as you can see all events for second, then sailfish make them invisible and shows them after hour. ....

i dont think that this issue should be closed now and forgoten.

pan tau ( 2015-07-28 11:02:55 +0300 )edit

@Miguel thanks very much for following that up on OwnCloud side. @"pan tau" investigation into CalDAV issues continues internally. I have posted a link to a bugreport and potential fix in a comment above, hopefully that will resolve the issue you're seeing.

chris.adams ( 2015-07-29 09:25:33 +0300 )edit

Question tools

Follow
8 followers

Stats

Asked: 2015-07-15 16:52:37 +0300

Seen: 1,185 times

Last updated: Jul 24 '15