Ask / Submit
18

[bug] Change layout on Bluetooth keyboard and TOHKBD does not work

asked 2015-07-15 19:19:10 +0200

nick75 gravatar image

updated 2015-12-25 19:14:26 +0200

Thoric gravatar image

Updated to Sailfish 1.1.7.27, already had latest TOHKBD driver 0.4.1. Changed setting in Sailfish to Swedish input on physical keyboard, and in TOHKBD settings my keyboard is recognized as Scandic. Rebooted my jolla.

But still åäö do not work, instead I get the same US characters as previously.

Also experienced by other user.

This bug also appears on Bluetooth keybords, Logitech K810

Possibility to choose different keyboard layouts for Bluetooth keyboards if paired with one for different languages via Settings > System > Text input > Active layout

Update: Clarify that the bug affects both TOHKBD and Bluetooth keyboards.

Update: 1.1.9.28 brings åäö to Scandic TOHKBD, but messes up every character that needs pressing the blue circle key.

edit retag flag offensive close delete

Comments

Same here, but I'm guessing the TOHKBD software must be updated to support it.

ssahla ( 2015-07-15 19:41:25 +0200 )edit
1

@ssahla, that might be true but as stated in TOHKBD FAQ I interpret it as it should work when the next sailfish update arrives.

A: Jolla Sailfish 1.1.6.27 version (and older) does not support changing keyboard layout. We need to wait for sailfish update.

nick75 ( 2015-07-15 19:55:09 +0200 )edit

Is TOHKBD working in Android now? Thanks :)

tokaru ( 2015-07-15 20:42:12 +0200 )edit
2

@tokaru, it works in Android, tested both Spotify and Skype. But for me the åäö does not work at all.

nick75 ( 2015-07-15 20:47:09 +0200 )edit

Thanks a lot, good to hear it is working in Android :) Hope to see öäü soon, too.

tokaru ( 2015-07-15 20:59:43 +0200 )edit

3 Answers

Sort by » oldest newest most voted
4

answered 2015-07-17 16:01:28 +0200

ssahla gravatar image

updated 2015-07-17 16:08:28 +0200

Layout changing isn't implemented yet, though it shows in the UI already. (According to this.)

edit flag offensive delete publish link more

Comments

3

OK. Interesting that Jolla decided to release the UI part for something that is yet to be implemented... Wonder if UI is removed or the functionality implemented when Björnträsket goes from early access to public release. For sure it can't be left as is.

Valker ( 2015-07-17 18:07:12 +0200 )edit

@ssahla, the note in the TOHKBD FAQ you are referring to was updated from 1.1.6 to 1.1.7 "long" after this question was created - and even longer after that Jolla published that the function now was released.

nick75 ( 2015-07-18 11:18:01 +0200 )edit

I know. Does that make the information less relevant?

ssahla ( 2015-07-18 11:58:52 +0200 )edit

I'm using 2.0.0.10 and a bluetooth swiss french keyboard. It's near from the german one, but not exactly the same. How can I configure it to have a bluetooth keyboard matching my swiss french layout.

Here I'm, having the information of kimmoli here was the solution:

I choose physical keyboard as german (deutsch) and then :

[root@Jolla ~]# dconf write /desktop/lipstick-jolla-home/layout '"ch"'
[root@Jolla ~]# dconf write /desktop/lipstick-jolla-home/variant '"fr"'

Now it's working: Nice from you kimmoli!

Thoric ( 2015-12-25 19:22:16 +0200 )edit
1

answered 2015-09-01 19:58:20 +0200

Now that 1.1.7.28 is released for everyone, let's get this back on the main page.

I picked up a bluetooth keyboard from a store today. After a long search for a cheap bt keyboard with scandic layout (ÄÖÅ) I wasn't very happy when I found out Jolla still doesn't support changing the layout of external keyboards. Is there a workaround for this? I am never going to need other hw keyboard layouts than the scandinavian/finnish one so I am happy to "ruin" some layout files if I need to :P

edit flag offensive delete publish link more

Comments

@ssahla Thanks, but I where can I fetch a finnish one?

jollailija ( 2015-09-01 20:09:48 +0200 )edit

The poster of that answer said (s)he got the French layout from a Linux distro, so that might be the way to go. Sorry, I can't help you any more than that.

I'm hoping Jolla will sort this out by Sailfish 2.0. External keyboards are probably used with tablets way more often than with phones, and they do have a lot of Finnish customers, so they really should...

ssahla ( 2015-09-01 20:25:17 +0200 )edit
1

answered 2015-09-09 23:05:58 +0200

nick75 gravatar image

My Scandic TOHKBD now with working åäö after updating to 1.1.9.28 .

edit flag offensive delete publish link more

Comments

Same here! But the layout is otherwise broken – all the @£$∞§| are in the wrong places...

ssahla ( 2015-09-09 23:32:29 +0200 )edit

@ssahla, I can comfirm that allt characters requiring pressing the blue ring key are in the wrong places. Is this because of the OS or the driver. I guess time will tell. Ironically, this however makes the keyboard more useful for me, because I use åäö more often than those characters.

nick75 ( 2015-09-10 08:53:41 +0200 )edit

If I change to english keyboard symbols seem to be correct, but then I'll lose ÄÖ. AFAIK TOHKBD settings do nothing, so I would assume after @kimmoli updates the settings it should work :)

Pornis ( 2015-09-10 09:20:27 +0200 )edit

No AltGr commands is working on my bluetooth keyboard with Swedish layout

eson ( 2015-09-10 09:29:53 +0200 )edit
Login/Signup to Answer

Question tools

Follow
5 followers

Stats

Asked: 2015-07-15 19:19:10 +0200

Seen: 1,056 times

Last updated: Sep 27 '15