Ask / Submit
13

Alarm clock going off late (and only after activating the display)

asked 2014-01-04 06:55:43 +0200

mcfrisk gravatar image

updated 2014-07-22 10:58:52 +0200

jiit gravatar image

Set two alarms last night: 5:40 and 5:45.

5:40 one was working as expected but 5:45 played the alarm sound after I woke the screen up at 5:48. Odd. I wonder if the device was in some sleep/power save mode for too long.


EDIT by tokaru: I have had the same issue today (1.0.7.16), so I am adding some information about my incident here, hope it helps with debugging.

Jolla's alarm always worked reliantly for me and never failed to wake me up at the time it should, but today I literally had to wake the phone up to be alarmed. The alarm was set to 7:00 (the same alarm I am using nearly every day for months) but did not go off this time. I was already awake by that time, so I am sure that I did not turn it off while still being asleep. Not knowing how late it was, I activated the display at ~ 7:11 to check the time, the alarm then started immediately upon my interaction.

Here are some excerpts from journalctl which I believe contain helpful information for the developers (if I can help with more information, pls let me know), note that there is actually not a single log message between 07:00:02 and 07:11:57, omissions are marked with [...].

Jun 25 07:00:00 Jolla systemd[1]: Time has been changed
[...]
Jun 25 07:00:00 Jolla dbus-daemon[891]: Activating via systemd: service name='com.nokia.voland' unit='jolla-alarm-ui.service'
Jun 25 07:00:00 Jolla systemd[884]: Starting Alarm ui...
Jun 25 07:00:00 Jolla [6646]: [W] MGConfItem::update_value:77 - MGConfItem Failed to read "/desktop/jolla/silica_framerate"
Jun 25 07:00:00 Jolla dbus-daemon[891]: Successfully activated service 'com.nokia.voland'
Jun 25 07:00:00 Jolla systemd[884]: Started Alarm ui.
Jun 25 07:00:02 Jolla timed-qt5[888]: ERROR: Voland call 'create' failed, message: 'No such object path '/com/nokia/voland''
Jun 25 07:00:02 Jolla dbus-daemon[891]: Activating via systemd: service name='com.nokia.voland' unit='jolla-alarm-ui.service'
Jun 25 07:00:02 Jolla systemd[884]: Starting Alarm ui...
Jun 25 07:00:02 Jolla systemd[884]: Starting Alarm ui...
Jun 25 07:11:57 Jolla kernel: PM: suspend entry 2014-06-25 05:00:02.583283553 UTC
Jun 25 07:11:57 Jolla systemd[1]: Time has been changed
[...]
Jun 25 07:11:57 Jolla kernel: [TP] sent power key event
Jun 25 07:11:57 Jolla kernel: request_suspend_state: wakeup (3->0) at 38464040938596 (2014-06-25 05:11:57.625910197 UTC)
[...]
Jun 25 07:11:58 Jolla booster-silica-qt5[6825]: [W] MGConfItem::update_value:77 - MGConfItem Failed to read "/desktop/jolla/theme/font/sizeMultiplier"
Jun 25 07:11:58 Jolla booster-silica-qt5[6825]: [W] MGConfItem::update_value:77 - MGConfItem Failed to read "/desktop /jolla/theme/font/sizeThreshold"
Jun 25 07:11:58 Jolla booster-silica-qt5[6825]: [W] MGConfItem::update_value:77 - MGConfItem Failed to read "/desktop/sailfish/silica/theme_pixel_ratio"
Jun 25 07:11:58 Jolla [6825]: [W] MGConfItem::update_value:77 - MGConfItem Failed to read "/desktop/jolla/silica_framerate"
Jun 25 07:11:58 Jolla dbus-daemon[891]: Successfully activated service 'com.nokia.voland'
Jun 25 07:11:58 Jolla systemd[884]: Started Alarm ui.
edit retag flag offensive close delete

Comments

version 1.0.2.5?

Stskeeps ( 2014-01-04 11:29:17 +0200 )edit

Yes 1.0.2.5.

mcfrisk ( 2014-01-04 13:18:58 +0200 )edit
1

I've noticed that if alarm time is set near in the future, like a couple of minutes, it might not work or only play alarm when you turn display on & unlock. Maybe it also has problems with multiple alarms close to each other? I will be testing this, hoping I'll wake up...

hana ( 2014-01-08 19:38:15 +0200 )edit

same issue here: setting the alarm in the near future (and switching off the device -in order to experiment a solution for another bug/issue) it simply doesn't work. Using it for morning alarm (<6hours later) it works perfectly on-time.

thewas ( 2014-01-31 00:16:19 +0200 )edit

Are you experiencing alarms that go off late in 1.0.3.8?

PMG ( 2014-02-26 14:09:55 +0200 )edit

1 Answer

Sort by » oldest newest most voted
3

answered 2014-06-27 15:29:19 +0200

spiiroin gravatar image

@tokaru: Thanks for the journal!

Looks like: device wakes up from suspend at correct time, but alarm ui startup fails / is delayed and device falls back to suspend. (The alarm ui finally starts up when power key was pressed -> alarm shows up, but almost 12 minutes late)

Created internal bug ticket for this.

edit flag offensive delete publish link more

Great, thanks for this :) Let me know if you need anything else. By the way, this did not happen again, so far.

tokaru ( 2014-06-29 12:19:07 +0200 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2014-01-04 06:55:43 +0200

Seen: 558 times

Last updated: Jun 27 '14