Ask / Submit

Revision history [back]

click to hide/show revision 1
initial version

posted 2016-10-06 09:59:35 +0300

Sailfish OS 2.0: proxy settings for WLAN

In my new Aquafish, the WLAN is behind proxy. My proxy is a http one; i.e. it is http://10.3.100.207:8080. I could use the same for http and https. It works smoothly in my laptop where I am using Manjaro.

Unfortunately, the proxy settings in Aquafish ask to use https::// for https proxy. I could not use http scheme. The main issue is that WLAN is not working. I have searched through this together.jolla.com and all the questions are 2 year old questions and seems that there is not solid answer. Only one work around I could see is using redsocks and libevent and modifying iptables settings or something. As I am newbie to this OS, I am reluctant to play with it by modifying things through terminal. (However, I am ready to try something through terminal if proper documentation is available which not available as of now from my perspective)

So my questions are: Kindly let me know the method for setting the proxy value a http://10.3.100.207:8080 for all_proxy. It will be great if I could know if someone could make it work in their phone and their method.

Regards, Sree

Sailfish OS 2.0: proxy settings for WLAN

In my new Aquafish, the WLAN is behind proxy. My proxy is a http one; i.e. it is http://10.3.100.207:8080. I could use the same for http and https. It works smoothly in my laptop where I am using Manjaro.

Unfortunately, the proxy settings in Aquafish ask to use https::// for https proxy. I could not use http scheme. The main issue is that WLAN is not working. I have searched through this together.jolla.com and all the questions are 2 year old questions and seems that there is not solid answer. Only one work around I could see is using redsocks and libevent and modifying iptables settings or something. As I am newbie to this OS, I am reluctant to play with it by modifying things through terminal. (However, I am ready to try something through terminal if proper documentation is available which not available as of now from my perspective)

So my questions are: Kindly let me know the method for setting the proxy value a http://10.3.100.207:8080 for all_proxy. It will be great if I could know if someone could make it work in their phone and their method.

Regards, Sree

Sailfish OS 2.0: proxy settings for WLAN

In my new Aquafish, the WLAN is behind proxy. My proxy is a http one; i.e. it is http://10.3.100.207:8080. I could use the same for http and https. It works smoothly in my laptop where I am using Manjaro.

Unfortunately, the proxy settings in Aquafish ask to use https::// for https proxy. I could not use http scheme. The main issue is that WLAN is not working. I have searched through this together.jolla.com and all the questions are 2 year old questions and seems that there is not solid answer. Only one work around I could see is using redsocks and libevent and modifying iptables settings or something. As I am newbie to this OS, I am reluctant to play with it by modifying things through terminal. (However, I am ready to try something through terminal if proper documentation is available which not available as of now from my perspective)

So my questions are: Kindly let me know the method for setting the proxy value a http://10.3.100.207:8080 for all_proxy. It will be great if I could know if someone could make it work in their phone and their method.

Do we have any files (like /etc/environment, .bashrc or proxy.sh ) which could be modified so that my mobile will use the proxy settings. I am facing lots of issues as I am forced to use the paid data packs in 24 X 7 WiFi zone. Please help. None of the questions in the together.jolla regarding the proxy is answered properly. Please help

Regards, Sree

Sailfish OS 2.0: proxy settings for WLAN

In my new Aquafish, the WLAN is behind proxy. My proxy is a http one; i.e. it is http://10.3.100.207:8080. I could use the same for http and https. It works smoothly in my laptop where I am using Manjaro.

Unfortunately, the proxy settings in Aquafish ask to use https::// for https proxy. I could not use http scheme. The main issue is that WLAN is not working. I have searched through this together.jolla.com and all the questions are 2 year old questions and seems that there is not solid answer. Only one work around I could see is using redsocks and libevent and modifying iptables settings or something. As I am newbie to this OS, I am reluctant to play with it by modifying things through terminal. (However, I am ready to try something through terminal if proper documentation is available which not available as of now from my perspective)

So my questions are: Kindly let me know the method for setting the proxy value a http://10.3.100.207:8080 for all_proxy. It will be great if I could know if someone could make it work in their phone and their method.

Do we have any files (like /etc/environment, .bashrc or proxy.sh ) which could be modified so that my mobile will use the proxy settings. I am facing lots of issues as I am forced to use the paid data packs in 24 X 7 WiFi zone. Please help. None of the questions in the together.jolla regarding the proxy is answered properly. Please help

Edited after 2.0.4 update.

The issue with proxy still persists. Still the browser and jolla store is not taking the proxy.

Regards, Sree

Sailfish OS 2.0: proxy settings for WLAN

In my new Aquafish, the WLAN is behind proxy. My proxy is a http one; i.e. it is http://10.3.100.207:8080. I could use the same for http and https. It works smoothly in my laptop where I am using Manjaro.

Unfortunately, the proxy settings in Aquafish ask to use https::// for https proxy. I could not use http scheme. The main issue is that WLAN is not working. I have searched through this together.jolla.com and all the questions are 2 year old questions and seems that there is not solid answer. Only one work around I could see is using redsocks and libevent and modifying iptables settings or something. As I am newbie to this OS, I am reluctant to play with it by modifying things through terminal. (However, I am ready to try something through terminal if proper documentation is available which not available as of now from my perspective)

So my questions are: Kindly let me know the method for setting the proxy value a http://10.3.100.207:8080 for all_proxy. It will be great if I could know if someone could make it work in their phone and their method.

Do we have any files (like /etc/environment, .bashrc or proxy.sh ) which could be modified so that my mobile will use the proxy settings. I am facing lots of issues as I am forced to use the paid data packs in 24 X 7 WiFi zone. Please help. None of the questions in the together.jolla regarding the proxy is answered properly. Please help

Edited after 2.0.4 update.

The issue with proxy still persists. Still the browser and jolla store is not taking the proxy.

I would really appreciate if anybody could provide some method to use the proxy as it is not working and stuck for long time. I tried setting http_proxy and HTTP_PROXY in /etc/profile.d. But it is not working.

Regards, Sree

Sailfish OS 2.0: proxy settings for WLAN

In my new Aquafish, the WLAN is behind proxy. My proxy is a http one; i.e. it is http://10.3.100.207:8080. I could use the same for http and https. It works smoothly in my laptop where I am using Manjaro.

Unfortunately, the proxy settings in Aquafish ask to use https::// for https proxy. I could not use http scheme. The main issue is that WLAN is not working. I have searched through this together.jolla.com and all the questions are 2 year old questions and seems that there is not solid answer. Only one work around I could see is using redsocks and libevent and modifying iptables settings or something. As I am newbie to this OS, I am reluctant to play with it by modifying things through terminal. (However, I am ready to try something through terminal if proper documentation is available which not available as of now from my perspective)

So my questions are: Kindly let me know the method for setting the proxy value a http://10.3.100.207:8080 for all_proxy. It will be great if I could know if someone could make it work in their phone and their method.

Do we have any files (like /etc/environment, .bashrc or proxy.sh ) which could be modified so that my mobile will use the proxy settings. I am facing lots of issues as I am forced to use the paid data packs in 24 X 7 WiFi zone. Please help. None of the questions in the together.jolla regarding the proxy is answered properly. Please help

Edited after 2.0.4 update.

The issue with proxy still persists. Still the browser and jolla store is not taking the proxy.

I would really appreciate if anybody could provide some method to use the proxy as it is not working and stuck for long time. I tried setting http_proxy and HTTP_PROXY in /etc/profile.d. But it is not working.

----------------EDIT ---------------------due to frustration -----------------------------------------------------------------

I feel so bad that I could not get any response that could fix the issue so far. Everyday I visit this page and see if somebody replied. I think I have tried almost everything I know about linux configurations. Another option was to change the ip-tables, installing sudo and all. It looks complicated for me and seems insecure for me. Hence I didn't go for it. (Again for that - to install the sudo we need to change the repo and all). It is very frustrating when you pay for data when you are staying in 24 X 7 free wifi zone.

Regards, Sree

Sailfish OS 2.0: proxy settings for WLAN

In my new Aquafish, the WLAN is behind proxy. My proxy is a http one; i.e. it is http://10.3.100.207:8080. I could use the same for http and https. It works smoothly in my laptop where I am using Manjaro.

Unfortunately, the proxy settings in Aquafish ask to use https::// for https proxy. I could not use http scheme. The main issue is that WLAN is not working. I have searched through this together.jolla.com and all the questions are 2 year old questions and seems that there is not solid answer. Only one work around I could see is using redsocks and libevent and modifying iptables settings or something. As I am newbie to this OS, I am reluctant to play with it by modifying things through terminal. (However, I am ready to try something through terminal if proper documentation is available which not available as of now from my perspective)

So my questions are: Kindly let me know the method for setting the proxy value a http://10.3.100.207:8080 for all_proxy. It will be great if I could know if someone could make it work in their phone and their method.

Do we have any files (like /etc/environment, .bashrc or proxy.sh ) which could be modified so that my mobile will use the proxy settings. I am facing lots of issues as I am forced to use the paid data packs in 24 X 7 WiFi zone. Please help. None of the questions in the together.jolla regarding the proxy is answered properly. Please help

Edited after 2.0.4 update.

The issue with proxy still persists. Still the browser and jolla store is not taking the proxy.

I would really appreciate if anybody could provide some method to use the proxy as it is not working and stuck for long time. I tried setting http_proxy and HTTP_PROXY in /etc/profile.d. But it is not working.

----------------EDIT ---------------------due to frustration -----------------------------------------------------------------

I feel so bad that I could not get any response that could fix the issue so far. Everyday I visit this page and see if somebody replied. I think I have tried almost everything I know about linux configurations. Another option was to change the ip-tables, installing sudo and all. It looks complicated for me and seems insecure for me. Hence I didn't go for it. (Again for that - to install the sudo we need to change the repo and all). It is very frustrating when you pay for data when you are staying in 24 X 7 free wifi zone.

Regards, Sree

Sailfish OS 2.0: proxy settings for WLAN

In my new Aquafish, the WLAN is behind proxy. My proxy is a http one; i.e. it is http://10.3.100.207:8080. I could use the same for http and https. It works smoothly in my laptop where I am using Manjaro.

Unfortunately, the proxy settings in Aquafish ask to use https::// for https proxy. I could not use http scheme. The main issue is that WLAN is not working. I have searched through this together.jolla.com and all the questions are 2 year old questions and seems that there is not solid answer. Only one work around I could see is using redsocks and libevent and modifying iptables settings or something. As I am newbie to this OS, I am reluctant to play with it by modifying things through terminal. (However, I am ready to try something through terminal if proper documentation is available which not available as of now from my perspective)

So my questions are: Kindly let me know the method for setting the proxy value a http://10.3.100.207:8080 for all_proxy. It will be great if I could know if someone could make it work in their phone and their method.

Do we have any files (like /etc/environment, .bashrc or proxy.sh ) which could be modified so that my mobile will use the proxy settings. I am facing lots of issues as I am forced to use the paid data packs in 24 X 7 WiFi zone. Please help. None of the questions in the together.jolla regarding the proxy is answered properly. Please help

Edited after 2.0.4 update.

The issue with proxy still persists. Still the browser and jolla store is not taking the proxy.

I would really appreciate if anybody could provide some method to use the proxy as it is not working and stuck for long time. I tried setting http_proxy and HTTP_PROXY in /etc/profile.d. But it is not working.

----------------EDIT ---------------------due to frustration -----------------------------------------------------------------

I feel so bad that I could not get any response that could fix the issue so far. Everyday I visit this page and see if somebody replied. I think I have tried almost everything I know about linux configurations. Another option was to change the ip-tables, installing sudo and all. It looks complicated for me and seems insecure for me. Hence I didn't go for it. (Again for that - to install the sudo we need to change the repo and all). It is very frustrating when you pay for data when you are staying in 24 X 7 free wifi zone.

EDIT - something has been worked - but don't know the reason

Today when I checked I have seen that in developer terminal I could see HTTPS_PROXY. Hence I tried to access browser from there and I could connect to internet. But when I tried store-client it didn't work properly. It asks for different login and stuffs. It seems that the proxy value is not available at GUI for any application. I am not sure why is it happening like this.

If anybody got some hint how I could use the applications without running from the terminal.

Regards, Sree

[Bug / New Feature Requirement] Sailfish OS 2.0: proxy settings for WLAN

In my new Aquafish, the WLAN is behind proxy. My proxy is a http one; i.e. it is http://10.3.100.207:8080. I could use the same for http and https. It works smoothly in my laptop where I am using Manjaro.

Unfortunately, the proxy settings in Aquafish ask to use https::// for https proxy. I could not use http scheme. The main issue is that WLAN is not working. I have searched through this together.jolla.com and all the questions are 2 year old questions and seems that there is not solid answer. Only one work around I could see is using redsocks and libevent and modifying iptables settings or something. As I am newbie to this OS, I am reluctant to play with it by modifying things through terminal. (However, I am ready to try something through terminal if proper documentation is available which not available as of now from my perspective)

So my questions are: Kindly let me know the method for setting the proxy value a http://10.3.100.207:8080 for all_proxy. It will be great if I could know if someone could make it work in their phone and their method.

Do we have any files (like /etc/environment, .bashrc or proxy.sh ) which could be modified so that my mobile will use the proxy settings. I am facing lots of issues as I am forced to use the paid data packs in 24 X 7 WiFi zone. Please help. None of the questions in the together.jolla regarding the proxy is answered properly. Please help

Edited after 2.0.4 update.

The issue with proxy still persists. Still the browser and jolla store is not taking the proxy.

I would really appreciate if anybody could provide some method to use the proxy as it is not working and stuck for long time. I tried setting http_proxy and HTTP_PROXY in /etc/profile.d. But it is not working.

----------------EDIT ---------------------due to frustration -----------------------------------------------------------------

I feel so bad that I could not get any response that could fix the issue so far. Everyday I visit this page and see if somebody replied. I think I have tried almost everything I know about linux configurations. Another option was to change the ip-tables, installing sudo and all. It looks complicated for me and seems insecure for me. Hence I didn't go for it. (Again for that - to install the sudo we need to change the repo and all). It is very frustrating when you pay for data when you are staying in 24 X 7 free wifi zone.

EDIT - something has been worked - but don't know the reason

Today when I checked I have seen that in developer terminal I could see HTTPS_PROXY. HTTPS_PROXY as I have set the env variables in profile.d/proxy.sh. Hence I tried to access browser from there and I could connect to internet. But when I tried store-client it didn't work properly. It asks for different login and stuffs. It seems that the proxy value is not available at GUI for any application. I am not sure why is it happening like this.

If anybody got some hint how I could use the applications without running from the terminal.

Just to Bring Up My Post (BUMP).

Developers, please help.

Regards, Sree

[Bug / New Feature Requirement] Sailfish OS 2.0: proxy settings for WLAN

In my new Aquafish, the WLAN is behind proxy. My proxy is a http one; i.e. it is http://10.3.100.207:8080. I could use the same for http and https. It works smoothly in my laptop where I am using Manjaro.

Unfortunately, the proxy settings in Aquafish ask to use https::// for https proxy. I could not use http scheme. The main issue is that WLAN is not working. I have searched through this together.jolla.com and all the questions are 2 year old questions and seems that there is not solid answer. Only one work around I could see is using redsocks and libevent and modifying iptables settings or something. As I am newbie to this OS, I am reluctant to play with it by modifying things through terminal. (However, I am ready to try something through terminal if proper documentation is available which not available as of now from my perspective)

So my questions are: Kindly let me know the method for setting the proxy value a http://10.3.100.207:8080 for all_proxy. It will be great if I could know if someone could make it work in their phone and their method.

Do we have any files (like /etc/environment, .bashrc or proxy.sh ) which could be modified so that my mobile will use the proxy settings. I am facing lots of issues as I am forced to use the paid data packs in 24 X 7 WiFi zone. Please help. None of the questions in the together.jolla regarding the proxy is answered properly. Please help

Edited after 2.0.4 update.

The issue with proxy still persists. Still the browser and jolla store is not taking the proxy.

I would really appreciate if anybody could provide some method to use the proxy as it is not working and stuck for long time. I tried setting http_proxy and HTTP_PROXY in /etc/profile.d. But it is not working.

----------------EDIT ---------------------due to frustration -----------------------------------------------------------------

I feel so bad that I could not get any response that could fix the issue so far. Everyday I visit this page and see if somebody replied. I think I have tried almost everything I know about linux configurations. Another option was to change the ip-tables, installing sudo and all. It looks complicated for me and seems insecure for me. Hence I didn't go for it. (Again for that - to install the sudo we need to change the repo and all). It is very frustrating when you pay for data when you are staying in 24 X 7 free wifi zone.

EDIT - something has been worked - but don't know the reason

Today when I checked I have seen that in developer terminal I could see HTTPS_PROXY as I have set the env variables in profile.d/proxy.sh. Hence I tried to access browser from there and I could connect to internet. But when I tried store-client it didn't work properly. It asks for different login and stuffs. It seems that the proxy value is not available at GUI for any application. I am not sure why is it happening like this.

If anybody got some hint how I could use the applications without running from the terminal.

Just to Bring Up My Post (BUMP). Again BUMP

Developers, please help.

Regards, Sree

[Bug / New Feature Requirement] Sailfish OS 2.0: proxy settings for WLAN

In my new Aquafish, the WLAN is behind proxy. My proxy is a http one; i.e. it is http://10.3.100.207:8080. I could use the same for http and https. It works smoothly in my laptop where I am using Manjaro.

Unfortunately, the proxy settings in Aquafish ask to use https::// for https proxy. I could not use http scheme. The main issue is that WLAN is not working. I have searched through this together.jolla.com and all the questions are 2 year old questions and seems that there is not solid answer. Only one work around I could see is using redsocks and libevent and modifying iptables settings or something. As I am newbie to this OS, I am reluctant to play with it by modifying things through terminal. (However, I am ready to try something through terminal if proper documentation is available which not available as of now from my perspective)

So my questions are: Kindly let me know the method for setting the proxy value a http://10.3.100.207:8080 for all_proxy. It will be great if I could know if someone could make it work in their phone and their method.

Do we have any files (like /etc/environment, .bashrc or proxy.sh ) which could be modified so that my mobile will use the proxy settings. I am facing lots of issues as I am forced to use the paid data packs in 24 X 7 WiFi zone. Please help. None of the questions in the together.jolla regarding the proxy is answered properly. Please help

Edited after 2.0.4 update.

The issue with proxy still persists. Still the browser and jolla store is not taking the proxy.

I would really appreciate if anybody could provide some method to use the proxy as it is not working and stuck for long time. I tried setting http_proxy and HTTP_PROXY in /etc/profile.d. But it is not working.

----------------EDIT ---------------------due to frustration -----------------------------------------------------------------

I feel so bad that I could not get any response that could fix the issue so far. Everyday I visit this page and see if somebody replied. I think I have tried almost everything I know about linux configurations. Another option was to change the ip-tables, installing sudo and all. It looks complicated for me and seems insecure for me. Hence I didn't go for it. (Again for that - to install the sudo we need to change the repo and all). It is very frustrating when you pay for data when you are staying in 24 X 7 free wifi zone.

EDIT - something has been worked - but don't know the reason

Today when I checked I have seen that in developer terminal I could see HTTPS_PROXY as I have set the env variables in profile.d/proxy.sh. Hence I tried to access browser from there and I could connect to internet. But when I tried store-client it didn't work properly. It asks for different login and stuffs. It seems that the proxy value is not available at GUI for any application. I am not sure why is it happening like this.

If anybody got some hint how I could use the applications without running from the terminal.

Just to Bring Up My Post (BUMP). Again BUMP . Again BUMP

I know that bringing up the same post again and again is not good. But I don't have any other way out. If I knew, how to fix it, I could have fixed earlier :( Developers, please help.

Regards, Sree

[Bug / New Feature Requirement] Sailfish OS 2.0: proxy settings for WLAN

In my new Aquafish, the WLAN is behind proxy. My proxy is a http one; i.e. it is http://10.3.100.207:8080. I could use the same for http and https. It works smoothly in my laptop where I am using Manjaro.

Unfortunately, the proxy settings in Aquafish ask to use https::// for https proxy. I could not use http scheme. The main issue is that WLAN is not working. I have searched through this together.jolla.com and all the questions are 2 year old questions and seems that there is not solid answer. Only one work around I could see is using redsocks and libevent and modifying iptables settings or something. As I am newbie to this OS, I am reluctant to play with it by modifying things through terminal. (However, I am ready to try something through terminal if proper documentation is available which not available as of now from my perspective)

So my questions are: Kindly let me know the method for setting the proxy value a http://10.3.100.207:8080 for all_proxy. It will be great if I could know if someone could make it work in their phone and their method.

Do we have any files (like /etc/environment, .bashrc or proxy.sh ) which could be modified so that my mobile will use the proxy settings. I am facing lots of issues as I am forced to use the paid data packs in 24 X 7 WiFi zone. Please help. None of the questions in the together.jolla regarding the proxy is answered properly. Please help

Edited after 2.0.4 update.

The issue with proxy still persists. Still the browser and jolla store is not taking the proxy.

I would really appreciate if anybody could provide some method to use the proxy as it is not working and stuck for long time. I tried setting http_proxy and HTTP_PROXY in /etc/profile.d. But it is not working.

----------------EDIT ---------------------due to frustration -----------------------------------------------------------------

I feel so bad that I could not get any response that could fix the issue so far. Everyday I visit this page and see if somebody replied. I think I have tried almost everything I know about linux configurations. Another option was to change the ip-tables, installing sudo and all. It looks complicated for me and seems insecure for me. Hence I didn't go for it. (Again for that - to install the sudo we need to change the repo and all). It is very frustrating when you pay for data when you are staying in 24 X 7 free wifi zone.

EDIT - something has been worked - but don't know the reason

Today when I checked I have seen that in developer terminal I could see HTTPS_PROXY as I have set the env variables in profile.d/proxy.sh. Hence I tried to access browser from there and I could connect to internet. But when I tried store-client it didn't work properly. It asks for different login and stuffs. It seems that the proxy value is not available at GUI for any application. I am not sure why is it happening like this.

If anybody got some hint how I could use the applications without running from the terminal.

Just to Bring Up My Post (BUMP). Again BUMP . Again BUMP

I know that bringing up the same post again and again is not good. But I don't have any other way out. If I knew, how to fix it, I could have fixed earlier :( Developers, please help.

New update:

IF I could run harbour apps from terminal the it uses the proxy. But the android apps won't use the proxy even if it is ran from terminal. Kindly do the needful to use the proxy even if it access directly.

Regards, Sree

[Bug / New Feature Requirement] Sailfish OS 2.0: proxy settings for WLAN

In my new Aquafish, the WLAN is behind proxy. My proxy is a http one; i.e. it is http://10.3.100.207:8080. I could use the same for http and https. It works smoothly in my laptop where I am using Manjaro.

Unfortunately, the proxy settings in Aquafish ask to use https::// for https proxy. I could not use http scheme. The main issue is that WLAN is not working. I have searched through this together.jolla.com and all the questions are 2 year old questions and seems that there is not solid answer. Only one work around I could see is using redsocks and libevent and modifying iptables settings or something. As I am newbie to this OS, I am reluctant to play with it by modifying things through terminal. (However, I am ready to try something through terminal if proper documentation is available which not available as of now from my perspective)

So my questions are: Kindly let me know the method for setting the proxy value a http://10.3.100.207:8080 for all_proxy. It will be great if I could know if someone could make it work in their phone and their method.

Do we have any files (like /etc/environment, .bashrc or proxy.sh ) which could be modified so that my mobile will use the proxy settings. I am facing lots of issues as I am forced to use the paid data packs in 24 X 7 WiFi zone. Please help. None of the questions in the together.jolla regarding the proxy is answered properly. Please help

Edited after 2.0.4 update.

The issue with proxy still persists. Still the browser and jolla store is not taking the proxy.

I would really appreciate if anybody could provide some method to use the proxy as it is not working and stuck for long time. I tried setting http_proxy and HTTP_PROXY in /etc/profile.d. But it is not working.

----------------EDIT ---------------------due to frustration -----------------------------------------------------------------

I feel so bad that I could not get any response that could fix the issue so far. Everyday I visit this page and see if somebody replied. I think I have tried almost everything I know about linux configurations. Another option was to change the ip-tables, installing sudo and all. It looks complicated for me and seems insecure for me. Hence I didn't go for it. (Again for that - to install the sudo we need to change the repo and all). It is very frustrating when you pay for data when you are staying in 24 X 7 free wifi zone.

EDIT - something has been worked - but don't know the reason

Today when I checked I have seen that in developer terminal I could see HTTPS_PROXY as I have set the env variables in profile.d/proxy.sh. Hence I tried to access browser from there and I could connect to internet. But when I tried store-client it didn't work properly. It asks for different login and stuffs. It seems that the proxy value is not available at GUI for any application. I am not sure why is it happening like this.

If anybody got some hint how I could use the applications without running from the terminal.

Just to Bring Up My Post (BUMP). Again BUMP . Again BUMP

I know that bringing up the same post again and again is not good. But I don't have any other way out. If I knew, how to fix it, I could have fixed earlier :( Developers, please help.

New update:

IF I could run harbour apps from terminal the it uses the proxy. But the android apps won't use the proxy even if it is ran from terminal. Kindly do the needful to use the proxy even if it access directly.

New update: Now on Sailfish 2.1.2.3

I tried updating the about:config of the browser then the browser honours the proxy. Hence it go back to the original question, is there any config file which is honoured by all the applications like /etc/environment etc.. It would be great if somebody could let me know any config file which could be modified to use it across the OS.

Regards, Sree

[Bug / New Feature Requirement] Sailfish OS 2.0: proxy settings for WLAN

In my new Aquafish, the WLAN is behind proxy. My proxy is a http one; i.e. it is http://10.3.100.207:8080. I could use the same for http and https. It works smoothly in my laptop where I am using Manjaro.

Unfortunately, the proxy settings in Aquafish ask to use https::// for https proxy. I could not use http scheme. The main issue is that WLAN is not working. I have searched through this together.jolla.com and all the questions are 2 year old questions and seems that there is not solid answer. Only one work around I could see is using redsocks and libevent and modifying iptables settings or something. As I am newbie to this OS, I am reluctant to play with it by modifying things through terminal. (However, I am ready to try something through terminal if proper documentation is available which not available as of now from my perspective)

So my questions are: Kindly let me know the method for setting the proxy value a http://10.3.100.207:8080 for all_proxy. It will be great if I could know if someone could make it work in their phone and their method.

Do we have any files (like /etc/environment, .bashrc or proxy.sh ) which could be modified so that my mobile will use the proxy settings. I am facing lots of issues as I am forced to use the paid data packs in 24 X 7 WiFi zone. Please help. None of the questions in the together.jolla regarding the proxy is answered properly. Please help

Edited after 2.0.4 update.

The issue with proxy still persists. Still the browser and jolla store is not taking the proxy.

I would really appreciate if anybody could provide some method to use the proxy as it is not working and stuck for long time. I tried setting http_proxy and HTTP_PROXY in /etc/profile.d. But it is not working.

----------------EDIT ---------------------due to frustration -----------------------------------------------------------------

I feel so bad that I could not get any response that could fix the issue so far. Everyday I visit this page and see if somebody replied. I think I have tried almost everything I know about linux configurations. Another option was to change the ip-tables, installing sudo and all. It looks complicated for me and seems insecure for me. Hence I didn't go for it. (Again for that - to install the sudo we need to change the repo and all). It is very frustrating when you pay for data when you are staying in 24 X 7 free wifi zone.

EDIT - something has been worked - but don't know the reason

Today when I checked I have seen that in developer terminal I could see HTTPS_PROXY as I have set the env variables in profile.d/proxy.sh. Hence I tried to access browser from there and I could connect to internet. But when I tried store-client it didn't work properly. It asks for different login and stuffs. It seems that the proxy value is not available at GUI for any application. I am not sure why is it happening like this.

If anybody got some hint how I could use the applications without running from the terminal.

Just to Bring Up My Post (BUMP). Again BUMP . Again BUMP

I know that bringing up the same post again and again is not good. But I don't have any other way out. If I knew, how to fix it, I could have fixed earlier :( Developers, please help.

New update:

IF I could run harbour apps from terminal the it uses the proxy. But the android apps won't use the proxy even if it is ran from terminal. Kindly do the needful to use the proxy even if it access directly.

New update: Now on Sailfish 2.1.2.3

I tried updating the about:config of the browser then the browser honours the proxy. Hence it go back to the original question, is there any config file which is honoured by all the applications like /etc/environment etc.. It would be great if somebody could let me know any config file which could be modified to use it across the OS.

Just a reminder

Would it be possible for you to consider the proxy issues in coming update? It would be quiet useful for the people who are under instituional proxy.

Regards, Sree

[Bug / New Feature Requirement] Sailfish OS 2.0: proxy settings for WLAN

In my new Aquafish, the WLAN is behind proxy. My proxy is a http one; i.e. it is http://10.3.100.207:8080. I could use the same for http and https. It works smoothly in my laptop where I am using Manjaro.

Unfortunately, the proxy settings in Aquafish ask to use https::// for https proxy. I could not use http scheme. The main issue is that WLAN is not working. I have searched through this together.jolla.com and all the questions are 2 year old questions and seems that there is not solid answer. Only one work around I could see is using redsocks and libevent and modifying iptables settings or something. As I am newbie to this OS, I am reluctant to play with it by modifying things through terminal. (However, I am ready to try something through terminal if proper documentation is available which not available as of now from my perspective)

So my questions are: Kindly let me know the method for setting the proxy value a http://10.3.100.207:8080 for all_proxy. It will be great if I could know if someone could make it work in their phone and their method.

Do we have any files (like /etc/environment, .bashrc or proxy.sh ) which could be modified so that my mobile will use the proxy settings. I am facing lots of issues as I am forced to use the paid data packs in 24 X 7 WiFi zone. Please help. None of the questions in the together.jolla regarding the proxy is answered properly. Please help

Edited after 2.0.4 update.

The issue with proxy still persists. Still the browser and jolla store is not taking the proxy.

I would really appreciate if anybody could provide some method to use the proxy as it is not working and stuck for long time. I tried setting http_proxy and HTTP_PROXY in /etc/profile.d. But it is not working.

----------------EDIT ---------------------due to frustration -----------------------------------------------------------------

I feel so bad that I could not get any response that could fix the issue so far. Everyday I visit this page and see if somebody replied. I think I have tried almost everything I know about linux configurations. Another option was to change the ip-tables, installing sudo and all. It looks complicated for me and seems insecure for me. Hence I didn't go for it. (Again for that - to install the sudo we need to change the repo and all). It is very frustrating when you pay for data when you are staying in 24 X 7 free wifi zone.

EDIT - something has been worked - but don't know the reason

Today when I checked I have seen that in developer terminal I could see HTTPS_PROXY as I have set the env variables in profile.d/proxy.sh. Hence I tried to access browser from there and I could connect to internet. But when I tried store-client it didn't work properly. It asks for different login and stuffs. It seems that the proxy value is not available at GUI for any application. I am not sure why is it happening like this.

If anybody got some hint how I could use the applications without running from the terminal.

Just to Bring Up My Post (BUMP). Again BUMP . Again BUMP

I know that bringing up the same post again and again is not good. But I don't have any other way out. If I knew, how to fix it, I could have fixed earlier :( Developers, please help.

New update:

IF I could run harbour apps from terminal the it uses the proxy. But the android apps won't use the proxy even if it is ran from terminal. Kindly do the needful to use the proxy even if it access directly.

New update: Now on Sailfish 2.1.2.3

I tried updating the about:config of the browser then the browser honours the proxy. Hence it go back to the original question, is there any config file which is honoured by all the applications like /etc/environment etc.. It would be great if somebody could let me know any config file which could be modified to use it across the OS.

Just a reminder

Would it be possible for you to consider the proxy issues in coming update? It would be quiet useful for the people who are under instituional institutional proxy.

Just to Bring Up My Post (BUMP). Again BUMP . Again BUMP

I know that bringing up the same post again and again is not good. But I don't have any other way out. If I knew, how to fix it, I could have fixed earlier :( Hope it may be included in next update. :D

Regards, Sree