Ask / Submit

Revision history [back]

click to hide/show revision 1
initial version

posted 2016-10-12 23:58:56 +0300

[bug] Muted volume indicator is missing in 2.0.4

Where did it go? Before 2.0.4 there used to be an icon next to the battery percentage to indicate the ringtone/sounds is/are muted, but now it's gone and there is no indication whatsoever the ringtone is down to 0. I don't use any patches.

[bug] [bug in update process] Muted volume indicator is missing in 2.0.4

Where did it go? Before 2.0.4 there used to be an icon next to the battery percentage to indicate the ringtone/sounds is/are muted, but now it's gone and there is no indication whatsoever the ringtone is down to 0. I don't use any patches.

[bug in update process] language packs] Muted volume indicator is missing in 2.0.4missing

Where did it go? Before 2.0.4 there used to be an icon next to the battery percentage to indicate the ringtone/sounds is/are muted, but now it's gone and there is no indication whatsoever the ringtone is down to 0. I don't use any patches.

[bug in community language packs] Muted volume indicator is missing

Where did it go? Before 2.0.4 there used to be an icon next to the battery percentage to indicate the ringtone/sounds is/are muted, but now it's gone and there is no indication whatsoever the ringtone is down to 0. I don't use any patches.

[bug in community language packs] Muted volume indicator is missing

Where did it go? Before 2.0.4 there used to be an icon next to the battery percentage to indicate the ringtone/sounds is/are muted, but now it's gone and there is no indication whatsoever the ringtone is down to 0. I don't use any patches.

The issue presents only when using community language packs (Nederlands and Hungarian is available on OpenRepos).

The bug's root cause lies in the 14th line of the /usr/share/lipstick-jolla-home-qt5/statusarea/ProfileStatusIndicator.qml file where the Profile.name is blank when using a non built in language. Using the en_GB language the Profile.name changes between "general" and "silent".

[bug in community language packs] Muted volume indicator is missing

Where did it go? Before 2.0.4 there used to be an icon next to the battery percentage to indicate the ringtone/sounds is/are muted, but now it's gone and there is no indication whatsoever the ringtone is down to 0. I don't use any patches.

The issue presents occurs only when using community language packs (Nederlands and Hungarian is available on OpenRepos).

The bug's root cause lies in the 14th line of the /usr/share/lipstick-jolla-home-qt5/statusarea/ProfileStatusIndicator.qml file where the Profile.name is a blank string when using a non built in language. community language pack.

Using the en_GB built-in British English language the Profile.name changes between "general" and "silent"."silent" which cause the icon showing up properly.