Ask / Submit

Revision history [back]

click to hide/show revision 1
initial version

posted 2017-09-01 13:28:03 +0300

Failed update to 2.1.1, now user session won't start (no GUI)

I started the normal update process, through Settings, which said finished after an hour with "Cannot update at the time". The device remained in a weird state. When turned on, it will show the Jolla logo, load for a while then turn black. WLAN connects automatically and SSH is on, so I could connect to the phone.

I tried this:

# systemctl --state=failed
UNIT                           LOAD   ACTIVE SUB    DESCRIPTION
mount-sd@mmcblk1.service       loaded failed failed Handle sdcard
start-user-session.service     loaded failed failed Start User Session
systemd-tmpfiles-setup.service loaded failed failed Create Volatile Files and Directories
user@100000.service            loaded failed failed User Manager for UID 100000

I tried version --dup too:

# version --dup
REFRESHING CACHE AND DOWNLOADING PACKAGES
QDBusConnection: name 'org.freedesktop.PackageKit' had owner '' but we thought it was ':1.47'
Refreshing: 84%
Message: adaptation0: Store credentials not received. Not connected to D-Bus server
aliendalvik: Store credentials not received. Not connected to D-Bus server
customer-jolla: Store credentials not received. Not connected to D-Bus server
eas: Store credentials not received. Not connected to D-Bus server
store: [|] Valid metadata not found at specified URL(s)
xt9: Store credentials not received. Not connected to D-Bus server

Resolving: 84%
Error: nothing provides jolla-devicelock-daemon-encpartition needed by pattern:jolla-hw-adaptation-sbj-0.9.13-10.62.17.jolla.noarch
Finished transaction (status=2, runtime=24966ms)
UPGRADE NOT COMPLETE - Retry 1 of 9

Obviously, version --dup needs a user session to login to the Jolla server. I tried systemctl start user@100000, which won't work without devel-su (and I forgot the password).

What can I do, other than a full reset?

Failed update to 2.1.1, now user session won't start (no GUI)

I started the normal update process, through Settings, which said finished after an hour with "Cannot update at the time". The device remained in a weird state. When turned on, it will show the Jolla logo, load for a while then turn black. WLAN connects automatically and SSH is on, so I could connect to the phone.

I tried this:

# systemctl --state=failed
UNIT                           LOAD   ACTIVE SUB    DESCRIPTION
mount-sd@mmcblk1.service       loaded failed failed Handle sdcard
start-user-session.service     loaded failed failed Start User Session
systemd-tmpfiles-setup.service loaded failed failed Create Volatile Files and Directories
user@100000.service            loaded failed failed User Manager for UID 100000

I tried version --dup too:

# version --dup
REFRESHING CACHE AND DOWNLOADING PACKAGES
QDBusConnection: name 'org.freedesktop.PackageKit' had owner '' but we thought it was ':1.47'
Refreshing: 84%
Message: adaptation0: Store credentials not received. Not connected to D-Bus server
aliendalvik: Store credentials not received. Not connected to D-Bus server
customer-jolla: Store credentials not received. Not connected to D-Bus server
eas: Store credentials not received. Not connected to D-Bus server
store: [|] Valid metadata not found at specified URL(s)
xt9: Store credentials not received. Not connected to D-Bus server

Resolving: 84%
Error: nothing provides jolla-devicelock-daemon-encpartition needed by pattern:jolla-hw-adaptation-sbj-0.9.13-10.62.17.jolla.noarch
Finished transaction (status=2, runtime=24966ms)
UPGRADE NOT COMPLETE - Retry 1 of 9

Obviously, version --dup needs a user session to login to the Jolla server. I tried systemctl start user@100000, which won't work without devel-su (and I forgot the password).

What can I do, other than a full reset?reset? Can I somehow retrieve my password and manually start a user session? Note that I connect to SSH with keys, not with password.

Failed update to 2.1.1, now user session won't start (no GUI)

I started the normal update process, through Settings, which said finished after an hour with "Cannot update at the time". The device remained in a weird state. When turned on, it will show the Jolla logo, load for a while then turn black. WLAN connects automatically and SSH is on, so I could connect to the phone.

I tried this:

# systemctl --state=failed
UNIT                           LOAD   ACTIVE SUB    DESCRIPTION
mount-sd@mmcblk1.service       loaded failed failed Handle sdcard
start-user-session.service     loaded failed failed Start User Session
systemd-tmpfiles-setup.service loaded failed failed Create Volatile Files and Directories
user@100000.service            loaded failed failed User Manager for UID 100000

I tried version --dup too:

# version --dup
REFRESHING CACHE AND DOWNLOADING PACKAGES
QDBusConnection: name 'org.freedesktop.PackageKit' had owner '' but we thought it was ':1.47'
Refreshing: 84%
Message: adaptation0: Store credentials not received. Not connected to D-Bus server
aliendalvik: Store credentials not received. Not connected to D-Bus server
customer-jolla: Store credentials not received. Not connected to D-Bus server
eas: Store credentials not received. Not connected to D-Bus server
store: [|] Valid metadata not found at specified URL(s)
xt9: Store credentials not received. Not connected to D-Bus server

Resolving: 84%
Error: nothing provides jolla-devicelock-daemon-encpartition needed by pattern:jolla-hw-adaptation-sbj-0.9.13-10.62.17.jolla.noarch
Finished transaction (status=2, runtime=24966ms)
UPGRADE NOT COMPLETE - Retry 1 of 9

Obviously, version --dup needs a user session to login to the Jolla server. I tried systemctl start user@100000, which won't work without devel-su (and I forgot the password).

What can I do, other than a full reset? Can I somehow retrieve my password and manually start a user session? Note that I connect to SSH with keys, not with password.

Failed update to 2.1.1, now user session won't start (no GUI)

I started the normal update process, through Settings, which said finished after an hour with "Cannot update at the time". The device remained in a weird state. When turned on, it will show the Jolla logo, load for a while then turn black. WLAN connects automatically and SSH is on, so I could connect to the phone.

I tried this:

# systemctl --state=failed
UNIT                           LOAD   ACTIVE SUB    DESCRIPTION
mount-sd@mmcblk1.service       loaded failed failed Handle sdcard
start-user-session.service     loaded failed failed Start User Session
systemd-tmpfiles-setup.service loaded failed failed Create Volatile Files and Directories
user@100000.service            loaded failed failed User Manager for UID 100000

I tried version --dup too:

# version --dup
REFRESHING CACHE AND DOWNLOADING PACKAGES
QDBusConnection: name 'org.freedesktop.PackageKit' had owner '' but we thought it was ':1.47'
Refreshing: 84%
Message: adaptation0: Store credentials not received. Not connected to D-Bus server
aliendalvik: Store credentials not received. Not connected to D-Bus server
customer-jolla: Store credentials not received. Not connected to D-Bus server
eas: Store credentials not received. Not connected to D-Bus server
store: [|] Valid metadata not found at specified URL(s)
xt9: Store credentials not received. Not connected to D-Bus server

Resolving: 84%
Error: nothing provides jolla-devicelock-daemon-encpartition needed by pattern:jolla-hw-adaptation-sbj-0.9.13-10.62.17.jolla.noarch
Finished transaction (status=2, runtime=24966ms)
UPGRADE NOT COMPLETE - Retry 1 of 9

Obviously, version --dup needs a user session to login to the Jolla server. I tried systemctl start user@100000, which won't work without devel-su (and I forgot the password).

What can I do, other than a full reset? Can I somehow retrieve my password and manually start a user session? Note that I connect to SSH with keys, not with password.

EDIT: I manually changed the devel-su password in the recovery mode shell. Now I have access to better logs. This comes from journalctl -xe, after running systemctl start user@100000:

Sep 01 14:12:33 jollaphone systemd[1]: user@100000.service: Failed to load environment files: No such file or directory
Sep 01 14:12:33 jollaphone systemd[1]: user@100000.service: Failed to run 'start-pre' task: No such file or directory
Sep 01 14:12:33 jollaphone systemd[1]: Failed to start User Manager for UID 100000.
-- Subject: Unit user@100000.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit user@100000.service has failed.
-- 
-- The result is failed.
Sep 01 14:12:33 jollaphone systemd[1]: user@100000.service: Unit entered failed state.
Sep 01 14:12:33 jollaphone systemd[1]: user@100000.service: Failed with result 'resources'.
Sep 01 14:12:34 jollaphone systemd[1]: user@100000.service: Service hold-off time over, scheduling restart.
Sep 01 14:12:34 jollaphone systemd[1]: Stopped User Manager for UID 100000.
-- Subject: Unit user@100000.service has finished shutting down