Ask / Submit

Revision history [back]

click to hide/show revision 1
initial version

posted 2013-12-24 17:43:42 +0300

WPA2-PSK[AES] wifi support needed + workaround

Jolla needs to add support of suing WPA2-PSK[AES] for the wifi connections, as a lot of routers + workspaces + universities use it.

Currently there is an unofficial workaround which people can use.

a) activate devel-mode
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) turn on/off wlan (or reboot phone)

WPA2-PSK[AES] wifi support needed + workaround

Jolla needs to add support of suing using WPA2-PSK[AES] for the wifi connections, as a lot of routers + workspaces + universities use it.

Currently there is an unofficial workaround which people can use.

a) activate devel-mode
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

WPA2-PSK[AES] wifi support needed + workaround

Jolla needs to add support of using WPA2-PSK[AES] for the wifi connections, as a lot of routers + workspaces + universities use it.

Currently there is an unofficial workaround which people can use.

a) activate devel-mode
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

WPA2-PSK[AES] wifi support needed + workaround

Jolla needs to add support of using WPA2-PSK[AES] for the wifi connections, as a lot of routers + workspaces + universities use it.

Currently there is an unofficial workaround which people can use.

a) activate devel-mode
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

WPA2-PSK[AES] wifi support needed + workaround

Jolla needs to add support of using WPA2-PSK[AES] for the wifi connections, as a lot of routers + workspaces + universities use it.

Currently there is an unofficial workaround which people can use.

a) activate devel-mode
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

WPA2-PSK[AES] wifi support needed + workaround

Jolla needs to add support of using WPA2-PSK[AES] for the wifi connections, as a lot of routers + workspaces + universities use it.

Currently there is an unofficial workaround which people can use.

a) activate devel-mode
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

WPA2-PSK[AES] wifi support needed + workaround

Jolla needs to add support of using WPA2-PSK[AES] for the wifi connections, as a lot of routers + workspaces + universities use it.

Currently there is an unofficial workaround which people can use.

a) activate devel-mode
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

WPA2-PSK[AES] WPA2-PSK[AES]+[Others] wifi support needed + workaround

Jolla needs to add support of using WPA2-PSK[AES] for the wifi connections, as a lot of routers + workspaces + universities use it.

Currently there is an unofficial workaround which people can use.

a) activate devel-mode
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

WPA2-PSK[AES]+[Others] wifi support needed + workaround

Jolla needs to add support of using WPA2-PSK[AES] for the wifi connections, as a lot of routers + workspaces + universities use it.

Currently there is an unofficial workaround which people can use.

a) activate devel-mode
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

WPA2-PSK[AES]+[Others] wifi support needed + workaround

Jolla needs to add support of using WPA2-PSK[AES] for the wifi connections, as a lot of routers + workspaces + universities use it.

[The workaround as of 1.0.5.16 does not seem to work any-more]

Currently there is an unofficial workaround which people can use.

a) activate devel-mode
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

WPA2-PSK[AES]+[Others] wifi support needed + workaround

Jolla needs to add support of using WPA2-PSK[AES] for the wifi connections, as a lot of routers + workspaces + universities use it.

[The workaround as of 1.0.5.16 does not seem to [UPDATE] This fix works once again with new 1.0.7.16, Saapunki update. I only tested it on WPA2-PSK[AES] but it works Hope it will work any-more]for you too

Currently there is an unofficial workaround which people can use.

a) activate devel-mode
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

WPA2-PSK[AES]+[Others] WPA-802.1X (enteprise) +[Others] wifi support needed + workaround

Jolla needs to add support of using WPA2-PSK[AES] WPA-802.1X for the wifi connections, as a lot of routers + workspaces + universities use it.

[UPDATE] This fix works once again with new 1.0.7.16, Saapunki update. I only tested it on WPA2-PSK[AES] WPA-802.1X/EAP-PEAP but it works Hope it will work for you too

Currently there is an unofficial workaround which people can use.

a) activate devel-mode
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

WPA-802.1X (enteprise) +[Others] wifi support needed + workaround

Jolla needs to add support of using WPA-802.1X for the wifi connections, as a lot of routers + workspaces + universities use it.

[UPDATE] This fix works once again with new 1.0.7.16, Saapunki update. I only tested it on WPA-802.1X/EAP-PEAP but it works Hope it will work for you too

Currently there is an unofficial workaround which people can use.

a) activate devel-mode
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

WPA-802.1X (enteprise) +[Others] wifi support needed + workaround

Jolla needs to add support of using WPA-802.1X for the wifi connections, as a lot of routers + workspaces + universities use it.

[UPDATE] This fix works once again with new 1.0.7.16, Saapunki update. I only tested it on WPA-802.1X/EAP-PEAP but it works Hope it will work for you tootoo. You will still need to install the patched wpa_supplicant rpm provided in the second answer below.

Currently there is an unofficial workaround which people can use.

a) activate devel-mode
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

WPA-802.1X (enteprise) (enterprise) +[Others] wifi support needed + workaround

Jolla needs to add support of using WPA-802.1X for the wifi connections, as a lot of routers + workspaces + universities use it.

[UPDATE] This fix works once again with new 1.0.7.16, Saapunki update. I only tested it on WPA-802.1X/EAP-PEAP but it works Hope it will work for you too. You will still need to install the patched wpa_supplicant rpm provided in the second answer below.

Currently there is an unofficial workaround which people can use.

a) activate devel-mode
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

WPA-802.1X (enterprise) +[Others] GUI wifi support needed + workaround

Jolla needs to add support of using WPA-802.1X for the wifi connections, as a lot of routers + workspaces + universities use it.

[UPDATE] This fix works once again with new 1.0.7.16, Saapunki update. I only tested So the WPA Supplicant does work now but there is no GUI implementation of adding additional networks, you will need to use a workaround described below. To make things easier try to use SSH connection from your PC to Jolla, that should make it easier than typing it out on WPA-802.1X/EAP-PEAP but it works Hope it will work for you too. You will still need to install the patched wpa_supplicant rpm provided in the second answer below.screen keyboard.

How to SSH found here

Currently there is an unofficial workaround which people can use.

a) activate devel-mode
developer-mode (Settings->System->DeveloperMode)
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) save and exit
f) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

As an example here is my eduroam login for Univerisy connection

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
Phase1=0
Phase2=MSCHAPV2
Identity=********@glam.ac.uk
Passphrase=********

There was no need to specify the certificate

WPA-802.1X (enterprise) +[Others] GUI wifi support needed + workaround

[UPDATE]

Sad news :( 1.1.0.38 Uitukka does have issues with the wpa_supplicant and enterprise connections but there seems to be hope: From TMO forum: zlatko >>Ckick Here<<

Jolla needs to add support of using WPA-802.1X for the wifi connections, as a lot of routers + workspaces + universities use it.

So the WPA Supplicant does work now but there is no GUI implementation of adding additional networks, you will need to use a workaround described below. To make things easier try to use SSH connection from your PC to Jolla, that should make it easier than typing it out on screen keyboard.

How to SSH found here

Currently there is an unofficial workaround which people can use.

a) activate developer-mode (Settings->System->DeveloperMode)
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) save and exit
f) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

As an example here is my eduroam login for Univerisy connection

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
Phase1=0
Phase2=MSCHAPV2
Identity=********@glam.ac.uk
Passphrase=********

There was no need to specify the certificate

WPA-802.1X (enterprise) +[Others] GUI wifi support needed + workaround

[UPDATE]

Sad news :( 1.1.0.38 Uitukka does have have issues with the wpa_supplicant and and enterprise connections but there seems seems to be hope: hope: From TMO forum: zlatko >>Ckick Here<<

[**zlatko

Ckick Here<<**](http://talk.maemo.org/showpost.php?p=1443992&postcount=417)

Jolla needs to add support of using WPA-802.1X for the wifi connections, as a lot of routers + workspaces + universities use it.

So the WPA Supplicant does work now but there is no GUI implementation of adding additional networks, you will need to use a workaround described below. To make things easier try to use SSH connection from your PC to Jolla, that should make it easier than typing it out on screen keyboard.

How to SSH found here

Currently there is an unofficial workaround which people can use.

a) activate developer-mode (Settings->System->DeveloperMode)
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) save and exit
f) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

As an example here is my eduroam login for Univerisy connection

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
Phase1=0
Phase2=MSCHAPV2
Identity=********@glam.ac.uk
Passphrase=********

There was no need to specify the certificate

WPA-802.1X (enterprise) +[Others] GUI wifi support needed + workaround

[UPDATE]

Sad news :( 1.1.0.38 Uitukka does have have issues with the wpa_supplicant and and enterprise connections but there seems seems to be hope: From TMO forum: [**zlatko

Ckick Here<<**](http://talk.maemo.org/showpost.php?p=1443992&postcount=417)

zlatko >>Ckick Here<<

Jolla needs to add support of using WPA-802.1X for the wifi connections, as a lot of routers + workspaces + universities use it.

So the WPA Supplicant does work now but there is no GUI implementation of adding additional networks, you will need to use a workaround described below. To make things easier try to use SSH connection from your PC to Jolla, that should make it easier than typing it out on screen keyboard.

How to SSH found here

Currently there is an unofficial workaround which people can use.

a) activate developer-mode (Settings->System->DeveloperMode)
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) save and exit
f) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

As an example here is my eduroam login for Univerisy connection

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
Phase1=0
Phase2=MSCHAPV2
Identity=********@glam.ac.uk
Passphrase=********

There was no need to specify the certificate

WPA-802.1X (enterprise) +[Others] GUI wifi support needed + workaround

[UPDATE]

Sad news :( Update 1.1.0.38 Uitukka does currently has an issue with connman that crashes all connections (Wi-Fi and mobile data) when trying to connect to a WPA2 Enterprise network (saved in a custom config file as in this post). An official patch will be released soon, but if you have issues with the wpa_supplicant opted in to the update and enterprise connections but there seems to be hope: From TMO forum: zlatko >>Ckick Here<<can't wait for the official patch, you can install this rpm: http://repo.merproject.org/obs/home:/csslayer:/branches:/home:/tbr:/sailfish/latest_armv7hl/armv7hl/connman-1.24+git46+master.394.1.ga5393b5-10.6.1.jolla.armv7hl.rpm If you don't know what you're doing, don't update to 1.1.0.38 and don't install the patched rpm.

Jolla needs to add support of using WPA-802.1X for the wifi connections, as a lot of routers + workspaces + universities use it.

So the WPA Supplicant does work now but there is no GUI implementation of adding additional networks, you will need to use a workaround described below. To make things easier try to use SSH connection from your PC to Jolla, that should make it easier than typing it out on screen keyboard.

How to SSH found here

Currently there is an unofficial workaround which people can use.

a) activate developer-mode (Settings->System->DeveloperMode)
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) save and exit
f) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

As an example here is my eduroam login for Univerisy connection

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
Phase1=0
Phase2=MSCHAPV2
Identity=********@glam.ac.uk
Passphrase=********

There was no need to specify the certificate

WPA-802.1X (enterprise) +[Others] GUI wifi support needed + workaround

[UPDATE]

Update 1.1.0.38 Uitukka currently has an issue with connman that crashes all connections (Wi-Fi and mobile data) when trying to connect to a WPA2 Enterprise network (saved in a custom config file as in this post). An official patch will be released soon, but if you have opted in to the update and can't wait for the official patch, you can install this rpm: http://repo.merproject.org/obs/home:/csslayer:/branches:/home:/tbr:/sailfish/latest_armv7hl/armv7hl/connman-1.24+git46+master.394.1.ga5393b5-10.6.1.jolla.armv7hl.rpm If you don't know what you're doing, don't update to 1.1.0.38 and don't install the patched rpm.

Jolla needs to add support of using WPA-802.1X for the wifi connections, as a lot of routers + workspaces + universities use it.

So the WPA Supplicant does work now but there is no GUI implementation of adding additional networks, you will need to use a workaround described below. To make things easier try to use SSH connection from your PC to Jolla, that should make it easier than typing it out on screen keyboard.

How to SSH found here

Currently there is an unofficial workaround which people can use.

a) activate developer-mode (Settings->System->DeveloperMode)
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) save and exit
f) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

As an example here is my eduroam login for Univerisy connection

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
Phase1=0
Phase2=MSCHAPV2
Identity=********@glam.ac.uk
Passphrase=********

There was no need to specify the certificate

WPA-802.1X (enterprise) +[Others] GUI wifi support needed + workaround

Jolla needs to add support of using WPA-802.1X for the wifi connections, as a lot of routers + workspaces + universities use it.

So the WPA Supplicant does work now but there is no GUI implementation of adding additional networks, you will need to use a workaround described below. To make things easier try to use SSH connection from your PC to Jolla, that should make it easier than typing it out on screen keyboard.

How to SSH found here

Currently there is an unofficial workaround which people can use.

a) activate developer-mode (Settings->System->DeveloperMode)
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

Code:

wifi_eduroam.config: please note that entries seem to be case sensitive

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret
 

e) save and exit
f) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

As an example here is my eduroam login for Univerisy University connection

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
Phase1=0
Phase2=MSCHAPV2
Identity=********@glam.ac.uk
Passphrase=********

There was no need to specify the certificate


ChemIst's Eduroam Config for uni-kl.de please note that entries seem to be case sensitive

[service_eduroam]
Type=wifi
Name=eduroam
EAP=ttls
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=PAP
Identity=********@rhrk.uni-kl.de
Passphrase=********

[How-To] WPA-802.1X (enterprise) (enterprise), eduroam +[Others] GUI wifi support needed + workaround

Jolla needs to add support of using WPA-802.1X for the wifi connections, as a lot of routers + workspaces + universities use it.

So the WPA Supplicant does work now but there is no GUI implementation of adding additional networks, you will need to use a workaround described below. To make things easier try to use SSH connection from your PC to Jolla, that should make it easier than typing it out on screen keyboard.

How to SSH found here

Currently there is an unofficial workaround which people can use.

a) activate developer-mode (Settings->System->DeveloperMode)
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

wifi_eduroam.config: please note that entries seem to be case sensitive

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) save and exit
f) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

As an example here is my eduroam login for University connection

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
Phase1=0
Phase2=MSCHAPV2
Identity=********@glam.ac.uk
Passphrase=********

There was no need to specify the certificate


ChemIst's Eduroam Config for uni-kl.de please note that entries seem to be case sensitive

[service_eduroam]
Type=wifi
Name=eduroam
EAP=ttls
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=PAP
Identity=********@rhrk.uni-kl.de
Passphrase=********

[How-To] WPA-802.1X (enterprise), eduroam +[Others] GUI wifi support needed + workaround

Jolla needs to add support of using WPA-802.1X for the wifi connections, as a lot of routers + workspaces + universities use it.

So the WPA Supplicant does work now but there is no GUI implementation of adding additional networks, you will need to use a workaround described below. To make things easier try to use SSH connection from your PC to Jolla, that should make it easier than typing it out on screen keyboard.

How to SSH found here

Currently there is an unofficial workaround which people can use.

a) activate developer-mode (Settings->System->DeveloperMode)
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

wifi_eduroam.config: please note that entries seem to be case sensitive

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) save and exit
f) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

As an example here is my eduroam login for University connection

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
Phase1=0
Phase2=MSCHAPV2
Identity=********@glam.ac.uk
Passphrase=********

There was no need to specify the certificate


ChemIst's Eduroam Config for uni-kl.de please note that entries seem to be case sensitive

[service_eduroam]
Type=wifi
Name=eduroam
EAP=ttls
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=PAP
Identity=********@rhrk.uni-kl.de
Passphrase=********

[How-To] WPA-802.1X (enterprise), eduroam +[Others] GUI wifi support needed + workaround

Jolla needs to add support of using WPA-802.1X for the wifi connections, as a lot of routers + workspaces + universities use it.

So the WPA Supplicant does work now but there is no GUI implementation of adding additional networks, you will need to use a workaround described below. To make things easier try to use SSH connection from your PC to Jolla, that should make it easier than typing it out on screen keyboard.

How to SSH found here

Currently there is an unofficial workaround which people can use.

a) activate developer-mode (Settings->System->DeveloperMode)
b) use the terminal on the device or ssh to the device
c) install vim or any other text editor
d) vim /var/lib/connman/wifi_eduroam.config

wifi_eduroam.config: please note that entries seem to be case sensitive

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=MSCHAPV2
Identity=user@domain
Passphrase=yoursecret

e) save and exit
f) turn on/off wlan (or reboot phone)

Please feel free to contribute :)

if you want to install vim or nano please use the commands in terminal

nano:

pkcon install nano

vim:

pkcon install zypper
zypper in vim

[update]: nodevel has released a sailfish application which allows to create such networks, Feel free to have a loop at [Roamer](https://openrepos.net/content/nodevel/roamer)

As an example here is my eduroam login for University connection

[service_eduroam]
Type=wifi
Name=eduroam
EAP=peap
Phase1=0
Phase2=MSCHAPV2
Identity=********@glam.ac.uk
Passphrase=********

There was no need to specify the certificate


ChemIst's Eduroam Config for uni-kl.de please note that entries seem to be case sensitive

[service_eduroam]
Type=wifi
Name=eduroam
EAP=ttls
CACertFile=/etc/ssl/certs/ca-bundle.crt
Phase2=PAP
Identity=********@rhrk.uni-kl.de
Passphrase=********