Ask / Submit

Revision history [back]

click to hide/show revision 1
initial version

posted 2014-03-21 14:22:19 +0300

Beep is played in messaging instead of configured sound

After the recent update to Sailfish OS 1.0.4.20 (Ohijärvi) there is a regression in the Messaging app notifications. Short sound beep is triggered even if there is No sound configured in the Settings -> System -> Sounds and feedback -> Message. In case there is custom sound defined it's not played, just a short beep is triggered.

How to reproduce:

  1. Ensure you DON'T have Silence sounds enabled in Settings -> System -> Sounds and feedback. Also ensuse you have No sound configured for Message.
  2. Send SMS to your phone. New conversation thread will be created in the messaging app. No sound will be triggered. This is correct behavior.
  3. Open the thread and leave it open. The phone needs to stay awake and the messaging app openen inside the thread.
  4. Send another SMS to your phone. This time the SMS will trigger beep even if no sound is configured for SMS notification.

Temporary workaround:

Enable Silence sounds in Settings -> System -> Sounds and feedback.

Beep is played in messaging instead of configured sound

After the recent update to Sailfish OS 1.0.4.20 (Ohijärvi) there is a regression in the Messaging app notifications. Short sound beep is triggered even if there is No sound configured in the Settings -> System -> Sounds and feedback -> Message. In case there is custom sound defined it's not played, just a short beep is triggered.

How to reproduce:

  1. Ensure you DON'T have Silence sounds enabled in Settings -> System -> Sounds and feedback. Also ensuse you have No sound configured for Message.
  2. Send SMS to your phone. New conversation thread will be created in the messaging app. No sound will be triggered. This is correct behavior.
  3. Open the thread and leave it open. The phone needs to stay awake and the messaging app openen inside the thread.
  4. Send another SMS to your phone. This time the SMS will trigger beep even if no sound is configured for SMS notification.

Temporary workaround:

Enable Silence sounds in Settings -> System -> Sounds and feedback.