Ask / Submit

Revision history [back]

click to hide/show revision 1
initial version

posted 2014-05-06 11:18:21 +0200

Why is Jolla/sailfish so hard to connect to linux

The question is why is a Linux/opensorce phone so hard to sync/connect to a Linux computer ? Is should be as easy a a work in the park..!?.. but no !!! What is missing !!

Why is Jolla/sailfish so hard to connect to linux

The question is why is a Linux/opensorce phone so hard to sync/connect to a Linux computer ? Is should be as easy a a work in the park..!?.. but no !!! What is missing !!

Why is Jolla/sailfish so hard to connect to linux

The question is why is a Linux/opensorce phone so hard to sync/connect to a Linux computer ? Is should be as easy a a work in the park..!?.. but no !!! What is missing !!

Why is Jolla/sailfish so hard to connect to linux

The question is why is a Linux/opensorce phone so hard to sync/connect to a Linux computer ? Is should be as easy a a work in the park..!?.. but no !!! What is missing !!

Update : Ok, I see this issue still is hot and not solved in an nativ jolla app. So here is what I do at the moment. 1 : I have to be root - set under settings -> system ->developer mode . Set USB LAN to 192.168.1.11 set a SSH password 2 : make a script on my /home/(your user) f.eks. 'mountjolla'

START

#!/usr/bin/bash localIp='192.168.1.10/24' localBroadcast='192.168.1.255' netAdp=$1 mountPath='/home/(your user)/jolla' user='nemo' jollaIp='192.168.1.11'

sudo ip addr add $localIp broadcast $localBroadcast dev $netAdp

First umount if all ready mounted

fusermount -u $mountPath sleep 2 sshfs $user@$jollaIp:/home/$user -p 22 $mountPath

END

3 : do a "mkdir /home/(your user)/jolla . If it is not there allready 4 : do chmod 755 to your script "chmod 755 ~/mountjolla" 5 : plug usb cable in phone & computer 5a : if not check usbnet module is loaded with "lsmod" 6 : do "ip link" ( on Archlinux ) and I guess others Linux OS's 7: notice what net device pop up ( f.eks. enp0s29u1u2u1u3 ) 8 : run your script "mountjolla enp0s29u1u2u1u3" And you have you jolle "nemo" dir mounted at /home/(your user)/jolla !

9 : umount it with "fusermount -u /home/(your user)/jolla"

Still not a "easy way" tough :-/ but it works

Why is Jolla/sailfish so hard to connect to linux

The question is why is a Linux/opensorce phone so hard to sync/connect to a Linux computer ? Is should be as easy a a work in the park..!?.. but no !!! What is missing !!

Update : Ok, I see this issue still is hot and not solved in an nativ jolla app. So here is what I do at the moment. 1 : I have to be root - set under settings -> system ->developer mode . Set USB LAN to 192.168.1.11 set a SSH password 2 : make a script on my /home/(your user) f.eks. 'mountjolla'

START

## START
#!/usr/bin/bash
localIp='192.168.1.10/24'
localBroadcast='192.168.1.255' 
netAdp=$1
mountPath='/home/(your user)/jolla'
user='nemo'
jollaIp='192.168.1.11'

jollaIp='192.168.1.11' sudo ip addr add $localIp broadcast $localBroadcast dev $netAdp

$netAdp # First umount if all ready mounted

mounted fusermount -u $mountPath sleep 2 sshfs $user@$jollaIp:/home/$user -p 22 $mountPath

END

$mountPath ### END

3 : do a "mkdir /home/(your user)/jolla . If it is not there allready 4 : do chmod 755 to your script "chmod 755 ~/mountjolla" 5 : plug usb cable in phone & computer 5a : if not check usbnet module is loaded with "lsmod" 6 : do "ip link" ( on Archlinux ) and I guess others Linux OS's 7: notice what net device pop up ( f.eks. enp0s29u1u2u1u3 ) 8 : run your script "mountjolla enp0s29u1u2u1u3" And you have you jolle "nemo" dir mounted at /home/(your user)/jolla !

9 : umount it with "fusermount -u /home/(your user)/jolla"

Still not a "easy way" tough :-/ but it works

Why is Jolla/sailfish so hard to connect to linux

The question is why is a Linux/opensorce phone so hard to sync/connect to a Linux computer ? Is should be as easy a a work in the park..!?.. but no !!! What is missing !!

Update : Ok, I see this issue still is hot and not solved in an nativ jolla app. So here is what I do at the moment. 1 : I have to be root - set under settings -> system ->developer mode . Set USB LAN to 192.168.1.11 set a SSH password 2 : make a script on my /home/(your user) f.eks. 'mountjolla'

## START
#!/usr/bin/bash
localIp='192.168.1.10/24'
localBroadcast='192.168.1.255' 
netAdp=$1
mountPath='/home/(your user)/jolla'
user='nemo'
jollaIp='192.168.1.11'

sudo ip addr add $localIp broadcast $localBroadcast dev $netAdp
# First umount if all ready mounted
fusermount -u $mountPath
sleep 2
sshfs $user@$jollaIp:/home/$user -p 22 $mountPath
### END

3 : do a "mkdir /home/(your user)/jolla . If it is not there allready 4 : do chmod 755 to your script "chmod 755 ~/mountjolla" 5 : plug usb cable in phone & computer 5a : if not check usbnet module is loaded with "lsmod" 6 : do "ip link" ( on Archlinux ) and I guess others Linux OS's 7: notice what net device pop up ( f.eks. enp0s29u1u2u1u3 ) 8 : run your script "mountjolla enp0s29u1u2u1u3" And you have you jolle "nemo" dir mounted at /home/(your user)/jolla !

9 : umount it with "fusermount -u /home/(your user)/jolla"

Still not a an "easy way" tough :-/ but it works

Why is Jolla/sailfish so hard to connect to linux

The question is why is a Linux/opensorce phone so hard to sync/connect to a Linux computer ? Is should be as easy a a work in the park..!?.. but no !!! What is missing !!

Update : Ok, I see this issue still is hot and not solved in an nativ jolla app. So here is what I do at the moment. 1 :

  1. I have to be root - set under settings -> system ->developer mode . Set USB LAN to 192.168.1.11 192.168.1.11 set a SSH password 2 : password
  2. make a script on my /home/(your user) f.eks. 'mountjolla'

    ## START
    
  3. START

    #!/usr/bin/bash localIp='192.168.1.10/24' localBroadcast='192.168.1.255' netAdp=$1 mountPath='/home/(your user)/jolla' user='nemo' jollaIp='192.168.1.11' jollaIp='192.168.1.11'

    sudo ip addr add $localIp broadcast $localBroadcast dev $netAdp # $netAdp

    First umount if all ready mounted mounted

    fusermount -u $mountPath sleep 2 sshfs $user@$jollaIp:/home/$user -p 22 $mountPath ### END

    3 : $mountPath

    END

  4. do a "mkdir /home/(your user)/jolla . If it is not there allready 4 : allready

  5. do chmod 755 to your script "chmod 755 ~/mountjolla" 5 : ~/mountjolla"

  6. plug usb cable in phone & computer 5a : computer

  7. if not check usbnet module is loaded with "lsmod" 6 :

  8. do "ip link" ( on Archlinux ) and I guess others Linux OS's 7: OS's

  9. notice what net device pop up ( f.eks. enp0s29u1u2u1u3 ) 8 : )

  10. run your script "mountjolla enp0s29u1u2u1u3"

And you have you jolle "nemo" dir mounted at /home/(your user)/jolla !

9 :

  1. umount it with "fusermount -u /home/(your user)/jolla"

Still not an "easy way" tough :-/ but it works

Why is Jolla/sailfish so hard to connect to linux

The question is why is a Linux/opensorce phone so hard to sync/connect to a Linux computer ? Is should be as easy a a work in the park..!?.. but no !!! What is missing !!

Update : Ok, I see this issue still is hot and not solved in an nativ jolla app. So here is what I do at the moment.

  1. I have to be root - set under settings -> system ->developer mode . Set USB LAN to 192.168.1.11 set a SSH password
  2. make a script on my /home/(your user) f.eks. 'mountjolla'
  3. START

    #!/usr/bin/bash localIp='192.168.1.10/24' localBroadcast='192.168.1.255' netAdp=$1 mountPath='/home/(your user)/jolla' user='nemo' jollaIp='192.168.1.11'

    sudo ip addr add $localIp broadcast $localBroadcast dev $netAdp

    First umount if all ready mounted

    fusermount -u $mountPath sleep 2 sshfs $user@$jollaIp:/home/$user -p 22 $mountPath

    END

  4. do a "mkdir /home/(your user)/jolla . If it is not there allready

  5. do chmod 755 to your script "chmod 755 ~/mountjolla"

  6. plug usb cable in phone & computer

  7. if not check usbnet module is loaded with "lsmod"

  8. do "ip link" ( on Archlinux ) and I guess others Linux OS's

  9. notice what net device pop up ( f.eks. enp0s29u1u2u1u3 )

  10. run your script "mountjolla enp0s29u1u2u1u3"

And you have you jolle "nemo" dir mounted at /home/(your user)/jolla !

  1. umount it with "fusermount -u /home/(your user)/jolla"

Still not an "easy way" tough :-/ but it works

Why is Jolla/sailfish so hard to connect to linux

The question is why is a Linux/opensorce phone so hard to sync/connect to a Linux computer ? Is should be as easy a a work in the park..!?.. but no !!! What is missing !!

Update : Ok, I see this issue still is hot and not solved in an nativ jolla app. So here is what I do at the moment.

  1. I have to be root - set under settings -> system ->developer mode . Set USB LAN to 192.168.1.11 set a SSH password
  2. make a script on my /home/(your user) f.eks. 'mountjolla'
  3. Script :

    START

    #!/usr/bin/bash localIp='192.168.1.10/24' localBroadcast='192.168.1.255' netAdp=$1 mountPath='/home/(your user)/jolla' user='nemo' jollaIp='192.168.1.11'

    sudo ip addr add $localIp broadcast $localBroadcast dev $netAdp

    First umount if all ready mounted

    fusermount -u $mountPath sleep 2 sshfs $user@$jollaIp:/home/$user -p 22 $mountPath

    END

  4. do a "mkdir /home/(your user)/jolla . If it is not there allready

  5. do chmod 755 to your script "chmod 755 ~/mountjolla"

  6. plug usb cable in phone & computer

  7. if not check usbnet module is loaded with "lsmod"

  8. do "ip link" ( on Archlinux ) and I guess others Linux OS's

  9. notice what net device pop up ( f.eks. enp0s29u1u2u1u3 )

  10. run your script "mountjolla enp0s29u1u2u1u3"

And you have you jolle "nemo" dir mounted at /home/(your user)/jolla !

  1. umount it with "fusermount -u /home/(your user)/jolla"

Still not an "easy way" tough :-/ but it works

Why is Jolla/sailfish so hard to connect to linux

The question is why is a Linux/opensorce phone so hard to sync/connect to a Linux computer ? Is should be as easy a a work in the park..!?.. but no !!! What is missing !!

Update : Ok, I see this issue still is hot and not solved in an nativ jolla app. So here is what I do at the moment.

  1. I have to be root - set under settings -> system ->developer mode . Set USB LAN to 192.168.1.11 set a SSH password
  2. make a script on my /home/(your user) f.eks. 'mountjolla'
  3. Script :

    START


## START
#!/usr/bin/bash
localIp='192.168.1.10/24'
localBroadcast='192.168.1.255' 
netAdp=$1
mountPath='/home/(your user)/jolla'
user='nemo'
jollaIp='192.168.1.11'

jollaIp='192.168.1.11' sudo ip addr add $localIp broadcast $localBroadcast dev $netAdp

$netAdp # First umount if all ready mounted

mounted fusermount -u $mountPath sleep 2 sshfs $user@$jollaIp:/home/$user -p 22 $mountPath

$mountPath

### END

  1. do a "mkdir /home/(your user)/jolla . If it is not there allready

  2. do chmod 755 to your script "chmod 755 ~/mountjolla"

  3. plug usb cable in phone & computer

  4. if not check usbnet module is loaded with "lsmod"

  5. do "ip link" ( on Archlinux ) and I guess others Linux OS's

  6. notice what net device pop up ( f.eks. enp0s29u1u2u1u3 )

  7. run your script "mountjolla enp0s29u1u2u1u3"

And you have you jolle "nemo" dir mounted at /home/(your user)/jolla !

  1. umount it with "fusermount -u /home/(your user)/jolla"

Still not an "easy way" tough :-/ but it works

Why is Jolla/sailfish so hard to connect to linux

The question is why is a Linux/opensorce phone so hard to sync/connect to a Linux computer ? Is should be as easy a a work in the park..!?.. but no !!! What is missing !!

Update : Ok, I see this issue still is hot and not solved in an nativ jolla app. So here is what I do at the moment.

  1. I have to be root - set under settings -> system ->developer mode . Set USB LAN to 192.168.1.11 set a SSH password
  2. make a script on my /home/(your user) f.eks. 'mountjolla'
  3. Script :

## START
#!/usr/bin/bash
localIp='192.168.1.10/24'
localBroadcast='192.168.1.255' 
netAdp=$1
mountPath='/home/(your user)/jolla'
user='nemo'
jollaIp='192.168.1.11'

sudo ip addr add $localIp broadcast $localBroadcast dev $netAdp
# First umount if all ready mounted
fusermount -u $mountPath
sleep 2

sshfs $user@$jollaIp:/home/$user -p 22 $mountPath

### END$mountPath

  1. do a "mkdir /home/(your user)/jolla . If it is not there allready

  2. do chmod 755 to your script "chmod 755 ~/mountjolla"

  3. plug usb cable in phone & computer

  4. if not check usbnet module is loaded with "lsmod"

  5. do "ip link" ( on Archlinux ) and I guess others Linux OS's

  6. notice what net device pop up ( f.eks. enp0s29u1u2u1u3 )

  7. run your script "mountjolla enp0s29u1u2u1u3"

And you have you jolle "nemo" dir mounted at /home/(your user)/jolla !

  1. umount it with "fusermount -u /home/(your user)/jolla"

Still not an "easy way" tough :-/ but it works

Why is Jolla/sailfish so hard to connect to linux

The question is why is a Linux/opensorce phone so hard to sync/connect to a Linux computer ? Is should be as easy a a work in the park..!?.. but no !!! What is missing !!

Update : Ok, I see this issue still is hot and not solved in an nativ jolla app. So here is what I do at the moment.

  1. I have to be root - set under settings -> system ->developer mode . Set USB LAN to 192.168.1.11 set a SSH password
  2. make a script on my /home/(your user) f.eks. 'mountjolla'
  3. Script :

#!/usr/bin/bash
localIp='192.168.1.10/24'
localBroadcast='192.168.1.255' 
netAdp=$1
mountPath='/home/(your user)/jolla'
user='nemo'
jollaIp='192.168.1.11'

sudo ip addr add $localIp broadcast $localBroadcast dev $netAdp
# First umount if all ready mounted
fusermount -u $mountPath
sleep 2

sshfs $user@$jollaIp:/home/$user -p 22 $mountPath

$mountPath
  1. do a "mkdir /home/(your user)/jolla . If it is not there allready

  2. do chmod 755 to your script "chmod 755 ~/mountjolla"

  3. plug usb cable in phone & computer

  4. if not check usbnet module is loaded with "lsmod"

  5. do "ip link" ( on Archlinux ) and I guess others Linux OS's

  6. notice what net device pop up ( f.eks. enp0s29u1u2u1u3 )

  7. run your script "mountjolla enp0s29u1u2u1u3"

And you have you jolle "nemo" dir mounted at /home/(your user)/jolla !

  1. umount it with "fusermount -u /home/(your user)/jolla"

Still not an "easy way" tough :-/ but it works

Why is Jolla/sailfish so hard to connect to linux

The question is why is a Linux/opensorce phone so hard to sync/connect to a Linux computer ? Is should be as easy a a work in the park..!?.. but no !!! What is missing !!

Update : Ok, I see this issue still is hot and not solved in an nativ jolla app. So here is what I do at the moment.

  1. I have to be root - set under settings -> system ->developer mode . Set USB LAN to 192.168.1.11 set a SSH password
  2. make a script on my /home/(your user) f.eks. 'mountjolla'
  3. Script :

#!/usr/bin/bash
localIp='192.168.1.10/24'
localBroadcast='192.168.1.255' 
netAdp=$1
mountPath='/home/(your user)/jolla'
user='nemo'
jollaIp='192.168.1.11'

sudo ip addr add $localIp broadcast $localBroadcast dev $netAdp
# First umount if all ready mounted
fusermount -u $mountPath
sleep 2
sshfs $user@$jollaIp:/home/$user -p 22 $mountPath

  1. do a "mkdir /home/(your user)/jolla . If it is not there allready

  2. do chmod 755 to your script "chmod 755 ~/mountjolla"

  3. plug usb cable in phone & computer

  4. if not check usbnet module is loaded with "lsmod"

  5. do "ip link" ( on Archlinux ) and I guess others Linux OS's

  6. notice what net device pop up ( f.eks. enp0s29u1u2u1u3 )

  7. run your script "mountjolla enp0s29u1u2u1u3"

And you have you jolle "nemo" dir mounted at /home/(your user)/jolla !

  1. umount it with "fusermount -u /home/(your user)/jolla"

Still not an "easy way" tough :-/ but it works

Another way is using firefox with "FireFTP" extention: , after setup ssh settings + password etc , connect USB cable, get usbnet setup with "ip link" and "sudo ip addr add (localIP) broadcast (localBrodcast) dev (jollaIP)" and point browser to "sftp://(jollaIP)/". Then you get a nice "mc" like interface :P (thanks coderus for the hint)

Why is Jolla/sailfish so hard to connect to linuxlinux?

The question is why is a Linux/opensorce Why is a Linux/open-source phone so hard to sync/connect to a Linux computer ? Is computer? It should be as easy a a work easier than a walk in the park..!?.. but no !!! park! What is missing !! missing? Why is it so important to force Linux users through circuitous MITM-style hubris just to connect?

Update : Ok, I see this issue still is hot and not solved in an nativ jolla app. So here is what I do at the moment.

Update (not OP): Ten step workarounds vs. plug and play? I should be able to connect and set up a read-only connection without device root or deference any third party (yes, even Jolla) ssh/root permission monitor/authenticator. For Read-only, this should be a user level permissions/connection fix. Write/Execute are distinct problems. Is the wireless/USB technology/security standard that bad, or is this a user auditability/security management issue?

  1. I have to be root - set under settings -> system ->developer mode . Set USB LAN to 192.168.1.11 set a SSH password
  2. make a script on my /home/(your user) f.eks. 'mountjolla'
  3. Script :

#!/usr/bin/bash
localIp='192.168.1.10/24'
localBroadcast='192.168.1.255' 
netAdp=$1
mountPath='/home/(your user)/jolla'
user='nemo'
jollaIp='192.168.1.11'

sudo ip addr add $localIp broadcast $localBroadcast dev $netAdp
# First umount if all ready mounted
fusermount -u $mountPath
sleep 2
sshfs $user@$jollaIp:/home/$user -p 22 $mountPath

  1. do a "mkdir /home/(your user)/jolla . If it is not there allready

  2. do chmod 755 to your script "chmod 755 ~/mountjolla"

  3. plug usb cable in phone & computer

  4. if not check usbnet module is loaded with "lsmod"

  5. do "ip link" ( on Archlinux ) and I guess others Linux OS's

  6. notice what net device pop up ( f.eks. enp0s29u1u2u1u3 )

  7. run your script "mountjolla enp0s29u1u2u1u3"

And you have you jolle "nemo" dir mounted at /home/(your user)/jolla !

  1. umount it with "fusermount -u /home/(your user)/jolla"

Still not an "easy way" tough :-/ but it works

Another way is using firefox with "FireFTP" extention: , after setup ssh settings + password etc , connect USB cable, get usbnet setup with "ip link" and "sudo ip addr add (localIP) broadcast (localBrodcast) dev (jollaIP)" and point browser to "sftp://(jollaIP)/". Then you get a nice "mc" like interface :P (thanks coderus for the hint)

Why is Jolla/sailfish so hard to connect to linux?

tldr; Please don't mistake mitigating workarounds for solutions to this problem. Simple connection with another Linux computer is tough or problematic for many users of Sailfish devices.

Why is a Linux/open-source phone so hard to sync/connect to a Linux computer? It should be easier than a walk in the park! What is missing? Why is it so important to force Linux users through circuitous MITM-style hubris just to connect?

Update : Ok, I see this issue still is hot and not solved in an nativ jolla app. So here is what I do at the moment.

Update (not OP): Ten step workarounds vs. plug and play? I should be able to connect and set up a read-only connection without device root or deference any third party (yes, even Jolla) ssh/root permission monitor/authenticator. For Read-only, this should be a user level permissions/connection fix. Write/Execute are distinct problems. Is the wireless/USB technology/security standard that bad, or is this a user auditability/security management issue?

  1. I have to be root - set under settings -> system ->developer mode . Set USB LAN to 192.168.1.11 set a SSH password
  2. make a script on my /home/(your user) f.eks. 'mountjolla'
  3. Script :

#!/usr/bin/bash
localIp='192.168.1.10/24'
localBroadcast='192.168.1.255' 
netAdp=$1
mountPath='/home/(your user)/jolla'
user='nemo'
jollaIp='192.168.1.11'

sudo ip addr add $localIp broadcast $localBroadcast dev $netAdp
# First umount if all ready mounted
fusermount -u $mountPath
sleep 2
sshfs $user@$jollaIp:/home/$user -p 22 $mountPath

  1. do a "mkdir /home/(your user)/jolla . If it is not there allready

  2. do chmod 755 to your script "chmod 755 ~/mountjolla"

  3. plug usb cable in phone & computer

  4. if not check usbnet module is loaded with "lsmod"

  5. do "ip link" ( on Archlinux ) and I guess others Linux OS's

  6. notice what net device pop up ( f.eks. enp0s29u1u2u1u3 )

  7. run your script "mountjolla enp0s29u1u2u1u3"

And you have you jolle "nemo" dir mounted at /home/(your user)/jolla !

  1. umount it with "fusermount -u /home/(your user)/jolla"

Still not an "easy way" tough :-/ but it works

Another way is using firefox with "FireFTP" extention: , after setup ssh settings + password etc , connect USB cable, get usbnet setup with "ip link" and "sudo ip addr add (localIP) broadcast (localBrodcast) dev (jollaIP)" and point browser to "sftp://(jollaIP)/". Then you get a nice "mc" like interface :P (thanks coderus for the hint)