Ask / Submit
8

android version in sailfish 2?

asked 2015-09-04 18:07:42 +0200

Birger gravatar image

Hi,

Can anyone tell which android version that will be in 2.0 of the OS?

The current 4.1.2 is a bit old now.

edit retag flag offensive close delete

Comments

4.1.2 is just fine, you can run 99% of all Apps available.

malk4ever ( 2015-09-08 10:36:47 +0200 )edit
4

Except for the 1% that I want to use!

DavidJ ( 2015-10-30 02:10:00 +0200 )edit
2

+1 Just wanted to install Woltapp on Sailfish 2.0. Requires Android 4.2...

4.1.2 is not fine. I have read couple of threads about this and still don't know if 4.4.4 support for Jolla phone is coming or not.

raaja-arzka ( 2015-11-04 11:35:02 +0200 )edit
3

Also a setback with one BLE wearable with Android app. No can do 4.1.x.

https://together.jolla.com/question/10407/what-is-the-support-lifetime-for-the-included-myriad-alien-dalvik/?answer=31361#post-id-31361

https://together.jolla.com/question/10407/what-is-the-support-lifetime-for-the-included-myriad-alien-dalvik/

"you can run 99% of all Apps available" is not enough, if the 99% are the wrong ones.

raaja-arzka ( 2015-11-04 19:54:12 +0200 )edit

1 Answer

Sort by » oldest newest most voted
7

answered 2015-09-04 19:31:51 +0200

rainisto gravatar image

updated 2015-09-04 19:34:18 +0200

Android version is not tied to 2.0 OS (Alien Dalvik is not part of Sailfish OS), it depends on the version that device manufacturers Android baseport is. Jolla1 currently has 4.1.2 and tablet currently has 4.4.4. (if I remember right).

edit flag offensive delete publish link more

Comments

4

Ok, thank you. But what does this mean for the future of Jolla1. Between the lines I read there won't be an update in the near future and because Jolla1 is old there then never will be?! Android 4.4.4 would be a major step and a really cool update. Because all of the closed source updates of google after 4.4 it's likely that most apps will be compatible to 4.3/4.4 for a very long time.

CLR64 ( 2015-09-04 21:59:01 +0200 )edit
4

Ah.. This was disturbing. For me this means I now will have to get another phone. I could wait for 2.0 and a new android compatibility, but now that seems highly unlikely.

Well it has been fun for a while with the Jolla.

I don't think I will go for another even if they release a new one as it has given me a lot of instability and compatibility issues with apps I need.

Birger ( 2015-09-04 22:24:47 +0200 )edit
1

@CLR64: answer has 'currently'-word, so it doesn't say that versions are written in stone. It may or may not be upgraded at some point.

rainisto ( 2015-09-05 01:08:28 +0200 )edit
2

Some point is unfortunately to undefined for my needs.

Birger ( 2015-09-05 18:10:24 +0200 )edit

That doesn't make sense. Roadmap tells: "upgrade to version 4.4.4" ... "upgrade" ... So if this is what will be shipped at the tablet at release while the phone is nailed down to 4.1.2 there is no upgrade, just a nail and a release.

Also this isn't marked as "Tablet specific" in the roadmap.

Last the roadmap states it is "Implemented, not released yet" but the tablets are actually shipping, so they are released.

//EDIT: "version that device manufacturers Android baseport is" device manufacturer is Jolla. Phone has been designed for SailfishOS, not Android. Alien Dalvik is not a port of Android.

V10lator ( 2015-10-09 08:38:23 +0200 )edit
Login/Signup to Answer

Question tools

Follow
5 followers

Stats

Asked: 2015-09-04 18:07:42 +0200

Seen: 2,518 times

Last updated: Sep 04 '15