Ask / Submit
27

TOH: "Problem with store. This The Other Half is not working." [duplicate]

asked 2014-01-05 23:14:06 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2014-01-21 11:24:25 +0300

eric gravatar image

Note (2014-01-17): This is a duplicate to Connecting white other half gives error. So please vote and comment there. (Nonetheless, I do not close this question yet, because it has a high visibility and if closed people would not get directed to that other question. Current counter here: 292 views / 15 votes)

Original question:

"Problem with store. This The Other half is not working." -- This is the message, I always get when clasping the white TOH (the only one I have) to the Jolla. This message even appears while the Jolla Store is in front and working.

I have no clue what to do about this. Does the TOH needs to be replaced? (Actually, I do not even have a clear idea of what I am missing due to this failure and whether it is worthwhile being bothered about it.)

edit retag flag offensive reopen delete

The question has been closed for the following reason "duplicate question" by eric
close date 2014-01-21 11:25:59.891526

Comments

I have the same problem. The error message does not give any hint as to what is not working: is the NFC chip in the phone broke or is the NFC tag on the TOH!? Does the store have a problem?

minnist ( 2014-01-05 23:18:12 +0300 )edit

Have you rebooted your device and then trying to put that white TOH on again?

goldenm ( 2014-01-05 23:20:15 +0300 )edit

I rebooted my device now several times: it makes no difference. Furthermore, THO is actually recognized only when it is being clapped on the device which results in the error message.

Oh, and I reseted the device as well, albeit, to no effect. Updating the OS does also not solve the problem.

minnist ( 2014-01-05 23:36:29 +0300 )edit

I am having the same problem, even after multiple reboots and a reset. I just gave up and turned tohd.service off, but I hope this will be fixed one day.

nodevel ( 2014-01-06 00:21:27 +0300 )edit

Same error message here. The white ambiences were there in the first place, but vanished after the first reboot ...

RogerCrocker ( 2014-01-06 01:13:16 +0300 )edit

6 Answers

Sort by » oldest newest most voted
1

answered 2014-01-21 11:25:40 +0300

eric gravatar image

As indicated in the update of this question, this is a duplicate of: https://together.jolla.com/question/5330/connecting-white-other-half-give-error/

Please cast your votes and comments there, thank you!

Closing as duplicate.

edit flag offensive delete publish link more
0

answered 2014-01-17 10:18:18 +0300

nodevel gravatar image

Here is a log that might help (Jolla):

Jan 17 09:15:29 localhost dbus-daemon[1301]: Showing UI entry point toh
Jan 17 09:15:29 localhost store-client[15485]: [D] Store::Server::makeUrl:160 - Request URL:  QUrl( "https://store-api.jolla.com/api/v001/th...80/" )  
Jan 17 09:15:29 localhost store-client[15485]: [D] Store::RequestProxy::slotReplyFinished:88 - void Store::RequestProxy::slotReplyFinished()... FOUND" 
Jan 17 09:15:29 localhost store-client[15485]: [W] Store::Server::slotRequestError:726 - void Store::Server::slotRequestError(Store::RequestProxy*) 
Jan 17 09:15:29 localhost store-client[15485]: [W] Store::Server::slotRequestError:727 - Error:  203 "Error downloading https://store-api.jo... FOUND" 
Jan 17 09:15:29 localhost store-client[15485]: [W] Store::Server::slotRequestError:728 - Data:  ""Not found."" 
Jan 17 09:15:29 localhost dbus-daemon[1301]: TOH Failure:  This The Other Half is not working
Jan 17 09:15:29 localhost dbus-daemon[1301]: UI was closed
edit flag offensive delete publish link more

Comments

Looks like journal is cutting lines? Great...

nodevel ( 2014-01-17 10:22:18 +0300 )edit

Looks like the TOH-ID is not found in the store database. I think it would be best to contact Jolla Care in this case.

pycage ( 2014-01-17 20:24:58 +0300 )edit
0

answered 2014-01-17 23:15:32 +0300

gehowa gravatar image

updated 2014-01-18 10:46:07 +0300

After switching the phone language from German to English I could install the poppy red ambience. White TOH still gives me the error, no matter how much language switching is involved. However, now I can de- and reinstall the "First One" ambience as much as I want (and in any language) :/

edit flag offensive delete publish link more

Comments

1

So... What should I do when my phone is already in English?

nodevel ( 2014-01-18 03:35:36 +0300 )edit

same as @nodevel already set to english, but doesn't work

kelvan ( 2014-01-18 13:53:25 +0300 )edit
0

answered 2014-01-18 08:08:45 +0300

http://talk.maemo.org/report.php?p=1407067

edit flag offensive delete publish link more
-1

answered 2014-01-18 11:36:19 +0300

Nokius gravatar image

Sounds like that this TOH has been used with an other Jolla if its ones activated (installed) its associated with this Phone (IMEI). This is needed if the TOH has feature like Music / Games ... If you reset the Phone (first activation) you can bind the TOH again to a other Phone or the same.

edit flag offensive delete publish link more
-4

answered 2014-01-05 23:20:49 +0300

RX Shorty gravatar image

This also happend after a reset of the device? Sounds like your white other half is broken indeed. What you are missing is a white Ambiance I guess :)

edit flag offensive delete publish link more

Comments

I guess it is not broken because it's trying to download stuff (the ambiance) from the store... Just a general issue with the store, maybe a reboot fixes it?

goldenm ( 2014-01-05 23:28:09 +0300 )edit

I rebooted my device now several times: it makes no difference. Furthermore, THO is actually recognized only when it is being clapped on the device which results in the error message. Oh, and I reseted the device as well, albeit, to no effect. Updating the OS does also not solve the problem.

minnist ( 2014-01-05 23:35:57 +0300 )edit

Is your phone connected to internet though 3G or Wifi? Try to change the connection, see if it helps.

goldenm ( 2014-01-05 23:45:55 +0300 )edit
1

The store as such has access to the Internet. I can download applications. I only can test with Wifi.

Out of curiosity, why is the comment provided by RX Shorty an answer even though it is not? Does that not maybe prevent people who might actually have an answer to answer the problem?

minnist ( 2014-01-05 23:50:23 +0300 )edit

"maybe a reboot fixes it?": No.

"other half is broken indeed." How can it be broken, when the Jolla recognizes that there is just (re-installed) a TOH -- if it recognizes this, the NFC tag must be sending something. What else could it be than its ID?

"missing is a white Ambiance I guess :)" What exactly does this mean? As far as I understood, I can select images from the Gallery and assign an "ambiance" to them. However, I just worked out that only the background and volume scale changes with the selected ambiance image. If I change any setting in the settings menu, the changes are applied system-wide -- for all ambiance images active. I have no clue, whether this is the way it is intended to be or not, and whether this behavior would change with a properly working TOH.

jgr ( 2014-01-06 00:03:31 +0300 )edit

Question tools

Follow
5 followers

Stats

Asked: 2014-01-05 23:14:06 +0300

Seen: 2,106 times

Last updated: Jan 21 '14