We have moved to a new Sailfish OS Forum. Please start new discussions there.

usb tethering without sim

asked 2015-10-14 12:38:41 +0300

Tuxle gravatar image

Hi all

I would like to use my Jolla Phone without a SIM Card, but I can not share my wifi connection over USB with my Laptop. This Scenario is very common, because there are many old, buggy BaseStations around here and new Hardware (usally everything with WLan.AC) can not connect to these (public) hotspots.

Are there any Plans to support this?

Regards Tuxle

edit retag flag offensive close delete

2 Answers

Sort by » oldest newest most voted

answered 2015-10-14 14:14:32 +0300

Philippe De Swert gravatar image

There is somewhere on this forum already one solution for this. I just could not quickly dig it up.

You can also do it from the command line in the traditional linux way.

echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o wlan0 -j MASQUERADE
iptables -A FORWARD -i wlan0 -o rndis0  -m state  --state RELATED,ESTABLISHED -j ACCEPT
iptables -A FORWARD -i rndis0 -o wlan0 -j ACCEPT

And then you need of course set up the gateway (usb interface ip, default is etc on the pc side

edit flag offensive delete publish link more


Hi @Philippe De Swert - I'm getting this output after entering the second line; bash: iptables: command not found.

pkcon search name iptables reveals iptables are installed.

I have no idea how to proceed.

Spam Hunter ( 2015-10-15 00:47:20 +0300 )edit

@Markkyboy: you would have to be root / devel-su first.

Philippe De Swert ( 2015-10-15 00:52:26 +0300 )edit

@Philippe De Swert - I should have mentioned, I was already root (su - in my case), the bash error still occurs.

Spam Hunter ( 2015-10-15 13:06:08 +0300 )edit

@Markkyboy: no idea what's wrong with your device. Works fine here. Can you check if you have /sbin/iptables? Otherwise you could give pkcon --allow-reinstall install iptables a go...

Philippe De Swert ( 2015-10-15 13:14:30 +0300 )edit

Yes @Philippe De Swert, sbin/iptables are present. The command pkcon --allow-reinstall install iptables yields this response; Failed to parse command line: Unknown option --allow-reinstall. Tis all a bit odd, I am using a pretty fresh install of and everything else (to my knowledge) is running sweetly!.

Spam Hunter ( 2015-10-15 13:33:06 +0300 )edit

answered 2016-06-10 16:44:50 +0300

eatdirt gravatar image

Just filled this answer with my jolla, sim card removed, usb connection to my desktop selected by picking up "Internet sharing" when plugging the usb cable.

1) Install the package: pkcon install usb-moded-settings-sailfish

2) plug the usb cable, select "internet sharing"

3) your WAN connection has been deactivated, but go back on it, switch it on and here you go.


edit flag offensive delete publish link more
Login/Signup to Answer

Question tools



Asked: 2015-10-14 12:38:41 +0300

Seen: 2,024 times

Last updated: Jun 10 '16