Ask / Submit
3

How to initiate a conversion via xmpp?

asked 2014-01-13 22:00:59 +0300

jukey gravatar image

I was not able to figure out how to write a message using the xmpp account I created in the settings section. I would have expected it in the messages application (also usable for text messages).

I also do not see a field for xmpp addresses if I create or edit a contact.

edit retag flag offensive close delete

Comments

By open the contact in the People application and tapping on the xmpp information?

lomo ( 2014-01-13 22:03:39 +0300 )edit

Basically the same question, but completely different cause and solution, this question might be helpful for people with similar problems.

tokaru ( 2014-02-25 23:12:43 +0300 )edit

3 Answers

Sort by » oldest newest most voted
2

answered 2014-01-13 22:07:33 +0300

ossi1967 gravatar image

Make sure the XMPP account is online. Your contacts will be imported to the address book. Afterwards you can initiate a chat from the chat application just as you expected by selecting one of those contacts.

As for directly entering an XMPP address in the contacts details: No, I don't think thats possible now. I imported VCF files that already included XMPP data... and the Jolla Phone didn't know what to do with them. (It's only logical if you think about it: It's not enough to say: This is an XMPP address. You need to specify which of your own accounts this address is bound to.)

edit flag offensive delete publish link more

Comments

Make sure the XMPP account is online.

Thanks @ossi1967 I assume that is my problem. When I enter the account (jukey@jabber.ccc.de) an password and swipe to the left side I can see a message like "not online" for a few milliseconds before I am back in the account view.

Unfortunately I can not find a single point in whole OS + Apps where I can see the status. If I swype in from bottom and the use the pulley menu to see the status information I see Twitter and Facebook only. There should be my xmpp account visible as well even if it is offline. Maybe this issue is related to this question?

jukey ( 2014-01-14 23:05:35 +0300 )edit

Hi Jukey I guees your problem is about the cer file there is a wprkaround dune to the fact that there is no glue to add cert from other SSL disrebuter

https://together.jolla.com/question/1607/gui-to-addtrust-ssl-root-certsself-signed-certs/?answer=17670#post-id-17670

Nokius ( 2014-02-02 23:29:42 +0300 )edit
1

answered 2014-01-13 22:12:23 +0300

tad gravatar image

updated 2014-01-13 22:12:44 +0300

In the People application, there is a globe symbol right in front of all letters. Tap there and you see all your contacts, that are online.

edit flag offensive delete publish link more

Comments

This button is greyed out for me. Do I need to import contacts anywhere?

Sebix ( 2015-07-30 22:47:19 +0300 )edit

@Sebix either a) your account is not online b) you don't have any contacts on your buddy list yet c) none of your buddies are online

tad ( 2015-07-30 23:10:48 +0300 )edit

Thanks @tad, then I have the same problem as everyone. The latter two possibilities are not the case as it works with other clients.

Sebix ( 2015-07-31 09:59:47 +0300 )edit
0

answered 2014-01-14 23:56:07 +0300

jukey gravatar image

This description solves the issue.

In addition I would like to mention that openssl could be installed via

pkcon install opensssl

as normal user.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2014-01-13 22:00:59 +0300

Seen: 1,389 times

Last updated: Jan 14 '14