Ask / Submit
10

Some videos in browser are corrupted after kymijoki update

asked 2017-12-02 21:38:02 +0300

max630 gravatar image

updated 2018-02-08 14:00:04 +0300

After installing the kymijoki update (2.1.3.7) many videos are shown corrupted. An example is https://img-9gag-fun.9cache.com/photo/awQYXQy_460sv.mp4 which is shown like Screenshot

It sounds very much like https://together.jolla.com/question/62337/corrupted-video-playback-in-browser/ but I seem to have the fix already:

[nemo@Sailfish ~]$ rpm -q gstreamer0.10-colorconv                  
gstreamer0.10-colorconv-0.0.20140910.0-10.2.3.jolla.armv7hl
edit retag flag offensive close delete

1 Answer

Sort by » oldest newest most voted
2

answered 2018-02-07 17:39:42 +0300

lpr gravatar image

from changelog of package gstreamer1.0-droid:

add a fallback for when I420ColorConverter.so isn't installed. Contributes to JB#38765

but the correct filename is libI420colorconvert.so in /system/lib/

so it falls back to obviously broken fallback-function...

edit flag offensive delete publish link more

Comments

Thanks! I'll try to install the previous version and see if it helps. Do you happen to know if there are binary packages available somewhere?

max630 ( 2018-02-08 06:48:30 +0300 )edit

I should admit I don't find any libI420colorconvert.so in /system/lib/, or even any file with string "420" in its name, anywhere. So I don't really understand what it was about. But I'll try anyway.

max630 ( 2018-02-08 06:53:48 +0300 )edit

I downgraded gstreamer1.0-droid to 0.20170510.0, the video plays correctly.

max630 ( 2018-02-08 10:11:12 +0300 )edit

on jolla1 /system/lib/libI420colorconvert.so is provided by package droid-system-sbj

lpr ( 2018-02-08 18:38:57 +0300 )edit
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2017-12-02 21:38:02 +0300

Seen: 446 times

Last updated: Feb 08