Ask / Submit
35

Sailfish X - Generally too loud

asked 2018-01-29 11:19:17 +0300

LVPVS gravatar image

updated 2018-02-22 06:46:28 +0300

Hei,

Newer EDIT

With EA 2.1.4.13 the

$ pactl --set-sink-volume sink.primary 80%

seems to be having no effect at all.

$ pactl --set-sink-volume sink.deep_buffer 80%

Works instead.

I wonder if this was an intentional move or some mistake?

/Newer EDIT

EDIT

May I ask somebody with anotner device (not SailfishX!) to check in CLI the output of the following command and post a part of it here?

$ pactl list

I am interested in something like this:

Sample #7 Name: pulldown_lock Sample Specification: s16le 1ch 48000Hz Channel Map: mono Volume: (invalid) balance 0.00

Thank you in advance!

/EDIT

Before the haters begin hating, I have already dug up the TJC for any similar issues. ;) With no real success of finding solutions/answers.

Last weekend I got myself an Xperia X (F5122, as F5121 was out of reach for me) and Sailfish X. I put some effort and working hours into it and now I have a great new phone. A worthy successor of my late JP1301.

I like it, but I noticed that the volume of the sounds on the Xperia X are too high for my taste. I even had to mute the system sounds for that reason. Today the (clock) alarm almost woke up the whole block I live in.

My question is: Is it only me experiencing this, or is it a known issue?

I know work-arounds. Well, some work-arounds. But is there an official solution there?

EDIT

Thanks to everyone for the work-arounds. The clock alarm was only an example. The 'charger connected/disconnected tone' is another. Not to mention the 'unlock tone'...

Actually, I am more interested in the 'WHY' not in the 'HOW'. ;)

/EDIT

Another EDIT

After having the general sink volume reduced to some more bearable level, I noticed that the volume during calls (both via earphone, loudspeaker and BT carkit) is too low.

How, where can I tweak these levels independently so that they remain persistent over reboots?

/Another EDIT

Kiitos,

LVPVS over.

edit retag flag offensive close delete

Comments

6

Same issue with the clock here! Way too loud!

louisbob ( 2018-01-29 12:10:04 +0300 )edit

@LVPVS So it works on the dual SIM version? That is nice! I'm considering getting it too!

kat6 ( 2018-02-04 08:32:33 +0300 )edit

Hei @kat6,

OFF

It does indeed. There are some glitches here and there, but mostly fine.

The 'dual-SIM hack' is working, too. After a reboot, I had the extra item in Settings App.

The display leaves me speechless every time I look at it. After four years on my late JP1301, it is stunningly beautiful.

/OFF

LVPVS over.

LVPVS ( 2018-02-04 08:53:28 +0300 )edit

I'm still not sure if the volume is able to damage the hardware or not. My device starts again making ugly noises while playing lout sounds, this time the upper speaker seems affected... read topic here

Robomike ( 2018-02-04 11:27:25 +0300 )edit

May I suggest, you take a look at this (my) answer, which provides you with the possibility of setting the lowest and highest volume, as well as the granularity, for calls and media (with granularity I oretty much mean the number of clicks on the volume buttons) - I've done it for the hands free speakers, but you can use any of the files in the mentioned directory and you can adjust them to your liking (but you should make a backup of the original and the changed file, as system updates may cause them to change or revert).

Here's my link

I hope, it helps you or anyone a bit...

eriXD ( 2018-03-31 10:18:51 +0300 )edit

8 Answers

Sort by » oldest newest most voted
13

answered 2018-01-29 16:07:20 +0300

null gravatar image

Yes! It's way way too loud! I reduced the volume for the PulseAudio sink by adding

set-sink-volume sink.primary 0x6000

to /etc/pulse/arm_droid_default.pa

After that either reboot for the changes to take effect or write the following as nemo:

pactl set-sink-volume sink.primary 60%
edit flag offensive delete publish link more

Comments

1

Thanks @null,

I used your work-around until we have anything official. This came in handy.

LVPVS over.

LVPVS ( 2018-01-29 16:24:36 +0300 )edit

Okay, this work-around is good for suppressing all the sounds coming from the phone. The dark side is that it decreases the volume of the call as well... Making it too silent in the car, connected via Bluetooth.

LVPVS over.

LVPVS ( 2018-01-31 11:09:21 +0300 )edit

Well, normal calls are loud enough for me like this. I don't have any bluetooth devices (or a car for that matter), so can't really comment on that. I guess trying something a bit higher or changing it when you're in the car and changing back afterwards are options... though that is going to be annoying. I really hope Jolla will address this soon.

null ( 2018-01-31 15:59:36 +0300 )edit
5

answered 2018-01-29 12:32:26 +0300

lutinotmalin gravatar image

You can lower the volume on Settings>Ambiences, the default percentage for each ambience is 80, which is quite loud I agree.

About the Clock alarm, I had the same issue about the volume, without talking about the snooze time which was too short for me (5min).

I solved that issue by installing Clock Settings within OpenRepos. With that application, you could edit the volume and snooze time to adjust them regarding your preferences.

edit flag offensive delete publish link more

Comments

3

Thank you, @lutinotmalin, I am aware of the work-arounds lingering.

I am wondering why Sailfish X has it's general sound levels at such heights.

It is not only the alarm that breaks glasses when it goes off, but also the charger connected/disconnected and the unlock tones are also waaaay too loud. and they don't seem to be respecting the general Ambience-defined sound levels.

LVPVS over.

LVPVS ( 2018-01-29 15:05:46 +0300 )edit

Thanks, @lutinnotmalin, I loved the loudness of my new Sailfish X / F5121 with my car stereo, but indeed next morning I got a heart attack... The Clock Settings from OpenRepos did resolve that. However, the other Jolla ambiance alert sounds were also far too loud. Since there appears to be no easy adjustement for this, I took all the jolla-*.ogg files my ambiance(s) are using (https://together.jolla.com/question/32468/wiki-location-of-path-to-configuration-etc-files-sailfish/?answer=32469#post-id-32469) into my computer and then back but with a few adjustements: A brute force solution was to normalize all files to some 15 % lower volume. Now I don't jump anymore when a message arrive. Otherwise, unlike for some others in this thread, out of the box telephone and podcast etc.volumes are OK for me.

canne ( 2018-04-28 17:44:41 +0300 )edit
4

answered 2018-01-29 15:06:40 +0300

campeon gravatar image

updated 2018-02-12 15:07:57 +0300

I agree. And the minimal music volumen is too loud for using it in bed for example. I like to listen podcast to fall asleep and the minimal voumen is to loud for my taste....

edit flag offensive delete publish link more
2

answered 2018-01-30 10:55:39 +0300

liqquid gravatar image

updated 2018-01-30 11:03:33 +0300

Answered a few times already. You can change the alarm volume with Clock Settings app what you can find it in openrepos. There is also a volume control patch if I remember right where you can adjust the step percentages.

edit flag offensive delete publish link more
2

answered 2018-02-03 17:32:31 +0300

Sethdove gravatar image

Agree, all way too loud. Even on headphones. I can't use headphones on a phone call, because the lowest setting is just too loud to take.

edit flag offensive delete publish link more
1

answered 2018-02-03 18:15:44 +0300

aQUICK1 gravatar image

I can recall to change volume alarm under settings -> apps -> clock, 2 sliders that are adjustable !

edit flag offensive delete publish link more

Comments

That's only possible if you install Clock Settings first: https://openrepos.net/content/slava/clock-settings

nthn ( 2018-02-04 01:27:14 +0300 )edit

That's correct !

aQUICK1 ( 2018-02-04 21:01:18 +0300 )edit
1

answered 2018-02-04 20:16:06 +0300

Artemys gravatar image

hi all, interesting to read the problem, i thought, it's only just my taste, that i found also the voices too loud. and not ringing tone, of course it is adjustable at the ambiences' settings, as mentioned earlier. i found the phone's voice too loud, even if it is set to the lowest. sometimes i have the feeling, that the whole office is listening to the one whom i'm just talking with. i have a jollaC and earlier i had a jolla2, and the C is definitely louder. i noticed also earlier, that my husband's intex aqua fish is much louder, than the jolla2.

edit flag offensive delete publish link more

Comments

I had the same "problem" already with my Jolla1 phone. Even on the lowest volume setting, the voices in a call were always too loud for my taste. That was one, if not the, reason why i still use my N9 as my daily phone over the Jolla. With every update since December 2013 i was hoping that it is possible to have wider range for the volume control.

Stefan P ( 2018-02-05 00:00:52 +0300 )edit
0

answered 2018-02-13 21:49:36 +0300

julien2711 gravatar image

updated 2018-02-14 18:38:55 +0300

I have an Sony Xperia X F5121 and a Jolla C - just updated today

Xperia X: Unlock sound is as well extremely loud. Audio playback is very loud. For low volume for quite rooms I would choose as well the level before off. (This however is fine for me) Call loudness is better then with my version of JollaC. 50 % is about my jolla C loudness, which is good for quiete environment and enables higher volumes for louder environment. (Direct comparrison by calling myself over Threema)

pactl list
Sample #6
        Name: pulldown_lock
        Sample Specification: s16le 1ch 48000Hz
        Channel Map: mono
        Volume: (invalid)
                balance 0.00
        Duration: 0.3s
        Size: 25.8 KiB
        Lazy: no

JollaC: Unlock is significantly more quiet. Audioplayback was allways fine. Level 2 ~ Level 1 (Xperia) , Level 8 ~ Level 6 (Xperia) (Synchronus playback) Phone calls where allways to quite even on max volume. As statet before this is better with Xperia X

Sample #5
        Name: pulldown_lock
        Sample Specification: s16le 1ch 48000Hz
        Channel Map: mono
        Volume: (invalid)
                balance 0.00
        Duration: 0.3s
        Size: 25.8 KiB
        Lazy: no
        Filename: n/a
        Properties:
                media.role = "event"
                module-stream-restore.id = "x-meego-feedback-sound-level"
                media.name = "feedback-event"
                event.id = "pulldown_lock"
                media.filename = "/usr/share/sounds/jolla-ambient/stereo/pulldown_lock.wav"
                application.name = "libcanberra"
                native-protocol.peer = "UNIX socket client"
                native-protocol.version = "30"
                application.version = "0.30"
                application.id = "org.freedesktop.libcanberra"
                application.process.id = "1138"
                application.process.user = "nemo"
                application.process.host = "HOSTNAME"
                application.process.binary = "ngfd"
                application.language = "C"
                application.process.machine_id = "XXXXXXXXXXdeletedXXXX"
                application.process.arg0 = "/usr/bin/ngfd"

Closing words: An Idea could be that it has something to do with the region settings. I have a both phones set to german. In Germany we have laws which set an overall maximum level to the volume. As far as I know american products tend to be louder in comparison. My guess comes from the different experience with Jolla C. For me it was always by far to quiet. I will reset the Jolla C soon and I will check then with english language settings.

edit flag offensive delete publish link more

Comments

Hei @julien2711,

Thank you for your effort! I was hoping to see something at the 'Volume:' that is not '(invalid)'... I wonder where SailfishX has its default volume settings stored...

Kiitos, LVPVS over.

LVPVS ( 2018-02-13 22:11:07 +0300 )edit

@julien2711,

And other samples? Are there any similar?

Kiitos, LVPVS over.

LVPVS ( 2018-02-14 14:49:08 +0300 )edit

Update in the Text. I didnt see any samples before. Now it pops up ... I have no clue why it wasn't visible last time or I justs might have missed it. - Output is identical as far as I can see.

julien2711 ( 2018-02-14 18:37:05 +0300 )edit

Thank you, @julien2711.

I wonder why volume is 'invalid' on both devices.

In the mean time I found this in

/etc/pulse/arm-droid-default.pa

load-module module-role-ducking trigger_roles=alarm,notification,warning ducking_roles=x-maemo volume=-200dB

I tried to change the volume here, but with zero effect. Any idea why?

Kiitos,

LVPVS over.

LVPVS ( 2018-02-14 22:44:09 +0300 )edit

looks interesting. I tried but with no success. I reduced to -400dB and restarted because i couldn't successfully restart pa.

/usr/share/ngfd/events.d/pulldown_lock.ini

from there I found the value defenitions in:

/usr/share/ngfd/plugins.d/50-profile.ini

[profile]
sound-levels = system.sound.level;touchscreen.sound.level
system.sound.level = 0;50;75;100
touchscreen.sound.level = 0;30;50;75
search-path = /usr/share/sounds

I tried to find information what the configs do but only found a link to the vibration settings https://together.jolla.com/question/75711/how-to-modifiy-vibration-strengthpattern/

ngfd-settings-sailfish  NGFD configuration for Sailfish     Proprietary

from : https://wiki.merproject.org/wiki/SailfishOSS

So it should be possible to set specific volumes to certain events.

julien2711 ( 2018-02-15 19:59:07 +0300 )edit
Login/Signup to Answer

Question tools

Follow
10 followers

Stats

Asked: 2018-01-29 11:19:17 +0300

Seen: 2,107 times

Last updated: Feb 22