We have moved to a new Sailfish OS Forum. Please start new discussions there.

Keyboard doesnt open in Android-App (XA2) - still persists in and

Tracked by Jolla (Rejected)

asked 2019-08-05 19:38:47 +0200

mettska gravatar image

updated 2020-04-14 19:56:28 +0200

AkiBerlin gravatar image

For my work I need the app "EduPage". While trying to log in, the keyboard doesnt show up. I click several times in the email-adress-field and the password-field. The only thing happens is highliting the clicked field. AD restartet and the phone rebooted a few times.

EDIT: problem persists in with "Citrix Workspace" Android App

edit retag flag offensive close delete


working for me with Android keyboard and Jolla keyboard ...Screenshot_20190805_001.pngScreenshot_20190805_002.png

Levone1 ( 2019-08-06 05:24:54 +0200 )edit

You are using a XA2?

mettska ( 2019-08-06 10:04:04 +0200 )edit

oh, sorry, no... X Compact. It didn't occur to me that the device would matter, but I can see it now... will convert to comment

Levone1 ( 2019-08-06 13:30:45 +0200 )edit

The problem with EduPage persists for AkiBerlin on but it worked for mettska in Dec 2019 (OS 3.2.1?). Hmmm?

Maybe you want to collect the logcat log on Android Support and the journal log. Instructions here: https://jolla.zendesk.com/hc/en-us/articles/204110913. Please make notes on the date/time when something significant happens in the logs,

jovirkku ( 2020-04-14 18:10:51 +0200 )edit

@jovirkku: I have observed the problem when trying to use Citrix (not EduPage)

I will try to create a logcat file

AkiBerlin ( 2020-04-14 19:55:44 +0200 )edit

3 Answers

Sort by » oldest newest most voted

answered 2019-10-29 18:40:45 +0200

mettska gravatar image

updated 2019-10-29 18:41:08 +0200

This problem persists in (EA) for both apps (EduPage and Citrix). The "Android keyboard pops up reliably" from the release notes doesnt solve this problem here

edit flag offensive delete publish link more

answered 2019-08-14 00:44:53 +0200

AkiBerlin gravatar image

updated 2019-08-14 18:16:22 +0200

I have similar problems (no virtual keyboard) with Citrix Workspace App (for Android) on the XA2. I cannot use that app because also the bluetooth keyboard does not work on the XA2; see [XA2] Bluetooth keyboard pairs, but disconnects. I have no such problems on the X.

PS: I converted this (my comment) to an answer to get more attention on that problem because it is vital for me - I know it is not an answer but rather a comment

edit flag offensive delete publish link more


Yes, I really need EduPage. Its very important for my work-flow. I hope Jolla sees it and fixes it.

mettska ( 2019-08-14 18:19:40 +0200 )edit

This same issue exists with Microsoft Remote Desktop. Try to invoke the keyboard and it won't show up. Windows has a built-in softkeyboard, but it is definitely inconvenient.

WedgeStratos ( 2019-08-17 04:59:26 +0200 )edit

Well, plain USB keyboard would be a stop-gag solution...

DrYak ( 2019-10-29 21:03:23 +0200 )edit

answered 2019-12-12 21:06:31 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2019-12-12 21:06:31 +0200

mettska gravatar image

For EduPage: It works now with the latest update (*.55) of EduPage. So it seems they changed something.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools



Asked: 2019-08-05 19:38:47 +0200

Seen: 607 times

Last updated: Apr 14 '20