We have moved to a new Sailfish OS Forum. Please start new discussions there.

WLAN: Not enough time to enter a password for SSID

asked 2013-12-26 03:25:01 +0300

Anna gravatar image

updated 2014-01-26 06:10:19 +0300

If users have to enter a very long password for a (hidden) wireless network, they are getting interrupted before they are able to enter all characters. Sailfish doesn't leave users enough time to enter the full length password and connect to the wireless network.

Copy/paste the key using notes or SMS is a work around. But this must be fixed.

edit retag flag offensive close delete


What do you mean by, 'getting interrupted by device'?

It will not start connecting until after you finish the process and press the 'connect' button. The disconnection is a separate issue that we are looking into. Hidden networks are a bit of a problem area with the underlying connection software.

llornkcor ( 2013-12-28 14:36:59 +0300 )edit

I've got the same problem - entering a long password is impossible.

ender ( 2014-10-30 14:50:30 +0300 )edit

2 Answers

Sort by » oldest newest most voted

answered 2014-11-02 15:40:40 +0300

ralooyar gravatar image

updated 2014-11-02 15:46:17 +0300

I can confirm this problem, too. Both with versions (Ohijärvi, installed when shipped) and (Tahkalampi, updated yesterday).

Steps to reproduce:

  1. go to Settings -> System -> WLAN
  2. forget about current WLAN connection
  3. select "connect to internet" from drop down menu on top
  4. select a secure WLAN from list
  5. start typing long WLAN passwort

My observation: By selecting a WLAN (4. in list above) a timeout starts. After exactly 120 seconds password input is interrupted and you see a message saying:

Sorry. Could not connect to selected network.

Search again

If you have a WLAN password being 63 characters long, you have no chance to type this in 120 seconds.

All the password you have typed so far is lost. This is very annoying. First I thought it was my fault, by accidently touching the "ok" button on the lower right, so I tried a second and a third time. Not so nice user experience for a first-time-jolla-user. And setting up WLAN is one of the first steps after unboxing your shiny, new jolla phone.

Finally I found this post. And the solution to type the password in the messenger and copy&paste it to the WLAN dialog worked well.

But this bug needs to be fixed.

If you can't disable the 120 seconds timeout, maybe you could provide a back button in the "... Could not connect ..." dialog. So the user could go back and review/correct/change the typed SSID or password.

The latter would also be handy in case of typos, so you don't have to retype the whole password again.

The bug applies to WLAN with hidden SSID and shown SSID.

edit flag offensive delete publish link more

answered 2013-12-26 10:56:49 +0300

rsainio gravatar image

This happened to me as well; my key is actually long string of random characters. I solved the problem by activating the devel-mode and editing the file in /var/lib/connman/wifi5056a801170a525341managedpsk/settings file directly. The directory name wifi... will differ as it is made from your SID amongst others. It helps if you have another SID where you have a working connection so that you could compare the contents. Nicest way would be the connmanctl-command, but it is not installed.

edit flag offensive delete publish link more


Would copy&paste work?

ortylp ( 2013-12-26 11:15:46 +0300 )edit

Was my first thought as well, however getting the key to Jolla first and then copy&paste compared to ssh to jolla and quick editing won in my case. In fact it was copy and paste from one ssh session to another.

rsainio ( 2013-12-26 11:43:48 +0300 )edit

It does. You can enter the key in a note, then copy/paste. However, it's just a workaround and not solving the actual "problem".

Anna ( 2013-12-26 13:43:31 +0300 )edit

when initially unpacking and you do not have any wifi to connect via ssh AND you do not want to type, you can save the passphrase as a contact on an other phone, then sending via bluetooth and then copy from edit the imported contact to the wifi setup ;) send html file doesnt work no copy in browser

fl ( 2013-12-30 08:55:56 +0300 )edit

Another good way to "type" long passwords without touching the keyboard is QR codes. Use any online QR code generator (google it) to make a QR from your password. Then, install CodeReader app through Jolla Store and you're done.

And since there are tons of free QR apps for iOS/Android/BB/WPhone, this is a better method to give access to your WPA network to friends and family than the insecure WPS shit.

Mced ( 2015-10-13 19:07:25 +0300 )edit
Login/Signup to Answer

Question tools



Asked: 2013-12-26 03:25:01 +0300

Seen: 810 times

Last updated: Nov 02 '14