Ask / Submit
14

[bug] Specific web shortcuts in launcher can not be deleted. [answered]

asked 2014-07-15 09:23:36 +0200

helicalgear gravatar image

The web shortcut in launcher could not be deleted if the title of shortcut included the specific character like "[]" (e.g. "[bug] Web shortcuts in launcher"). Do anybody know any workaround about this issue ?

Thanks !

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by ssahla
close date 2014-12-03 22:25:59.975091

1 Answer

Sort by » oldest newest most voted
7

answered 2014-07-15 23:25:01 +0200

soson gravatar image

updated 2014-09-13 18:02:15 +0200

Here is my solution.

  1. Open terminal
  2. Change directory

    cd /home/nemo/.local/share/applications

  3. List shortcuts files

    ls -al

  4. Delete particular file

    rm <filename>

edit flag offensive delete publish link more

Comments

3

This can also be done with File Browser (from Jolla Store). Make hidden files visible from settings, navigate to the abovementioned directory and delete the shortcut you want to get rid of.

ssahla ( 2014-07-15 23:44:29 +0200 )edit

Now I can delete the shortcut. Thanks a lot !

helicalgear ( 2014-07-16 03:54:02 +0200 )edit
1

Thanks all - File browser and this answer worked for me too.

ninepine ( 2014-09-08 00:21:13 +0200 )edit

I also had this problem, not being able to delete short cuts saved in Favourites.

I had been playing around with RemorseItem.qml, reducing the timer from 5000ms to 0000s, which appears to have interfered with deleting certain objects.

I have corrected the RemorseItem.qml file back to 2000ms instead of 0000s and I can now delete unwanted saved favourites in Sailfish Browser and they stay deleted.

See this post; https://together.jolla.com/question/3244/remorse-timer-actions-and-remorse-timer-settings-configuration/#post-id-27986

Also, @soson - cd /home/nemo/.local/share/application doesn't exist on my Jolla. There is a folder called applications at the same path, not application; but this folder is empty. I'm using FileBrowser.

Edz ( 2014-09-13 17:05:21 +0200 )edit

@Markkyboy you were right,that folder should be called applications, i edited my answer. Anyway i think that Favouites items are managed different way, than Web shortcuts in launcher. i tested once again my solution and it is working. your folder is empty, because you probably did not add any web shortcut to launcher yet.

soson ( 2014-09-13 18:01:57 +0200 )edit

Question tools

Follow
3 followers

Stats

Asked: 2014-07-15 09:23:36 +0200

Seen: 535 times

Last updated: Sep 13 '14