Ask / Submit
19

Gallery shows portrait photos in landscape after 1.0.8.19 upgrade

asked 2014-07-20 13:49:08 +0300

Pesasa gravatar image

updated 2014-07-30 16:09:55 +0300

jiit gravatar image

The orientation of portrait photos taken after the upgrade is wrong in gallery. Both portrait and landscape photos are shown in landscape. The orientation metadata in exif is correct and photos are shown correctly with other software in my computer.

However this is only with new photos. Old photos are shown correctly. And the most strange thing is that some photos that were shown incorrectly right after taking, are now (5-6 days later) show correctly.

Additional detail: The gallery also does not show the title/filename of those new photos that it shows in incorrect orientation.

edit retag flag offensive close delete

Comments

1

I just looked at my gallery and all seems fine, I shot portrait oriented and went to gallery, and all portrait (new and old) photos looks fine to me...

magullo ( 2014-07-20 14:28:28 +0300 )edit

Now after reboot all photos taken before reboot are right way again, but new photos are landscape.

Pesasa ( 2014-07-20 14:32:43 +0300 )edit

I have also noticed that occasionally some pictures have wrong orientation on gallery, but that seems to be related wrong orientation data of the picture. Sometimes camera/orientation sensor on my Jolla get confused and set wrong orientation data to the pictures taken.

pata ( 2014-07-20 16:09:48 +0300 )edit

Same problem. Tahkalampi is riddled with bugs, I hope we get a hotfix soon

FinnishSushi ( 2014-07-20 16:51:43 +0300 )edit

Have the same problem... I didn't saw this thread and also opened similar one: https://together.jolla.com/question/52629/picture-rotated-automatically-why/

Schturman ( 2014-08-05 08:58:13 +0300 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2014-07-20 17:30:22 +0300

Pesasa gravatar image

updated 2014-07-20 17:31:02 +0300

Answering to myself.

It seems, that the orientation data is not red from the file itself but from some index. And the index didn't have it.

Rebooting or running tracker-control -es to re-index pictures helps.

Same as here: https://together.jolla.com/question/51215/pictures-are-not-shown-in-gallery-after-latest-release/

edit flag offensive delete publish link more

Comments

3

This does not solve the problem for me. Portraits are still the wrong way around. I've noticed that the camera app displayes the image correctly when after taking a picture you swipe left. Looking at the picture in that mode, the camera will actually flip the image 90 degrees after 1-2 seconds, after which it stays in the incorrect orientation.

2Ti ( 2014-07-29 16:49:11 +0300 )edit

Same problem, very annoying. Tracker-control -es does not fix it for me.

any updates are welcome.

fawz ( 2014-09-29 02:14:10 +0300 )edit

Any news on this? Still happenning to me in 1.1039!

okourkoulos ( 2014-11-27 15:40:15 +0300 )edit

Hello i have the same problem , when sending this image via email the landscape pictures are rotate to 180 degrees,

monkeyisland ( 2015-06-29 17:10:02 +0300 )edit

Still no solution to this problem?

magullo ( 2016-09-16 17:39:37 +0300 )edit
Login/Signup to Answer

Question tools

Follow
6 followers

Stats

Asked: 2014-07-20 13:49:08 +0300

Seen: 335 times

Last updated: Jul 20 '14