Ask / Submit
85

Beep-option for ringing

asked 2013-12-29 14:46:34 +0300

JiiHoo gravatar image

updated 2014-01-30 11:11:05 +0300

nephros gravatar image

N9 had three profiles which affected to ring-tone: ringing, beep and silent. Beep-profile caused N9 to discreetly beep once instead of ringing. Jolla/Sailfish has ringing and silence sounds options available for sounds/ringing, but beep-option is not existing.

Beep would be very practical in many cases, so it would be good have it "back" in Jolla. One possibility could be to add beep as option in Pulley-menu, similar to Silence sounds.

edit retag flag offensive close delete

Comments

1

This could be emulated by using an ambiance with all tones set to a suitable beeping-audio-file.

evk ( 2014-01-01 23:36:04 +0300 )edit

@evk Well, it is one possibility as a workaround. Though it seems that same image/photo can't be used in two different ambiances at the same time, would probably require creating a copy under different name first.

JiiHoo ( 2014-01-06 15:54:47 +0300 )edit
3

Using this workaround the phone would beep several times when ringing, not only once as wanted.

Seppo ( 2014-03-13 09:47:15 +0300 )edit
2

If the beep sound file has a long trailing silence it would take a while to loop.

vattuvarg ( 2016-08-15 18:01:37 +0300 )edit

So technically speaking the question should be read as 'how to play ringtone only once'. ngfdmight be another place to start finding one's luck. See this thread: https://together.jolla.com/question/83453/gui-for-configuring-non-graphical-feedback/

lakutalo ( 2016-08-16 11:15:10 +0300 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2016-08-15 17:45:08 +0300

cuh7b5 gravatar image

Another workaround is to store a beep sound file somewhere in your filesystem (e.g. /home/nemo/Music/Ringtones/Beep.mp3 ) and use dbus calls like these:

dbus-send --type=method_call --dest=com.nokia.profiled /com/nokia/profiled com.nokia.profiled.set_value string:"general" string:"voip.alert.tone" string:"/home/nemo/Music/Ringtones/Beep.mp3"
dbus-send --type=method_call --dest=com.nokia.profiled /com/nokia/profiled com.nokia.profiled.set_value string:"general" string:"ringing.alert.tone" string:"/home/nemo/Music/Ringtones/Beep.mp3"
dbus-send --type=method_call --dest=com.nokia.profiled /com/nokia/profiled com.nokia.profiled.set_value string:"general" string:"sms.alert.tone" string:"/home/nemo/Music/Ringtones/Beep.mp3"
dbus-send --type=method_call --dest=com.nokia.profiled /com/nokia/profiled com.nokia.profiled.set_value string:"general" string:"im.alert.tone" string:"/home/nemo/Music/Ringtones/Beep.mp3"
dbus-send --type=method_call --dest=com.nokia.profiled /com/nokia/profiled com.nokia.profiled.set_value string:"general" string:"email.alert.tone" string:"/home/nemo/Music/Ringtones/Beep.mp3"
dbus-send --type=method_call --dest=com.nokia.profiled /com/nokia/profiled com.nokia.profiled.set_value string:"general" string:"calendar.alert.tone" string:"/home/nemo/Music/Ringtones/Beep.mp3"
dbus-send --type=method_call --dest=com.nokia.profiled /com/nokia/profiled com.nokia.profiled.set_value string:"general" string:"clock.alert.tone" string:"/home/nemo/Music/Ringtones/Beep.mp3"

This unfortunately does not solve the problem that the beep ringtone will sound repeatedly instead of beeping only once. This is not implemented in Sailfish as I can see. I tried this:

dbus-send --type=method_call --dest=com.nokia.profiled /com/nokia/profiled com.nokia.profiled.set_value string:"general" string:"ringing.alert.type" string:"Beep"

But this has no effect. Someone more professional could investigate this problem.

If you want to revert to the original ringtone you can use the same method substituting the appropriate filename in /usr/share/sounds/jolla-ringtones/stereo/ , like this:

    dbus-send --type=method_call --dest=com.nokia.profiled /com/nokia/profiled com.nokia.profiled.set_value string:"general" string:"ringing.alert.tone" string:"/usr/share/sounds/jolla-ringtones/stereo/jolla-ringtone.ogg"
    dbus-send --type=method_call --dest=com.nokia.profiled /com/nokia/profiled com.nokia.profiled.set_value string:"general" string:"sms.alert.tone" string:"/usr/share/sounds/jolla-ringtones/stereo/jolla-messagetone.ogg"
etc...

Of course you can write a small shell script to change these values for you.

edit flag offensive delete publish link more

Comments

1

A workaround for the 'how to play ringtone only once' question: As root create a backup file and edit the file /usr/share/ngfd/events.d/ringtone.ini to turn off the repeat:

$ devel-su
# cp /usr/share/ngfd/events.d/ringtone.ini /usr/share/ngfd/events.d/ringtone.ini_bkp
# vi /usr/share/ngfd/events.d/ringtone.ini #or use your favorite editor

Change the line

sound.repeat     = true

to

sound.repeat     = false

Then restart the ngfd service:

# systemctl-user daemon-reload
# systemctl-user restart ngfd

If you want you can create a shell script to change to beep mode (see the ringtone change commands above) and to turn the sound.repeat off and vice versa. But then you need to run this script as root or grant privileges for your user to edit the ringtone.ini file and run the systemctl-user command. For the sake of simplicity I turned off sound.repeat and left it like that. It will beep only once if I use a beep tone and it will play the original ringtone only once, too. But the Jolla ringtone is ~1min long and I don't remember ever leaving an incoming call to reach the end of this music, so it does not bother me if it is not repeated at all.

Thanks to @lakutalo for the idea!

cuh7b5 ( 2016-08-17 14:19:37 +0300 )edit

You're welcome! This is what DIT is all about. Thanks for elaborating!

lakutalo ( 2016-08-17 14:49:20 +0300 )edit

After some testing i found a bug in this workaround. The backup of the ringtone.ini file made this solution unreliable. As the backup file is in the same directory as the modified ringtone.ini file it is interpreted to the daemon eliminating your changes. Please copy the file somewhere else, not under the /usr/share/ngfd/events.d/ directory. E.g. to create the backup file in your home directory the cp line should look like this:

$ cp /usr/share/ngfd/events.d/ringtone.ini /home/nemo/
cuh7b5 ( 2016-08-22 13:45:29 +0300 )edit
Login/Signup to Answer

Question tools

Follow
9 followers

Stats

Asked: 2013-12-29 14:46:34 +0300

Seen: 612 times

Last updated: Aug 15 '16