Ask / Submit
36

Jolla screen should not time-out while in USB developer mode

asked 2013-12-29 17:28:58 +0300

Mariusmssj gravatar image

updated 2014-07-18 13:37:16 +0300

kaltsi gravatar image

It's very annoying that you have to wake up the device every time you want to deploy code to the phone since if the screen is off it will not allow to deploy the code and I don't want to keep setting global screen time-out every time I want to develop for the phone. Android phones have an option to disable screen time-out when phone is in developer mode connected to the PC.

Or just add the possibility when application is deployed to wake up the phone automatically.

edit retag flag offensive close delete

Comments

N900 also keeps screen on if connected by USB to a power source.

MartinK ( 2013-12-29 18:31:39 +0300 )edit

possible workaround with mcetool you can find here: https://together.jolla.com/question/5029/bug-shaky-ssh-connection-via-wlan/#post-id-5179 but you are right it should be out of the box or at least a setting.

Kontio ( 2013-12-30 00:07:36 +0300 )edit

I've been playing around with mcetool as a deploy step.

Run custom command: /usr/sbin/mcetool -j enabled -U Deploy with rsync Run custom command /usr/sbin/mcetool -j disabled

But it'll only get me to the home screen, and I don't get the app maximized. And if rsync fails, it'll probably leave the blanking disabled.

evk ( 2014-01-08 19:40:17 +0300 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2014-05-20 10:49:18 +0300

evk gravatar image

Add a deploy step in your project settings (qtcreator). "Run custom remote command", with command line: /usr/sbin/mcetool -U; /usr/sbin/mcetool -m unlock

I have this after my rsync step.

(May not work if you lock the phone with PIN)

edit flag offensive delete publish link more

Comments

Thank you :)

Mariusmssj ( 2014-05-20 12:46:53 +0300 )edit
1

answered 2014-07-18 01:50:11 +0300

khnz gravatar image

Im using usb-moded and systemd to disable screen blanking in usb developer mode. Create the following files and restart usb-moded.

/etc/systemd/system/mcetool-alwayson.service

[Unit]
Description=disable screen blanking

[Service]
Type=oneshot
RemainAfterExit=true
ExecStart=/usr/sbin/mcetool -j enabled -U
ExecStop=/usr/sbin/mcetool -j disabled

/etc/usb-moded/run/alwayson-developer-mode.ini

[info]
name = mcetool-alwayson.service
mode = developer_mode
systemd = 1
edit flag offensive delete publish link more

Comments

killall -HUP usb_moded will cause it to reload the configuration too. Awesome idea!

Philippe De Swert ( 2014-07-18 13:33:37 +0300 )edit
Login/Signup to Answer

Question tools

Follow
5 followers

Stats

Asked: 2013-12-29 17:28:58 +0300

Seen: 531 times

Last updated: Jul 18 '14