Ask / Submit
8

Debugging in Mer VM does not start

asked 2013-12-30 19:26:07 +0200

epsilonijk gravatar image

updated 2014-01-10 21:08:35 +0200

lk gravatar image

When I try to start an application in the Mer VM debugger, it claims to start the debugger, there is a gdb process on the VM but it seems, Qt creator cannot connect, so it waits (forever?).

What can I do? The "free ports" check succeeds.

edit retag flag offensive close delete

Comments

Happening to me on OSX 1.8.4

rasjani ( 2013-12-31 11:43:14 +0200 )edit

1 Answer

Sort by » oldest newest most voted
4

answered 2014-01-02 19:09:59 +0200

kaltsi gravatar image

Debugging from Qt Creator with GDB is broken at the moment. It will be improved in upcoming SDK releases.

You can log in to the device with ssh and run gdb there on the command line.

edit flag offensive delete publish link more

Comments

1

Any idea when next SDK release is scheduled?

mholo65 ( 2014-01-06 23:25:57 +0200 )edit

Sorry, no there's no set time for the next release. We can do minor updates to fix low-hanging fruit type bugs or omissions on the short term, but unfortunately fixing the gdb debugging is not a very simple fix and we'll probably need a bigger release to fix that.

kaltsi ( 2014-01-07 13:22:43 +0200 )edit
1

This is a major bug for an upcoming mobile platform. Sailfish needs native applications from professional developers. For professionals time means money and a not working IDE supported debugger is really expensive. You should try to fix it as soon as possible.

barmeier ( 2014-01-12 15:04:58 +0200 )edit
1

Understood. Working debugger is on our priority list.

kaltsi ( 2014-01-12 15:48:09 +0200 )edit

Stumbled upon this problem today and I am happy that it was heard, understood and is on the list!

hardcodes.de ( 2014-01-18 18:40:53 +0200 )edit
Login/Signup to Answer

Question tools

Follow
5 followers

Stats

Asked: 2013-12-30 19:26:07 +0200

Seen: 282 times

Last updated: Jan 02 '14