Ask / Submit
13

Media player trough carkit (handsfree)not working

asked 2013-12-25 03:31:22 +0200

Miki gravatar image

updated 2014-01-08 23:27:58 +0200

Jan Wellmann gravatar image

Hi Sailors, I use handsfree a lot and that is working ok in my Renault Megane with integrated handsfree bluetooth carkit. But if i turn on video for example or music player, audio stays on Jolla and it is not transfered to my car speakers trough bluetooth... I have had this possibility on all my Nokia's (symbian and wp) and Android phones are working as well... Would be nice if it is possible to implement this... Thank you

edit retag flag offensive close delete

Comments

I don't have this problen, mine streams audio with no problems, I would prefere though that contacts are reachable via carkit

teun ( 2013-12-25 09:27:53 +0200 )edit

My comment is not answer to your problem per se, but similar bt-issue question: https://together.jolla.com/question/274/pbap-bluetooth-profile-support-is-requested/

What is important over there is, that Jolla staff member has answered to question over there..

LaruX ( 2013-12-26 22:56:03 +0200 )edit

Thanx LaruX for pointing it out.

Miki ( 2013-12-26 23:09:43 +0200 )edit

Works perfectly with my mercedes mid range head unit. It never did with its galactic predecessors. Seems to be rocket science and/or too many parties involved.

Aequanix ( 2013-12-27 18:52:17 +0200 )edit

Similar issue with GOgroove FlexSMART X2. In my case it may have to do with the warning message about "loud music can harm your ears", which seems to interrupt the connection process. After several attempts I can get sound to play through bluetooth, but it is really cumbersome.

StaticNoiseLog ( 2014-02-02 18:18:19 +0200 )edit

2 Answers

Sort by » oldest newest most voted
3

answered 2013-12-26 02:07:28 +0200

Jan Wellmann gravatar image

Hej Miki, I experienced similar problems, but they seem to be quite random. First, the connection to the BT-Handsfree-kit (Dension BT-Gateway on Car-Side, booth simple handsfree and hq audio-streaming) is recovered/reactivated most of the time when I reenter the car. Using the handsfree-function is no problem, seems to work anytime a pick up a call. Listening to music is difficult: I often have to restart the Media-Player several times untill audio is routed to bluetooth. Then, the selected protocol/profile is often HSP (Head-Set-Profile), which results in poor music-reproduction. A2DP is choosen only sometimes, more often after rebooting sailfish and manual reconnect to the car-kit. Other phones (N9,...) work flawless. This is more a bug-report than a feature-request...

edit flag offensive delete publish link more

Comments

Thanx for info Jan... :)

Miki ( 2013-12-26 23:07:45 +0200 )edit
1

@Jan Wellmann I have the same experience with Parrot MKi9100. After a Jolla reboot the BT audio works well and I can even conrol the media player from the carkit. Next time I come to my car the BT audio is mostly not working anymore while calls can be made and received without problems.

strnous ( 2014-01-06 23:12:54 +0200 )edit

@strnous@Miki I think, there is a way to restart the bt-service without having to reboot the whole phone:

    >> devel-su
>> systemctl restart bluetooth.service

Worked quite well for me.

Jan Wellmann ( 2014-01-08 23:13:04 +0200 )edit

It's not working for me :( I have a Volvo C30. Only audio files seems to sync right (that's what my Aqua Fish also mentioned "Audio connection" in the Bluetooth menu). I can make an receive calls true my carkit but everything is running double; the person on the other side is hearing me twice with delay. I presume that the carkit is not disabling my phone. Also the phonebook of my car stays empty. If somebody knows a workaround, please let me know, much appreciated. Hand free calling is a must and would be a step backwards if it's not working.

Dimi ( 2016-09-16 18:57:29 +0200 )edit
0

answered 2014-01-09 09:58:56 +0200

Jan Wellmann gravatar image

With the hints @trashin provided in https://together.jolla.com/question/12121/bug-bluetooth-sleeppower-states/ I could track this bug a bit.

  1. HSP/A2DP Profiles seems to be choosen correctly when the Jolla is awake when reconnecting to the car kit. So its likely a wake-up issue as suggested by trashin.
  2. If the carkit is switched of while the media-player is still running (pretty standard I guess), the audio-output of the media-player is sometimes rerouted to the Jollas speakers or stucked in an indifinit state (the player will not start playing tracks at all, time stucks at 0:00). Only switching booth bluetooth on/off (or restarting the service) while the media-player is closed seems to re-enable audio. If the player finds a valid bluetooth device after restart, it will route audio to bt.

Hope this helps.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2013-12-25 03:31:22 +0200

Seen: 2,668 times

Last updated: Jan 09 '14