Ask / Submit
3

[bug] Silent mode automatically disabled when opening settings app

asked 2015-09-30 19:33:28 +0300

Fuzzillogic gravatar image

I'm using Pebbled, which automatically enables the silent profile when the watch is connected. However, whenever I open the Jolla's settings app, the silent mode is automatically (and unwanted) disabled immediately. Pebbled uses DBus to switch to Silent profile. Seems fine to me.

This behavior is since SailfishOS 1.1.9.28.

Expected result: settings app should not interfere with selected silent mode.

edit retag flag offensive close delete

Comments

Have you filed a bug in the pebble github, maybe they can find a fix for this. I'll test it with my Pebble tomorrow and report if I can/can't reproduce the bug.

raketti ( 2015-09-30 20:50:28 +0300 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2015-09-30 20:23:45 +0300

Ancelad gravatar image

Try this patch, it should fix your problem https://openrepos.net/content/ancelad/patch-return-profile-control-lockscreen

edit flag offensive delete publish link more

Comments

Thanks, useful patch, but it does not fix the problem.

[edit] Huh. It does fix the problem! With the patch applied, I can't reproduce the issue. When I unapply the patch, the problem is back. So, simply applying your patch is a useful work around, and might give a good clue on what's going on.

Fuzzillogic ( 2015-09-30 20:30:38 +0300 )edit

The Jolla sailors should really pay attention to the surge in patches after 1.1.9.x...

Tanghus ( 2015-10-01 04:52:59 +0300 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2015-09-30 19:33:28 +0300

Seen: 175 times

Last updated: Sep 30 '15