Ask / Submit
48

[Bug] Accidental unlocks and pocket dialing --> [Feature req] Disable touch screen and pwrbtn when proximity is detected

asked 2014-01-07 01:01:01 +0300

CsTom gravatar image

updated 2016-08-22 09:49:50 +0300

J24 gravatar image

It has happened to me several (more than a few) times that my Jolla just went amok in my jeans' front pocket (screen facing inside, phone is upside down). It is very annoying when random people (random dialled number) shouting out of your pocket. Better (also happened) when "only" the recent calls gets redialled, at least I know who they were :-|

According to Builder in this question the proximity sensor should prevent this, yet this is happening. I cannot put my Jolla into the usual pocket anymore, because I can't trust it will stay put. Apparently make had very similar problem; however I wouldn't limit the solution just to prevent emergency dialing, but I'd really like to have a reliable lock on Jolla.

As for the question part: Is the proximity sensor in use after all (and if not, why not?) or was it just Builder's wishful thinking?

Update: apparently the proximity sensor is used only to block the double-tap gesture, but all other controls work even when the screen is covered (including power key and the touch screen itself).

Feature request: disable touch screen when proximity is detected. It is also useful for not accidentaly hanging up by ear... (for bonus point: disable power key as well when proximity is detected)

Related (duplicate?): Lockscreen too sensitive? Jolla writing pocket messages

edit retag flag offensive close delete

Comments

For the "accidental unlock" part, see this. The problem should be corrected with an UI tweak without needing the proximity sensor.

idiallo ( 2014-01-07 01:11:17 +0300 )edit
5

Well, that would probably prevent accidental redialling from the recent call list after the phone already accidetally unlocked itself.

I'd rather (or additionally) want to have a (much more) reliable lock. (as the phone can do other stuff as well, not only dial someone. Edit/remove contacts, send messages, etc [all of these already happened to me :/ ])

CsTom ( 2014-01-07 01:15:24 +0300 )edit
2

i have witnessed the phone to have a slight lock-flaw when using the swipe-gesture to lock it... sometimes it rewakes after a second or so... i haven't found out what causes it so far... have you checked if your device just rewakes before you actually put it in your pocket?

egnat69 ( 2014-01-07 10:24:19 +0300 )edit
6

Hmm. No I haven't checked, after I locked it I put it into pocket. However, IMHO, the phone should not do anything when the proximity sensor is covered (even if unlocked)

CsTom ( 2014-01-07 10:34:31 +0300 )edit
5

Just tested this by putting the phone in the pouch with the proximity sensor first. I was not able to unlock it with the double tap while the sensor was still covered. BUT, the power button could be pressed to enable the screen. Still it's hard to accidentally unlock it from the lock screen as it would need a long swipe. Maybe you unlocked it accidentally by the shorter swipe to the pulley menu, opening the phone app there, and pocket-dialed a recent number. This pulley menu seems dangerous.

pycage ( 2014-01-07 22:48:23 +0300 )edit

5 Answers

Sort by » oldest newest most voted
6

answered 2014-06-11 16:02:14 +0300

spiiroin gravatar image

updated 2016-08-22 09:46:44 +0300

J24 gravatar image

There are no plans to disable touch input when proximity sensor is covered (it would easily hinder things like "swipe from top to lock" gestures etc).

However touch input is blocked if touch is detected when display is powered up, i.e. if you put finger/palm on screen while it is off and then use the power key -> ui does not get input until the finger/palm is lifted from screen. While not perfect, this should make it less likely to have accidental input go through.

And, while there is no settings ui for this, you can disable power key when proximity sensor is covered from command line via

  • mcetool --set-powerkey-action=proximity

The normal operation can be restored via

  • mcetool --set-powerkey-action=always

And just for symmetry there is complete disable too:

  • mcetool --set-powerkey-action=never

(settings are preserved over reboots, mcetool can be installed via: pkcon install mce-tools)

edit flag offensive delete publish link more

Comments

I am asking for people to unlock my phone. To show them how easy it is just with dooble tap. But they press the unlock button. >.<

* mcetool --set-powerkey-action=never, is there any way that I can enable only the function to turn the phone off? Or is ti only from Terminal/app possible?

Thx!

TK ( 2014-06-11 16:27:35 +0300 )edit
1

@TK: Normally power key is handled by mce (with some ties to ui side) and powerkey-action=never disables also shutdown via power key.

However, there is emergency fallback (in case ui and/or mce have gone bonkers) that can be used - if you press the power key long enough (>5 seconds), dsme will initiate shutdown (unless there is an ongoing emergency call).

spiiroin ( 2014-06-11 17:01:10 +0300 )edit

PERFECT!!! :D

TK ( 2014-06-11 18:55:31 +0300 )edit

"if you put finger/palm on screen while it is off and then use the power key -> ui does not get input until the finger/palm is lifted from screen." <--- could not reproduce this behaviour on Jolla C.

Steps: 1) turn the screen off. 2) put a finger on the screen. 3) press power button to turn the screen on. 4) slide the finger down. -> Pulley menu is activated.

J24 ( 2016-08-22 09:01:11 +0300 )edit

I never had this problem with my Jolla 1, but it's giving me a real headache now with my new Jolla C. I was assuming this was a new issue with the early release updates (2.0.2.43 and --48), but it seems this is an old issue resurfacing. Pocket dialing would actually be preferable to all the shenanigans this gets up to on its own in my pocket (pocket Facebook posting...)

Pände ( 2016-08-22 11:20:05 +0300 )edit
2

answered 2014-11-06 15:48:26 +0300

nthn gravatar image

Disabling touch input when the sensor is covered is planned to be released in update10: https://lists.sailfishos.org/pipermail/devel/2014-November/005168.html

"Since this also means any proximity sensor faults will render the device practically unusable, it will be possible to temporarily disable proximity sensor by triple power key press."

edit flag offensive delete publish link more
1

answered 2016-12-02 17:09:23 +0300

inta gravatar image

updated 2016-12-02 17:11:29 +0300

The accidental unlocks are (now) a serius issue for me. I think the problem arised since the phone can be woken up not only by double tap but also by swipe. Within the last few weeks my phone did an emergency call 2 times while it was locked and in my pocket. It is extremly unpleasant if you have to explain why you just did an emergency call without any reason.

Most time this happens I have got my phone in the front pocket, screen facing towards my leg and walking for a longer distance. Sadly it is not easy to track those problem closer – sometimes it happens, sometimes not.

Any Ideas? At least with the first few SFOS 2 versions I had no problem like this.

edit flag offensive delete publish link more

Comments

I did not even know that we can unblank the phone by swipe. Is there a way to disable that? I never use this feature (as I did not even know about it). It might be the a possible cause of unintended unlocks (i.e. when I put my locked device in my pocket, it may touch my trousers and give a swipe action to unlock).

cuh7b5 ( 2017-06-27 18:00:44 +0300 )edit
0

answered 2014-02-12 14:12:53 +0300

chemist gravatar image

updated 2014-02-13 14:45:35 +0300

Touchscreen is disabled with proximity sensor being covered (display in standby). (WFM)

So open is

  • Deactivate power-btn if screen is turned off and proximity sensor is covered.
edit flag offensive delete publish link more

Comments

No it is not.

Check @Mohjive comment on the question: "the proximity sensor DOES indeed lock the screen from all touch input, but only if covered quick enough. Slower movement to cover the sensor makes it not react to lock touch input. The sensor shouldn't react to movement, but to actual absolute distance."

This is the case still in 1.0.3.8.

CsTom ( 2014-02-13 13:05:33 +0300 )edit

Please share a video of what you do, I cannot reproduce this behaviour.

chemist ( 2014-02-13 14:39:16 +0300 )edit
1

Hopefully you can access this. The touch is disabled only 2 times out of 5 coverings...

CsTom ( 2014-02-13 15:20:09 +0300 )edit

@CsTom mate you are on the wrong page here, I am talking about devices in standby, display off - I guess what is working for you is that your finger touches the touch-screen an does not recognize your second finger pulling therefore - the proximity sensor must not deactivate the touchscreen while on lock-screen and that is working like expected^^

chemist ( 2014-02-13 16:04:28 +0300 )edit
2

@chemist: read the thread more carefully :) The problem starts with standby. Pocket. Then the powerkey is pressed. It happens in the pocket. At this point we're at the beginning of the video: proximity sensor is covered (remember: pocket), yet the touchpanel works, unlocks and all hell gets loose.

Once more: when proximity sensor is covered, the touch should not be active at all.

CsTom ( 2014-02-13 16:31:36 +0300 )edit
0

answered 2014-02-12 14:25:16 +0300

Macilaci457 gravatar image

In dark environments the proximity sensor may detect it is "in-pocket". I assume this because double tap wake-up often fails in a blind dark room. In this case, if the PWR button is also disabled, it would be no way to wake up the device.

edit flag offensive delete publish link more

Comments

1

that does more sound like "device does not unlock from double-tap, sometimes", I just went to a blackroom and tried WFM

chemist ( 2014-02-12 18:13:43 +0300 )edit
Login/Signup to Answer

Question tools

Follow
8 followers

Stats

Asked: 2014-01-07 01:01:01 +0300

Seen: 2,878 times

Last updated: Dec 02 '16