Ask / Submit
41

Manage Calendars does not show all calendars and their sources

asked 2013-12-25 18:58:27 +0200

Joyce gravatar image

updated 2014-08-04 22:46:02 +0200

ssahla gravatar image

My family and I share calendars. I therefore have a lot of Calendars. (Outlook, MfE) When I access the 'Manage Calendars' screen, I do not see all calendars and I cannot scroll down to see the rest.

Edit (by @ssahla): The scroll bug is fixed, but the calendar still doesn't show which account each calendar is coming from. This really is annoying and should be fixed.

edit retag flag offensive close delete

Comments

same issue here

Xowap ( 2013-12-29 14:55:38 +0200 )edit

Reason for edit: renamed the question title to reflect the issue(s) and answers discussed here..

foss4ever ( 2013-12-31 01:16:10 +0200 )edit

same here, very annoying, as the calendar app is unusable for me: i see all my colleagues' diaries :/

cartron ( 2014-01-02 10:23:14 +0200 )edit

3 Answers

Sort by » oldest newest most voted
8

answered 2013-12-28 09:24:16 +0200

simo gravatar image

A must do: Add scrolling to the calendar list. Additionally, please add a small icon indicating where the calendar is from (I have 2 caledars called Default)

edit flag offensive delete publish link more

Comments

Definitely a remark of the calendar origin is needed. I.e while using two mail accounts of the same type (Zimbra in my case) causes same calendar names appear multiple times one from each account.

strnous ( 2013-12-28 09:59:25 +0200 )edit

Yeah, calendars must show their origin in the scroller :)

aleksih ( 2013-12-29 00:10:14 +0200 )edit
2

answered 2013-12-28 21:18:17 +0200

eber42 gravatar image

As a very quick & dirty workaround before an official fix is out, you can edit the calendar application configuration file (~/.config/nemo/nemo-qml-plugin-calendar.conf) by hand.

Add a line "<id>=true" for each calendar ID you want to hide from the calendar app. IDs can be found in the "CalendarId" columns in "calendars" table in ~/.local/share/system/privileged/Calendar/mkcal/db and other columns provide enough context information (name and account). This requires root access.

edit flag offensive delete publish link more

Comments

Thanks. Is there by any chance more configuration options? Is it possible to select one of the calendars to be the default one where the events are created?

tjp ( 2013-12-31 11:12:42 +0200 )edit

I thought this question was about problems caused by not seeing all calendars and their sources, and not to trying to hide them ;)

foss4ever ( 2014-01-02 10:32:00 +0200 )edit
0

answered 2014-02-01 00:10:01 +0200

nodevel gravatar image

updated 2014-02-01 00:11:35 +0200

Scrolling in the calendar list is now fixed in 1.0.3.8.

Sources still not recognizable though.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
8 followers

Stats

Asked: 2013-12-25 18:58:27 +0200

Seen: 515 times

Last updated: Aug 04 '14