Ask / Submit
18

Phone looses data connection when switching from wifi to mobile network.

asked 2017-03-01 22:32:08 +0300

pawel gravatar image

updated 2017-09-19 05:04:07 +0300

DarkTuring gravatar image

In addition to case below with Intex Aquafish 2.1.0.11 and running beta 2.1.1.26 after wifi disconnect the phone is soetimes incapable of connecting to mobile data, even though its available and seemingly connected to 4G.

The only thing that helps is in Utilities selecting restart network which likely restarts ofono. Why doesnt SFOS just force a network restart when connected and receiving Wifi connection drops, that would be a lot less painful for users and i dont mind waiting 5seconds compared to fiddling for tens of minutes with turning wifi off, mobile off and on, switching airplane mode etc.? This issue has not been resolved as of 2.1.1.26.


There are a few apps that do loose the connection when the phone switches the 'connection provider' from wifi to mobile network and back. one of those is i.e. together jolla app. harbour is another. sailorgram does not have this issue.

now you might say: this is the responsibility of the app dev, but i think that an app should not need to deal with such a basic thing like, where does my data come from.

thats why i did enter this issue here in.

edit retag flag offensive close delete

Comments

1

I understand it would make it easier for the users if the swap would be seemless, but I also understand the loosing of connection since it might seem as some kind of session hijack or man in the middle attack attempt to the service if the ip and hostname provided by your mobile service provider suddently changes to your home/work/school wlan isp's ones but the tokens stay the same...

avhakola ( 2017-03-01 23:25:46 +0300 )edit
1

This bug exists in my OpenRepos app Rush hour also. The connection to network is through QtQuick.XmlListModel 2.0. I'm using Jolla C and Iijoki 2.1.0.11

Rikujolla ( 2017-04-23 10:30:25 +0300 )edit

I can't reproduce it in Sailfinder which uses Python for it's requests. I build an autoconnect function directly on ConnMan so it seems that ConnMan is working OK?

Dylan Van Assche ( 2017-04-25 09:55:16 +0300 )edit

4 Answers

Sort by » oldest newest most voted
7

answered 2017-04-24 12:06:25 +0300

slava gravatar image

Here are some details about this issue for those who are interested: https://lists.sailfishos.org/pipermail/devel/2017-April/007869.html (sorry, no solution yet)

edit flag offensive delete publish link more

Comments

1

thanks for the info

pawel ( 2017-04-24 16:17:42 +0300 )edit
1

answered 2017-04-22 18:28:24 +0300

Heipa gravatar image

The same or similar problem on my Jolla I.
Since Ver. 2.1.0.11 some applications loose network from time to time especially after changing network method from WLAN to Mobile or back. I mean WLAN OFF and mobile network ON and vice versa. This concerns e.g. the stock weather app in events view and Threema messenger. Example: Weather in events view reports "No network available" while browser is working properly.
Killing the process and restarting it again seems to be a workaround for Threema. For the weather "widget" works restart network connections or restart home screen.

edit flag offensive delete publish link more

Comments

1

I'm having similar connection loss problem with EAS, though it happens even when roaming from one wifi ap to another. Using JollaC-ified Aqua Fish.

twi42 ( 2017-04-23 22:57:19 +0300 )edit
1

answered 2017-04-24 23:29:50 +0300

llornkcor gravatar image

Connection migration is not going to be seemless, i.e. your connection will break when going from one connection type to another like mobile -> wifi. In other words, a data stream like internet radio, will disconnect. This is up to the app to try to reconnect to the stream once the device has reconnected to the network.

That said, if configured to do so, the device should connect to the network. There are some issues with QNetworkAccessManager and networkAccessibility() which may be one issue. See https://codereview.qt-project.org/#/c/191370/

Another issue may be connman itself not re-establishing a connection. It seems particular troublesome when either wifi or mobile signal is weak.

Sorry I cannot really answer your problem, only try to explain it. While I was working for Jolla, we tried everything in our power to overcome the complicated networking issues.

edit flag offensive delete publish link more
1

answered 2019-01-23 14:31:43 +0300

Spark gravatar image

It seems Sailfish 3.0.1.11 solved this issue for me. Threema now only has a short disconnect when switching from wifi to mobile network now, then reconnects AND is able to send and receive messages.

Until now I always had to restart aliendalvik.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
5 followers

Stats

Asked: 2017-03-01 22:32:08 +0300

Seen: 810 times

Last updated: Jan 23