We have moved to a new Sailfish OS Forum. Please start new discussions there.

transfer files (photos)

asked 2013-12-25 20:27:12 +0300

naitsirhc gravatar image

updated 2014-01-20 12:58:51 +0300

lk gravatar image

Hi I can't find any way to transfer my Jolla photos to a Mac... Easiest would be Bluetooth, and I already paired Jolla and Mac, when sending a file from the Mac to the Jolla. But there seems to be no way of sending with BT from the Jolla. Choosing a photo in the Jolla gallery only gives me the option to delete it, but not to send it. In the BT menu there's no "send" option, either.

Connecting the phone with USB enables me to transfer the preinstalled images of the Jolla crew - but my own photos are not found by iphoto! Strangely enough, the Jolla (armv7hl) only appears as connected in iphoto, but not at all in the Finder...

edit retag flag offensive close delete

3 Answers

Sort by » oldest newest most voted

answered 2013-12-25 20:41:10 +0300

pnuu gravatar image

Over bluetooth it's currently possible to transfer images one by one: open Gallery, open the image you want to transfer, click on the image and select "Bluetooth share" above the image.

To copy all the images, I'd use scp. This needs the Developer mode enabled (Settings -> System settings -> Developer mode), and the Remote connection checked, then set a password. Then make a connection with the phone to a WLAN access point. After connection is established, take not of the IP address your phone receives, open a terminal on your laptop and issue the following command to copy the images to a folder Jolla_Pictures:

scp -r nemo@<ip-address-from-the-settings>:/home/nemo/Pictures/ Jolla_Pictures

I don't know if it's possible to connect via USB with ssh from Mac, but I find WLAN anyway more flexible option.

edit flag offensive delete publish link more


Or do it other way around, as I just did, by opening terminal within Jolla and type: scp -r /home/nemo/Pictures username@yourserver.com:folder/

Ragnar Kurm ( 2016-09-23 17:16:54 +0300 )edit

answered 2013-12-25 21:04:05 +0300

pcfe gravatar image

Try this;

  1. enter gallery
  2. tap preview of pictue to view pic (in the overview you get 'delete' on long press)
  3. tap picture once, a menu should come up in the upper half of the screen (with 3 navigation dots)
  4. select Bluetooth Share
  5. select your Mac
edit flag offensive delete publish link more

answered 2013-12-25 20:46:48 +0300

naitsirhc gravatar image

Hi, Thanks for the answer, in fact I always pressed the photo too long... I never saw the BLuetooth share option, only "delete". Now I tried again, and I got it... For the WLAN sharing, maybe I'll try that later.

edit flag offensive delete publish link more


Please accept one of the answers (round "check" symbol below the voting system) to mark the issue resolved.

pnuu ( 2013-12-25 21:35:21 +0300 )edit
Login/Signup to Answer

Question tools



Asked: 2013-12-25 20:27:12 +0300

Seen: 804 times

Last updated: Dec 25 '13