Bug: Audio/Video desync when watching videos locally

asked 2014-01-19 02:21:31 +0300

typo gravatar image

updated 2014-01-27 19:30:49 +0300

There seems to be a small issue with AV-sync in Jolla. I have tried with multiple different file formats, codecs, file sizes, durations, bitrates, video players etc. I have also tried with and without file conversion before transferring them to the phone but to no avail; audio always lags something like 0.3 seconds behind. That's a big enough difference to make watching videos on the phone rather annoying.

I haven't noticed anything similar when streaming videos over the net e.g. with Netflix; this only seems to apply to video files stored locally on the device. I have also tried with multiple different video players (Jolla's own media player, VLC and LLs Video Player so far), and the same applies to all of them.

Here's detailed information (extracted with MediaInfo) about the combinations I've tried so far:

Video file 1:

Video: MPEG-4 Visual, Advanced Simple@L5, Default (H.263), XVID, 23.976fps
Audio: 128kbps 48kHz mp3
Duration: 54min 51sec
Overall bitrate: 1396 Kbps (variable)

Video file 2:

Video: MPEG-4 Visual, Default (H.263), DX50 (DivX 5), 25fps
Audio: 128kbps 44.1kHz mp3
Duration: 23mn 56sec
Overall bitrate: 1055kbps

Video file 3:

Video: MPEG-4 Visual, DIV3 (DivX 3 Low), 23.976fps
Audio: 128kbps 48kHz mp3
Duration: 24min 29sec
Overall bitrate: 802kbps

Video file 4:

Video: AVC, High@L4.1, V_MPEG4/ISO/AVC, 23.976fps
Audio: 384kbps 48kHz AC-3
Duration: 43min 18sec
Overall bitrate: 5100kbps

As a positive sidenote, there wasn't any major difference in the playback of that last file, compared to the other ones.

I will be happy to provide any further information regarding the video files if requested.

edit retag flag offensive close delete

Comments

I didn't even know Jolla can play Xvid or DivX videos?

hana ( 2014-01-19 03:01:53 +0300 )edit

Information in the manual is a bit sparse at present and hopefully will become more comprehensive.

Richard

richardski ( 2014-01-19 03:18:10 +0300 )edit

Audio sync in Android was all over the place before Maadajävri. That update seems to have fixed it in most apps I use (Opera, Viral, YouTube). In the native players I've had no sync issues with H.264/AAC files.

hana ( 2014-01-19 12:42:31 +0300 )edit