We have moved to a new Sailfish OS Forum. Please start new discussions there.
1

Removing music album pics from the gallery

asked 2019-01-02 12:46:03 +0300

ApB gravatar image

I know this bug is supposed to be fixed but i still get the photos of the music albums (stored in the SD card) in the gallery.

I reset the tracker and they still show up. Is there something else i can do.

edit retag flag offensive close delete

Comments

1

Ideally, the artwork needs to be embedded into the tracks/album, then it should not show in Gallery.

Spam Hunter ( 2019-01-02 12:48:11 +0300 )edit

1 Answer

Sort by » oldest newest most voted
7

answered 2019-01-02 13:03:33 +0300

Andy Branson gravatar image

updated 2019-01-02 13:04:07 +0300

What are your album art filenames? Tracker now ignores these:

'Folder.jp*', 'Folder.png', 'Folder.gif', 'cover.jp*', 'cover.png', 'cover.gif', 'AlbumArt*.*'

So if you're using another filename, add it to the org.freedesktop.Tracker.Miner.Files ignored-files key in gsettings. Otherwise check that key to see if you might need to rerun the tracker-configs.sh oneshot.

edit flag offensive delete publish link more

Comments

Nice one, thanks for the tip!

Spam Hunter ( 2019-01-02 13:20:53 +0300 )edit

Some are folder.jpg (lower case f), some are Cover.jpg (upper case C). Need to check more.

ApB ( 2019-01-02 19:09:45 +0300 )edit

Renaming stuff fixed it although i believe the way this is handles should be a bit smarter.

Anyway you can add lower case folder, upper case cover, album name.jp, artist name - album name.jp etc to the ignored files.

ApB ( 2019-01-02 19:59:05 +0300 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2019-01-02 12:46:03 +0300

Seen: 248 times

Last updated: Jan 02 '19