Ask / Submit
2

store repository authentication

asked 2019-01-15 15:55:06 +0300

yoram gravatar image

updated 2019-01-15 19:19:50 +0300

Edz gravatar image

hello any access to store-repository.jolla.com stopped working for me, ether via store-client, system update or directly with pkcon/zypper

when using zypper ref, it reports authentication error for each store-repository.jolla.com repo. I do have jolla account and it worked before. ssu register ask for credentials and then reports authentication required

edit retag flag offensive close delete

Comments

Seems like it was down for a.moment but works again..

japsi ( 2019-01-15 16:03:37 +0300 )edit

sorry but the problem is persistent

yorambh ( 2019-01-15 16:08:02 +0300 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2019-02-02 16:55:47 +0300

jayki gravatar image

updated 2019-02-02 16:57:09 +0300

Please check if you have lpr_next repository enabled and installed glibc 2.23 from there.

Check with: pkcon search glibc | grep Installed

if you have please downgrade it to jollas version or update it to 2.25.6+git1 ( available at lpr_next, too, so a pkcon refresh and pkcon update should help, if not try pkcon install glibc. and if that also does not install it, you can try version --dup.)

The Problem is described here: https://together.jolla.com/question/129740/do-we-get-a-fix-for-glibc-security-issues/?answer=185358#post-id-185358 Updating to glibc2-25 solved all problems!

edit flag offensive delete publish link more

Comments

Indeed, upgrading glibc seems to solve the problem

yoram ( 2019-02-02 18:53:58 +0300 )edit

Yes, it worked, thank you. I had the same situation some weeks ago and reinstalled the Jolla libs, but this time I didn't even notice, that glibc was updated somehow. Thanks again.

TrulloF ( 2019-02-03 15:04:39 +0300 )edit
0

answered 2019-01-16 09:16:10 +0300

xfade gravatar image

There was a problem after a configuration change yesterday. It should not have lasted longer than an hour or so (intermittently). Does it work for you now?

You should not use ssu as that is for internal releases only.

edit flag offensive delete publish link more

Comments

1

Still cant access store-repository.jolla.com by any method

yorambh ( 2019-01-16 11:56:07 +0300 )edit

Still broken here.. for weeks :( Zypper complains with:

Error building the cache:
[store|plugin:/ssu?repo=store] Valid metadata not found at specified URL
jayki ( 2019-01-29 15:01:05 +0300 )edit

same here. no access to store or adaptation repositories

yoram ( 2019-01-30 16:07:35 +0300 )edit

I'd suggest to:

Go to Settings -> Accounts -> Jolla Account - Delete account and then: + Add account -> Jolla -> 'I have a Jolla account' and fill in the next steps.

This will remove the account and repository settings and re-create them.

xfade ( 2019-01-30 16:23:10 +0300 )edit
1

I have done that many times....

yoram ( 2019-01-30 16:39:06 +0300 )edit
Login/Signup to Answer

Question tools

Follow
5 followers

Stats

Asked: 2019-01-15 15:55:06 +0300

Seen: 394 times

Last updated: Feb 02