Ask / Submit
6

[XA2][3.0.3.9] Android support unstable + battery drain

asked 2019-05-27 18:28:28 +0300

lasselin gravatar image

On an Xperia XA2 Plus, with SailfishOS Hossa, the Android support is very unstable. Firefox Lite, Quickdic or OsmAnd~ freeze after only some seconds (less than a minute). When Android support is activate (with ou wthout wlan, with or without 4G, with or without BT), the CPU usage is very high (50% or 100%) making the power consumption very high.

When I received this phone I used it several days before switching sim-card and data. Android support was stable. I did the upgrade to 3.0.3.9. I exported my data with the Sailfish backup feature and I loaded the backup in the XA2. The jolla account in the backup was not the one attached to the Sailfisf Beta licence - I put the correct account back. Now, Android support is unstable. I uninstall / re-install Android support : no change.

It's not possible to use any Android app. Is there something I can do to solve or hlep solving that issue ?

edit retag flag offensive close delete

Comments

At least I can't confirm the behaviour yoj describe, especially I do not experience any battery drain or instabilities with Android support. Are you sure you do not experience a hw issue?

Kobold ( 2019-05-27 20:06:39 +0300 )edit

It doesn't seem. The batterry drain only appears when Android support is ON. When I turn it OFF, the CPU turn back close to 0%.

lasselin ( 2019-05-27 23:12:58 +0300 )edit

Stability is indeed something the Android support needs to be improved on, apps tend to crash and quite often the GUI gets mixed up and even a little tap on the screen is interpreted ass "long press", sometimes touch does not seem to be detected at all. I have seen the battery drain only once, it was gone after reboot.

kkarioja ( 2019-05-28 09:28:14 +0300 )edit

I have the same issue. Android support seems to restart every few minutes. This is on an XA2

avanhel ( 2019-07-03 14:59:49 +0300 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-07-12 09:11:18 +0300

Hi Iasselin After what work, I found a solution that works for me at the moment.

I followed instructions in this link to compleetly remove android. After I installed the android support again, Sailfish acted better. I still have some crashes but the drain is no longer as bad.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2019-05-27 18:28:28 +0300

Seen: 415 times

Last updated: Jul 12